1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Actualizações automáticas e vbshost.exe

Discussão em 'Windows 7 e anteriores' iniciada por ribamar, 26 de Fevereiro de 2009. (Respostas: 8; Visualizações: 781)

  1. ribamar

    ribamar Power Member

    Ora bem! Tenho o avira antivir instalado e este reconheceu-me um trojan de nome vbshost.exe ( acho que não tem relação com o vshost.exe do Visual Studio 2005 ), no momento que isso aconteceu as actualizações automáticas ficaram desligadas, e fui informado disso. O problema é que nas opções das actualizações automáticas estas encontram-se ligadas (na opção recomendado).

    -Tou a usar o XP SP3
    -O símbolo vermelho de alertas de segurança está na taskbar
    -No centro de segurança as actualizações automáticas estão desligadas, mesmo estando seleccionado ligadas nas suas opções
    -Não consigo reparar o vbshost.exe (...nem sei se é do windows, mas está na pasta system)

    -Numa procura rápida no fórum e google não consigo encontrar nada a respeito do vbshost.exe
     
  2. Blue Zee

    Blue Zee Power Member

    Descarregue e instale o Malwarebytes Anti-Malware.

    Actualize a faça um scan completo.

    Reinicie o sistema e comente.

    Zee
     
  3. ribamar

    ribamar Power Member

    Já tinha instalado! Apenas usei o "Spybot search and destroy" ( e nada foi encontrado ). Mas fiz como disse e fiz um scan completo usando o Malwarebytes e reiniciei. Resultado:

    Processos da Memória infectados: 0
    Módulos de Memória Infectados: 0
    Chaves do Registo infectadas: 0
    Valores do Registo infectados: 0
    Ítens do Registo infectados: 0
    Pastas infectadas: 0
    Ficheiros infectados: 0
    Processos da Memória infectados:
    (Nenhum item malicioso foi detectado)
    Módulos de Memória Infectados:
    (Nenhum item malicioso foi detectado)
    Chaves do Registo infectadas:
    (Nenhum item malicioso foi detectado)
    Valores do Registo infectados:
    (Nenhum item malicioso foi detectado)
    Ítens do Registo infectados:
    (Nenhum item malicioso foi detectado)
    Pastas infectadas:
    (Nenhum item malicioso foi detectado)
    Ficheiros infectados:
    (Nenhum item malicioso foi detectado)

    O problema persiste.
    -Enquanto fazia o scan, o avira acusava sempre o trojan (é na system32 e não na system que ele está alojado, anteriormente não estava correcto)
    -Posso tentar apagar o ficheiro usando o shredder do tuneup 2009, mas como disse não sei se o ficheiro é do windows
     
  4. Blue Zee

    Blue Zee Power Member

    A informação (in)disponível sobre o tal ficheiro faz crer que não é nada de bom.

    Confira P.F. que a ortografia é vbshost.exe!

    Pode usar o Unlocker para eliminar.

    Mas, talvez fosse útil "perder" um pouco mais de tempo e fazer isto.

    Se não resultar use o Unlocker para eliminar o ficheiro.

    Zee
     
  5. ribamar

    ribamar Power Member

    Por acaso já tinha usado o unlocker para verificar se o vbshost(.exe) estava a ser utilizado (a ortografia está correcta, copiei com o ctrl+c para não haver dúvidas) - e não estava a ser utilizado, logo utilizei o shredder - não foi permitido apagar o ficheiro (talvez por ser uma pasta do windows...), tentei apenas o usual shift+del e consegui apagar o ficheiro. Reiniciei. O vbshost já não se encontrava na pasta, mas o problema persistia, por isso resolvi fazer um scan com o avira, que por sua vez também não encontrou nada!

    Já corri o ccleaner, vou agora tentar o SUPERAntiSpyware.
    Já estou a achar estranho...
     
  6. ribamar

    ribamar Power Member

    Tá se a revelar mais difícil do que pensava! O SUPERAntiSpyware revelou 2 ameaças (menores) que foram posteriormente apagadas. Já corri antivir, SUPERAntiSpyware, Spybot S&D, Malwarebytes, ccleaner!!

    -Anteriormente bloqueei o acesso à internet do vbshost. Sem crer posso ter bloqueado o acesso das actualizações?? Ou não?
     
  7. Blue Zee

    Blue Zee Power Member

    Teste desactivando a firewall.

    Tente também o Dial-a-fix:
    http://wiki.lunarsoft.net/wiki/Dial-a-fix#Mirrors.2Fdownload_locations.2C_and_articles

    Extraia para uma pasta e corra o ficheiro Dial-a-fix.exe.

    Use esta opção para tentar reparar o Windos Update:
    http://wiki.lunarsoft.net/wiki/Dial-a-fix#WU.2FWUAU

    Diga-nos se resultou.

    Zee
     
    Última edição: 27 de Fevereiro de 2009
  8. ribamar

    ribamar Power Member

    A opção Dial-a-fix funcionou! As actualizações estão ligadas! Muito obrigado!
    Deixo as opções que foram escolhidas para resolver o problema:

    [​IMG]

    Mais uma vez obrigado!
     
  9. Blue Zee

    Blue Zee Power Member

    [​IMG]
    Óptimo!
     

Partilhar esta Página