1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Ajuda com disco externo - Urgente

Discussão em 'Dúvidas e Suporte Técnico PC' iniciada por ec99031, 28 de Agosto de 2006. (Respostas: 23; Visualizações: 1154)

  1. ec99031

    ec99031 Power Member

    Tenho aqui na net um colega meu com um pequeno problema. Ele ligou um disco externo que tb é leitor de cartoes (marca xpto - vosonic) a um pc com o XP home e este desligou-se durante a instalação dos drivers. O que acontece é que os drivers não foram correctamente instalados e mesmo tentando no gestor de dispositivos remover os volumes eles reaparecem de seguida.

    A questão é, como fazer para remover por completo os drivers (semi)-instalados de modo a que o windows volte a instalar de "raiz" os drivers?

    Se puderem ajudar... thks
     
  2. JPardinha

    JPardinha Power Member

    Boas, normalmente o restauro do sistema resolve esses pormenores, quento ao pc reiniciar, ou é da fonte ou da mboard (probably asrock). Espero ter ajudado!!
     
  3. ec99031

    ec99031 Power Member

    Quanto ao restauro, está desligado...

    O pc não reiniciou.

    Bom, vou explicar melhor o que se passou:

    Ele ligou o dispositivo ao pc, e durante a instalação dos drivers do dispositivo o dispositivo desligou-se e o windows xp atrofiou e não acabou a instalação (o pc continuou a funcar...)

    O problema é que ele quando liga o dispositivo ao pc o explorer atrofia todo (fica muito lento) e não consegue aceder ao dispositivo. Mas noutros pc's o dispositivo funca bem, logo o problema é dos drivers nesse pc.
    Por isso é que gostava de saber se existe alguma maneira de forçar o windows a remover os drivers que instalou para depois poder voltar a instalar os drivers do xp correctamente...


    Ah, ele tentou arranjar drivers pro dispositivo e só encontrou pro windows 2000, experimentou instalar por cima, mas continua a não funcar...


    Ideias são bemvindas, desde mexer no registry a outra coisa qualquer...
     
  4. Techdoctor

    Techdoctor Power Member

    Ele q experimente fazer a remoção dos drivers em Modo de Segurança.
    Julgo q aí já n terá problemas nisso.
     
  5. ec99031

    ec99031 Power Member

    Vou-lhe dizer pra tentar...

    A questão é:
    O dispositivo tem de estar ligado ao pc para desinstalar os drivers.
    Quando ele desinstala os drivers, logo de seguida o windows volta a instalar.
    Uma vez que a primeira instalação foi a que nao correu bem, estas "instalações" posteriores são sempre "defeituosas"...
    Por isso é que era interessante saber como forçar o windows a remover drivers já instalados...
     
  6. Techdoctor

    Techdoctor Power Member

    Se mesmo em Modo de Segurança n conseguir, tentem identificar no Gestor de Dispositivos quais são os ficheiros desses drivers (*.vxd, *.dll, etc) e apaguem-nos manualmente (ou melhor, movam-nos para uma pasta n vá dar-se o caso de algum ser tb necessário a outro dispositivo).
     
  7. ec99031

    ec99031 Power Member

    Essa ideia de ver os ficheiros não me tinha passado pela cabeça... vou falar com ele...
     
  8. Techdoctor

    Techdoctor Power Member

    Julgo q em Modo de Segurança ele n exigirá q o dispositivo esteja ligado.
    Mas se insistir nisso, faz a desinstalação e qd ele quiser fazer o reboot mandas (ou forças) o power-off (trabalhando sempre em Modo de Seg.).
    A seguir removes então os ficheiros correspondentes.
     
  9. ec99031

    ec99031 Power Member

    Bom o meu colega fez isto:
    "desinstalei o controlador Dispositivo de armazenamento de massa USB
    e quando ligo isto ele volta a instalar o disco externo
    mas depois nao consegue instalar as unidades nem atribuir letras"

    Soluções... Eu já nem sei o que lhe dizer...

    EDIT: pelos vistos agora ja atribui as letras mas acesso ao disco nepias
    Parece que isto esta relacionado com um tal de volsnap.sys
     
  10. Techdoctor

    Techdoctor Power Member

    Ele volta o instalar o Disco externo pq ele se encontra conectado ao PC...
    Desconecta-o para poderes remover os ficheiros dos drivers, reinicia o PC e depois de ele ter terminado o reboot é q ligas novamente o Disco.

    EDIT:
    Desculpa, já me tinhas dito q o sistema requer q o Disco externo esteja ligado para remover os drivers... É muita confusão já :)
     
    Última edição: 28 de Agosto de 2006
  11. ec99031

    ec99031 Power Member

    Neste momento ele está a tentar um pouco de tudo....
    Resposta dele:
    "estive a ler no site da microsoft e eles dizem pra tirar fora todos os controladores usb e reiniciar. tou a fazer isso agora. o problema nao é dos drivers pk os drivers sao do windows
    o problema é a configuraçao
    se os apago ele volta a coloca-los
    alias, nao os consigo apagar dentro do xp pk ele coloca-os no sitio de novo mal os apago"

    EDIT: Conclusão: continua na mesma...

    Alguém sabe como se apagam configurações de dispositivos... Uma vez que o problema não é nos drivers mas sim na menaeiro como aquilo está configurado?

    Acho que ele vai ter de mandar o xi$pê à vida..
     
    Última edição: 28 de Agosto de 2006
  12. Techdoctor

    Techdoctor Power Member

    E se ele fizer um "update drivers" no Gestor de Dispositivos?
     
  13. ec99031

    ec99031 Power Member

    Isso ele já fez... só que o pc atrofia todo (o explorer)...

    Como o dispositivo é leitor de cartões e disco rigido ele detecta bem o leitor de cartões, o prob é ao atribuir as unidades de armazenamento ao disco...
     
  14. Techdoctor

    Techdoctor Power Member

    E se fores ao "Disk Management" (nas "Administrative Tools", dentro do "Computer Management") e alterares manualmente a letra atribuída a esse Disco?
     
  15. Techdoctor

    Techdoctor Power Member

    Última edição: 28 de Agosto de 2006
  16. ec99031

    ec99031 Power Member

    O prob é que o disco não é bem configurado... se ele vai ao disk management o pc atrofia...

    O pc dá problm ao configurar o disco... por isso é que seria melhor "apagar" as conf. que deverão estar no registo do windows relativas aquele disco... Assim ele pensaria que era um dispositivo que nunca tinha sido instalado...
    Bom, mas acho que não se consegue resolver nada...
    Também n é grave, porque ele agora está a ligar o dispositivo num pc ao lado e aceder a ele por rede...
     
  17. Techdoctor

    Techdoctor Power Member

    E se fizer o seguinte (estão a acabar-se as ideias... :)):
    Com o dispositivo ligado ao PC, desactivá-lo no Gestor de Dispositivos.
    Desconecta-o, reinicia o PC e instala os drivers q ele arranjou para o 2000 (em princípio deverá funcionar, embora os drivers USB muitas vezes requeiram mesmo o SP2 para o XP).
    Finalmente conecta o Disco externo e verifica se ele aparece correctamente no Gestor de Dispositivos (talvez tenha q o activar).

    N custa tentar... :)


    Nota: sempre é o SP2 q ele tem?
     
  18. Techdoctor

    Techdoctor Power Member

  19. Techdoctor

    Techdoctor Power Member

    Apenas + uma ideia:
    Se ele instalar 1 outro dispositivo USB diferente (PenDrive ou mesmo HardDrive) pode ser q o sistema estabelize a nível de drivers USB. Depois desliga esse dispositivo e liga o q originou os problemas.

    Depois diz alguma coisa.
     
  20. atlante

    atlante Power Member

    O meu conselho vai no sentido de dasibilitar o USB na BIOS, logo pode remover todos os controladores usb sem problemas, depois basta ligar outra vez na bios

    cumps
     

Partilhar esta Página