1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Ajuda - Excel

Discussão em 'Programação' iniciada por w3e3w, 19 de Julho de 2007. (Respostas: 3; Visualizações: 575)

  1. w3e3w

    w3e3w Power Member

    Provavelmente a duvida que tenho é simples para quem percebe ...

    tenho uma tabela com este aspecto

    A
    1 ZSE
    2
    3
    4
    5 JUH
    6
    7
    8 FRT
    9
    10
    11 JUHY
    12
    13

    o que eu precisava era de um procedimento de preenchimento automático em que o valor de cima das celulas em branco fossem colados ou preenchidos nas celulas abaixo.

    Por ex.: A1 tem ZSE , então preenchia ZSE até à linha 4,
    a linha5 tem JUH entao preenchia JUH até a linha 7, e assim por diante.

    Alguém tem alguma ideia?

    Grato pela ajuda
     
  2. DisturbedGod

    DisturbedGod 1st Folding then Sex

    Boas,

    Consegues fazer isso com a função SE.

    Para resultar tens que introduzir uma linha na célula A1.
    A seguinte fórmula vai fazer com que a coluna B fique preenchida com os valores que queres:
    =SE(A2<>"";A2;B1) (terás que a introduzir no ínicio da tua tabela, ou seja na B2) - isto é o mesmo que se a Célula A2 estiver preenchida, introduz o valor da célula A2, se não estiver preenchida introduz o valor da célula B1.
     
  3. w3e3w

    w3e3w Power Member

    Obrigadissimo, amigo DisturbedGod!

    Funcionou perfeitamente!! :beerchug:
     
  4. DisturbedGod

    DisturbedGod 1st Folding then Sex

    De nada... sempre às ordens :)
     

Partilhar esta Página