1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Ajuda - excel

Discussão em 'Programação' iniciada por lupum, 31 de Outubro de 2008. (Respostas: 8; Visualizações: 744)

  1. lupum

    lupum Power Member

    Boas caros Gurus, tenho uma dúvida em Excel e gostaria de obter a vossa preciosa ajuda.

    Tenho uma tabela em Excel onde tenho 2 colunas. Uma com nomes e outra com valores.
    Queria que em determinada célula me indicasse os nomes das pessoas com valor 2, por exemplo.


    NOMES VALORES


    JOÃO 2


    MANUEL 5


    CRISTINO 2


    MARIA 2


    Queria que aparecesse, o João, Cristino, Maria.

    É possível com alguma fórmula?


    A fórmula que utilizei foi:
    =ÍNDICE(A2:B5;CORRESP(C10;B2:B5;0);1)

    Mas o excel só me dá o primeiro nome que encontra. Neste caso João. A célula C10 é onde se encontra o valor que desejo procurar. 2, neste caso.
    Eu não quero utilizar os filtros. Apenas fórmulas... É possível?
     
  2. esclarece um pontinho

    onde queres reproduzir os nomes? todos numa célula? em células da mesma coluna? não entendi bem essa parte.
    explica lá isso para irmos fazendo o exercício

    cumps

    acair
     
  3. lupum

    lupum Power Member

    Preciso de retornar os resultados numa célula.

    Exemplo:
    Na Célula G20: João, Cristino e Maria.
     
  4. dreamerboy

    dreamerboy Power Member

    Hummm, cheira-me que vais precisar de UDF para este caso concreto.
     
  5. lupum

    lupum Power Member

    Alguém consegue ajudar? :/
     
  6. lupum

    lupum Power Member

    Ninguém? :/
     
  7. K0mA

    K0mA Power Member

    Sabendo as células onde estão os valores podes usar esta formula para os juntar numa só célula.
     
  8. lupum

    lupum Power Member

    hummm Enviaram-me um exemplo com essa fórmula e outro com VBA lol.
    Quando conseguir osto aqui a solução.
    Obrigado meus caros :)
     
    Última edição: 6 de Novembro de 2008
  9. lupum

    lupum Power Member

    Podem fechar. Problema resolvido com fórmulas.
    Obrigado
     

Partilhar esta Página