1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Ajuda Flash

Discussão em 'Web Development' iniciada por Velshed, 23 de Julho de 2007. (Respostas: 4; Visualizações: 1075)

  1. Velshed

    Velshed Power Member

    Boas,
    comecei por criar animações em formato flash para adicionar ao site que desejo criar, e ao adicionar essas animações, quando as vou visualizar no browser aquilo bloqueia porque (acho eu) é devido aos controlos activex. Acontece que noutros sites que eu visito que têm animações em flash tal como este, isso não me acontece (o internet explorer não bloqueia essas animações).
    Alguém me pode ajudar? Quero criar o site com as animações de modo a que quando esse site for visitado o internet não bloqueie as animações... :S
     
  2. msdevweb

    msdevweb Power Member

    isso é muito estranho... mas tens algum javascript a implementar o flash, tipo o muito usado Run_active_content.js? ou algo parecido? se tens, e nao te da erro, verifica se na barra de estado do browser, au fundo, aparece concluido. Caso apareca algum icon de exclamaçao, ´porque pode ser do javascript que esteja a bloquear o browser.

    Se nao tens nunhum script a "carregar" o flash, o erro pode ser mesmo esse, mas como te digo, com ou sem o tal script, o flash deveria funcionar e nao bloquear o browser....

    Nao te ajudei em nada, mas pelo menos ja tens algumas das ideias do que possa ser..

    cumps.
     
  3. Velshed

    Velshed Power Member

    Olha eu na percebo mt disso dos javascript pr isso fiquei na msm.
    Vim só acrescentar que aquilo não é bem bloquear é mais aparece uma barra lá em cima que diz:"Para ajudar a proteger a sua segurança, o Internet Explorer restringiu este ficheiro de mostrar conteúdo activo que pode aceder ao computador. Clique aqui para opções..." Depois as opções disponíveis são: Permitir conteúdo bloqueado; Qual é o risco?; Barra de informações e ajuda.
    Depois se eu carrego na opção permitir conteúdo bloqueado ele pergunta se tenho a certeza de deixar aquele ficheiro executar conteúdo activo. Eu meto sim e aquilo já dá só k eu queria que não acontecesse isso porque aquilo antes de eu fazer isso à barra aquilo descordena tudo e além disso tenho medo que isso aconteça em todos os computadores e que pessoas que tenham mais receio não carreguem na barra e o site fica "feio".

    Espero que me consigam ajudar.
    Cumps
     
  4. msdevweb

    msdevweb Power Member

    Bem, isso assim ja é mais facil de explicar... na maior parte dos casos, isso aconteceu-te porque de certeza que configuraste a segurança do teu browser para bloquear conteudos shockwave/flash, ou ate mesmo se o flash recorrer ao tal javascript, que pelos visto esta a faze-lo, acontece em casos como a publicaçao de um flash pelo flash cs3 ou dreamweaver cs3, pode ser por isso que esta a dar erro, para resolveres isso, podes activar a execuçao de scripts javascript e conteudo shockwave/flash nas opçoes do browser.

    Mas para te "acalmar", posso-te dizer que por defeito esse bloqueio (ao shockwave/flash) vem desactivado no IE/Firefox/Opera.

    De qualquer das maneiras, coloca aqui o codigo fonte da tua pagina, mas so a parte onde tens o codigo do teu flash (<object>), e vê tambem se nao existe referencia nenhuma a algums ficheiros *.js logo antes do teu <body>.

    cumps.
     
    Última edição: 24 de Julho de 2007
  5. Velshed

    Velshed Power Member

    Pois mas sendo assim porque é que eu consigo ver as outras animações feitas no flash e não consigo ver as minhas.

    Eu penso que seja porque a minha animação não está assinaçada como segura porque eu fui às opções e uma delas que estava assinalada como desactivar era essa. Se for esse o problema, como resolvo? Como meto a minha animação como sendo segura?

    O código do vídeo fica aqui:
    <object classid="clsid:D27CDB6E-AE6D-11CF-96B8-444553540000" id="obj1" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0" border="0" width="312" height="229" hspace="0" vspace="-50" align="left">
    <param name="movie" value="Benfica pub.swf">
    <param name="quality" value="High">
    <param name="wmode" value="transparent">
    <embed src="Benfica%20pub.swf" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" name="obj1" width="312" height="229" quality="High" wmode="transparent"></object>

    Cumps,
    ajudem-me please!
     

Partilhar esta Página