1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Ajuda no excel!

Discussão em 'Windows Desktop e Surface' iniciada por carloselmano, 2 de Julho de 2006. (Respostas: 5; Visualizações: 874)

  1. carloselmano

    carloselmano Suspenso

    Oi pessoal! Estou com um problema que é o seguinte:
    Tenho um intervalo com letras tipo
    A B C D E e numa outra celula quero clicar uma letra á minha escolha e quero saber se tipo qdo escrever uma letra se ela pertencer a esse intervalo que aparece verdadeiro ou falso

    exemplo 1

    A B C D E numa outra celula digito B aparece num noutra celula = verdadeiro

    exemplo 2
    B C D E numa outra celula digito F aparece num noutra celula = Falso

    Espero pela vossa resposta
    Obrigado.
     
  2. shello

    shello Moderador
    Staff Member

    Boas!
    isto e escolhe Comparar um valor com uma lista de valores.

    Cumps

    P.S: Ambas as questões podiam estar na mesma therad ;)
     
  3. carloselmano

    carloselmano Suspenso

    Oi shello, vbmenu_register("postmenu_1056087", true); obrigado pelas resposta mas o quero fazer é assim

    Nome da pessoa | categoria
    Joaquim Manuel | pedreiro
    Manuel açorda | servente

    E depois atraves de celula de validação (onde coloco os nomes e deois escolho) que apareça qdo escolher o nome desejado que apareça numa celula a categoria à frente.


    . Tipo meter uma validação (lista) e qdo escolher o nome da pessoa que apareça numa celula a categoria que ela tem.Obrigado.
     
  4. shello

    shello Moderador
    Staff Member

    Andei agora aqui no Excel a exprimentar, e cheguei ainda a isto:
    {=SE(OU(EXACTO(D2;A2:A3));"Sim";"Não")}
    ...o que dá para fazer, se o nome estiver na lista aparece "sim", se não, aparece "não".
    Agora o que não estou a ver como fazer é ir procurar qual a célula que tem esse nome e depois, o objectivo seria ir buscar o conteúdo da célula à direita. :\

    Cumprimentos
    shello
     
  5. MrBean

    MrBean Power Member

    Fazes o seguinte. Exemplo:

    Tens a lista nas colunas A e B como disseste:

    Nome | Função
    Nome 1 | Função 1
    Nome 2 | Função 2

    na célula, digamos, D1 escreves o nome "Nome 1"
    na célula E1 escreves, se o excel for inglês (sem as aspas) "=vlookup(D1;$A:$B;2;FALSE)"

    e aparece lá a função da pessoa. Nesse caso, as colunas A e B estão reservadas para os nomes e funções.

    Penso que seja isto que querias...
     
  6. carloselmano

    carloselmano Suspenso

    OI MrBean!Obrigado pela dica!! Foi uma grande ajuda!Mas como nao tenho o excel em ingles a função é esta =PROCV(D1;$B:$C;2;FALSO)
     

Partilhar esta Página