1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

ajuda

Discussão em 'Programação' iniciada por hugosilva_797, 25 de Setembro de 2008. (Respostas: 11; Visualizações: 670)

  1. boas pessoal, eu iniciei me a umas semanas na pogramaçao.

    mas estou com alguns problemas na utilizaçao do turbo pascal, eu faço o programa e quando carrego em compile dix que tenho tudo certo, mas quando carrego em run aparece "error 200: division by zero".
    algume sabe qual e o problema ?
     
  2. Baderous

    Baderous Banido

    É porque tens alguma operação no teu código que está a levar a uma divisão por zero.
     
  3. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    Exacto.
    Podes mostrar o código, se for preciso vermos o que se passa?
     
  4. o codigo esta certo. porque quando eu carrago em compile o pograma diz que esta tudo certo mas quando meto run da o tal erro
     
  5. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    Repara...
    c = 1-1
    d = 2/c

    Ele compila com sucesso, está tudo certo, e quando metes run dá esse erro.
     
  6. nao tem nada a ver. ve este video

    Código:
    http://rapidshare.com/files/149493611/clip0002.zip.html
     
  7. Baderous

    Baderous Banido

    O programa em si até pode estar correcto, sem erros de sintaxe e tudo o mais, logo não acusa erros de compilação. No entanto o erro que obtens é um erro de execução que deriva de alguma expressão algébrica algures no teu código que está a gerar uma divisão por zero. E meteres aqui o código em vez de vídeos, ah? Seria melhor...
     
  8. mas isso e igual em qualquer codigo.

    fiz um no pc de um colega e dava perfeitamente passei pa minha pen meti no pc e ja deu erro.
     
  9. Baderous

    Baderous Banido

    Mete aqui o código.
     
  10. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    Epá, sinceramente, ninguém vai adivinhar o teu problema.
    Se queres chegar a algum lado com este tópico, mostra o código ou diz exactamente como o fizeste (e não, "deu no pc do meu amigo e não deu no meu" não é suficiente).
    Senão, isto não vai a lado nenhum, e vais ficar na mesma.
     
  11. Rúben T.

    Rúben T. Power Member

    Estás a usar o "uses crt" e o "clrscr" ? Apaga o "uses crt" e o "clrscr", grava o código, fecha o turbo pascal, volta a abrir o código, e tenta agora.

    A mim só assim resolveu, estranho mas é verdade, penso ser bug do Turbo Pascal ;)
     
  12. problema resolvido, era um bug que o programa tinha.

    mas obrigado na mesma pela vossa ajuda
     

Partilhar esta Página