1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Algoritmo maior e menor e sequencia

Discussão em 'Programação' iniciada por roberts, 27 de Outubro de 2012. (Respostas: 6; Visualizações: 2079)

  1. roberts

    roberts Power Member

    gostaria de saber como num algoritmo para além de ele fazer o maior numero e o menor também fazer uma sequencia.
    Ex maior num:5 menor num:1


    1 2 3 4 5

    Ser capaz de completar a sequencia
     
    Última edição: 27 de Outubro de 2012
  2. mr_quintas

    mr_quintas Power Member

    terias de fazer duas perguntas a meu ver
    Primero e ultimo numero:
    Intervalo :

    pra depois na incremençao do vector ela saber o espaçamento entre os numeros

    senao for assim era assim que tentava fazer
     
  3. dagas46

    dagas46 Power Member

    Assumindo que o algoritmo apenas usa valores inteiros é fácil. Pedes o menor e o maior. A partir daqui crias um ciclo, se o menor for menor que o maior, incrementas o menor e imprimes. Quando forem iguais sais do ciclo e imprimes o menor.
     
  4. roberts

    roberts Power Member

    Código:
    [COLOR=#f0f8ff][FONT=Courier]vars:[/FONT]
    [FONT=Courier]   menor, maior, i, c: inteiro[/FONT]
    [FONT=Courier]   [/FONT]
    [FONT=Courier]inicio[/FONT]
    [FONT=Courier]
    i<--0
    
    enquanto i<10 fazer
    
    Escrever("Insira o número: ")
    Ler (c)
    
    se (i=0) v (c>maior) então
    maior<---c
    
    fim_se
    
    
      se(i=0) v (c<menor) então[/FONT][/COLOR][COLOR=#f0f8ff][FONT=Courier]
    menor<----c
    [/FONT]
    [FONT=Courier]  fim_se
    [/FONT]
    fim_enquanto
    
    [FONT=Courier]   escreva("Menor: ", menor)[/FONT]
    [FONT=Courier]   escreva("Maior: ", maior)[/FONT]
    
    [FONT=Courier]fimalgoritmo[/FONT][/COLOR]

    O problema agora é se eu introduzir 10 numeros... ele sabe qual é o maior e o menor... e depois tem de completar uma sequencia, do género 1 2 3 4 5
     
  5. dagas46

    dagas46 Power Member

    Se introduzires 10 números, pelo que percebi que queres fazer, basta veres qual o menor e o maior desses 10 e depois com isso podes aplicar o algoritmo que te disse
     
  6. roberts

    roberts Power Member

    Eu já tenho o algoritmo em cima.
    Não se importa de acrescentar o que falta.
     
  7. dagas46

    dagas46 Power Member

    Está aqui o algoritmo. É só passar para pseudo-código como aí tens
     

Partilhar esta Página