1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Algumas dúvidas em Slackware

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por Neojag, 1 de Agosto de 2006. (Respostas: 5; Visualizações: 617)

  1. Neojag

    Neojag Power Member

    Comecei agora a brincar com Slackware 10, de maneira que estou aqui com umas dúvidas ;)
    Acabei neste momento de configurar a placa de rede e já tenho a net a bombar, mas para isso precisei de alguns reboots (depois de utilizar o netconfig, para actualizar o hostname e o domain). Há maneira de actualizar esta informação depois de editar os ficheiros de configuração ou de correr o netconfig sem reiniciar o sistema?

    A outra coisa tem a ver com o layout do teclado no KDE. Rais ma partam, fiquei com o layout correcto na shell, mas quando entro no KDE, fico c'o teclado americanóide. Onde camandro defino isto que não estou a encontrar? E já que estamos no KDE, para fazer o X arrancar de início, basta adicionar a qualquer um dos scripts de inicialização "startx"?

    E finalmente, onde é que posso editar o driver que é carregado para o rato de maneira a que a roda funcione? É que neste momento, só dois botões e nada mais.

    Muito obrigado meus caros!
     
  2. incognito54

    incognito54 Power Member

    Já não uso slack há um tempo mas acho que ainda me lembro de algumas coisas.~

    Para teres a roda tens q editar o xorg.conf a pata e na parte do rato pores:
    Código:
    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"
    Para arrancar directamente para o X tens que editar o rc.init e na parte onde diz o runlevel meteres o 4.

    Isso do KDE acho q podes ir ao control panel do KDE e editar. Quanto ao netconfig não te sei mesmo dizer.
     
  3. xtr3me

    xtr3me Power Member

    Em princípio agora já não vais precisar de editar mais vez nenhuma, portanto tás na boa.

    Tens de ir ao control panel do kde e procurar nas propriedades do teclado. De qualquer maneira é possível que tenhas uma bandeira na "tray" do kde (perto do relógio). Carrega lá e muda para o idioma correcto.

    Editas o /etc/X11/xorg.conf (ou XF86Config). Não sei qual das versões do slack 10 é que tens, por isso tens de ver se tens xorg ou não.
     
  4. Neojag

    Neojag Power Member

    Obrigado ;)
    Já editei o Xorg.conf com as opções que indicaram (mais os "" no 5, senão ele atrofiava, e depois de mudar o driver para ImPS/2), e já está a rolar :). Mas mais uma vez, como é que faço o X ler esta configuração sem ter de o estar a reiniciar?

    Edit: Yep, realmente o keyboard layout estava no control centre, mas só o encontrei com o search :)
     
    Última edição: 1 de Agosto de 2006
  5. xtr3me

    xtr3me Power Member

    Não consegues.
    Tens sempre de matar o X e voltar a arrancá-lo para que ele reconheça as definições.
    De qualquer maneira não é nada de muito complicado: Ctrl+Alt+Backspace (para matar) e depois startx.
     
  6. Neojag

    Neojag Power Member

    Ok then ;) Danke!
     

Partilhar esta Página