1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Alsa/oss

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por hgdn, 24 de Julho de 2007. (Respostas: 6; Visualizações: 927)

  1. hgdn

    hgdn Power Member

    Boas,

    Desde que instalei linux que tenho um problema e agora estou decidido em resolve-lo :-D

    Jogo Enemy Territory e por vezes quando abro o jogo o som não arranca! Apos uma pesquisa rápida vi que o problema não era só meu e que fazendo estes comandos e voltando a abrir o game o som ia dar:


    echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
    echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
    E é verdade... O som dá.... Mas tb sempre reparei que não conseguia ter, por exemplo, ouvir um mp3 e ter som no jogo.

    Ontem instalei o Team Speak e acontece o mesmo! Ou tenho som no Team speak, ou só no jogo!

    Pelo que já percebi este problema tb acontece com jogadores de Quake III.

    Alguem têm alguma ideia para isto? Pelo que li na net, algumas pessoas resolveram o problema instalando o plugin do ALSA, dmix, mas eu instalei e nada!


    EDIT: Uso Mandriva 2007.1. Com o 2007.0 tb acontecia isso!
     
  2. tangram

    tangram Power Member

    Esse problema do som é conhecido e estende-se a certa placas de sons. Lembro-me de ter lido sobre isso à uns meses atrás. Recordo-me de ter lido algures que era possível dar a volta à situação.

    Ainda assim dá uma olhada aqui: http://gentoo-wiki.com/HOWTO_Quake_III_Arena_/_Enemy_Territory
    http://enemy-territory.4players.de:1041/e107_plugins/forum/forum_viewtopic.php?180747.post
    http://zerowing.idsoftware.com/linux/et/
    https://help.ubuntu.com/community/EnemyTerritory
    http://blog.ogmaciel.com/?p=44
    http://alsa.opensrc.org/home/w/org/opensrc/alsa/index.php?title=FAQ023

    Tenta procurar no google por linux, et, teamspeak e ventrilo. Há de certeza formas de dar a volta à situação, pois havia pessoal do meu clã (long long time ago) que usava ET em linux com ventrilo.
     
  3. hgdn

    hgdn Power Member

    Boas,

    Já tinha tentado quase tudo o que deste e agora experimentei mais umas coisas que nc tinha visto! E continua na mesma! Acho que vou mm desistir : <

    Obrigado na mm pela resposta.
     
  4. Conde

    Conde Power Member

    Uma maneira mais rebuscada de resolver esse problema é instalares outra placa de som. ficando com duas, uma para o ET outra para o TS.
     
  5. hgdn

    hgdn Power Member

    Obrigadao! Infelizmente tentei tudo o que deram e nada! Estou farto disto ja :-D

    COmprar uma segunda placa tb não é solução! Para isso teria que ligar, por exemplo, phones a um lado e colunas a outro! Eu queria simplesmente receber som num sitio só e puder ter o micro tb! Provavelmente é mm desta minha placa! Talvez se comprar uma melhor isto fique resolvido!
     
  6. Martinho

    Martinho Power Member

    geralmente as placas onboard não fazem o mix por hardware, é uma funcionalidade delegada aos drivers. Qualquer SB Live faz mix por hardware e podem ser adquiridas em 2ª mão por preços muito acessiveis
     

Partilhar esta Página