1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

aMSN 0.96 e o autopackage

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por hellaxe, 28 de Novembro de 2006. (Respostas: 15; Visualizações: 4835)

  1. hellaxe

    hellaxe Power Member

    Pessoal gostava de saber se já alguém instalou a nova versão do aMSN 0.96 com o denominado "autopackage". Para o dapper ainda não há lá deb por isso aconselham o autopackage.
    aMSN
    Autopackage
     
  2. iGama

    iGama Ubuntuguide Translator

    Aqui vai uma explicação do que é o Autopackage:

    O formato Autopackage é suposto ser um instalador de pacotes nas distribuições Linux "Neutra". Este usa o seu próprio sistema de gestão de pacote, que é feito um download da Internet e instalado com o primeiro Autopackage que se instalar.

    Encontrei ontem um script que faz a compilação do aMsn com Anti-Alising ( sempre fica com melhor aparencia )

    Script criando por um membro da comunidade Ubuntu.

    Vuen @ Ubuntuforums

    Exemplo de como ficará ( com skin Kubuntu ):
    [​IMG]

    Isto é um script automato para a adição de suporte anti-aliasing ao aMsn. Ele irá compilar a última versão do beta do Tcl/TK e recompilar o último lançamento estável do aMsn. Isto não irá substituir a instalação actual do Tcl/Tk, assim é um método mais seguro e mais simples de reverter que outros métodos.

    Notas:
    * A versão beta do Tcl/Tk vao ser compilada e instalada no /usr/local; assim não irá substituir a instalação actual do Tcl/Tk, assim se esta instalação falhar, a tua instalação do aMsn não será afectada.
    * Se o aMsn se queixar que falta a biblioteca TLS quando se tenta fazer o login escolha "Don't download TLS, I'll install it myself" e depois clique em Account->Preferences->Advanced e na secção Other há uma caixa com o nome TLS, coloque o seguite: /usr/lib/tls1.50

    * A hold will be placed on the amsn package in apt-get so that it doesn't upgrade automatically. If you want to upgrade when a new version comes out, you will need to apt-get install the new package, then download the source code and compile it as in this script.
    * Certain icons will still look ugly in the default skin; this script will automatically add the Ubuntu and Kubuntu skins by GuS-Arg. You can activate them via Account -> Preferences -> Appearance -> Select Skin.

    * Se queres voltar ao aMsn normal, abre um terminal e escreve:

    Comandos:
    Já testei 2x e deu :)
     
    Última edição: 28 de Novembro de 2006
  3. hellaxe

    hellaxe Power Member

    Isso para desinstalar depois deve ser mais chato, não?

    IGama talvez me possas dar uma ajuda já que li algumas coisas e estou um pouco baralhado.
    Para fazer a minha propria aMSN_ubuntu.deb, chamemos-lhe assim, depois do make que comandos devo utilizar? Fakeroot com o dpkg-buildpackage ou outros? Se não te der muito trabalho podes colocar os comandos certos?

    É que neste campo de fazer deb's sou mesmo NOOB.

    Obrigado
     
  4. ruimoura

    ruimoura Power Member

    Para mim era correr tudo a autopackages. Era o grande salto que o Linux precisava de dar de encontro ao desktop. Mas há sempre os que têm comichão por uma ou outra razão.
    Saca o autopackage que não tens que andar com filmes nenhuns e já tem tudo incluído ...
     
    Última edição: 28 de Novembro de 2006
  5. hellaxe

    hellaxe Power Member

    Não me faz comichão quero aprender.
     
  6. CR_

    CR_ Power Member

    Eu já instalei. Aquilo não me instala nenhum .deb (pelo menos não o encontro pelo synaptic) , simplesmente instala o amsn e adiciona um icon.

    Desinstalar?

    #locale -u
    #locate amsn

    Rm -rf /Pastas do amsn
     
  7. iGama

    iGama Ubuntuguide Translator

    ta lá no post a dizer como remover :

    sudo apt-get remove --purge amsn
    sudo rm -r /usr/share/amsn

    Podes criar debs usando o checkinstall por exemplo:

    sudo aptitude install checkinstall

    sudo make
    sudo checkinstall
     
  8. hellaxe

    hellaxe Power Member

    Ok usei checkinstall e está ok.

    Esse com anti alising está supimpa.

    Alguém sabe como se mete no configure para fazer o enable do anti-alising? :x2:
     
  9. iGama

    iGama Ubuntuguide Translator

    ve no script que postei, ve quais os argumentos que ele usou :)
     
  10. hellaxe

    hellaxe Power Member

    Isso já eu vi mas não detecto nada relativo a isso.

    Só se for isto:
    Código:
    make CFLAGS="-g -O2 -D_REENTRANT"
    EDIT: Creio que já descobri deve ser isto:
    Código:
    --enable-xft
    Epá no ubuntu bem que podiam meter o TCL/TK 8.5 pois segundo me apercebi são eles que activam o anti-aliasing
     
    Última edição: 28 de Novembro de 2006
  11. mundano

    mundano Power Member

    Tentei instalar pelo script para ter as fontes com AA e deu-me isto:

    checking for png_read_info in -lpng... no
    configure: error: libpng is required
    ERROR: Could not compile aMSN.

    E pronto.. aborta a instalação..

    Não faço ideia do que seja o libpng e pelo apt-get não está disponível.. Alguém me explica como se eu fosse muito burro como instalar isto?

    Para mim 0.95 ou 0.96 tanto faz, queria era as fontes com AA, porque sem isso o aMSN fica com um aspecto horrível.
     
  12. iGama

    iGama Ubuntuguide Translator

    Não custa nada fazer uma procura no synaptic por libpng, o que ele ira devolver:

    Será então preciso instalar :

    sudo apt-get install libpng12-0 libpng12-dev

    Se te deu esse erro então tb vais precisar de instalar os pacotes libjpeg62 e libjpeg62-dev
     
  13. mundano

    mundano Power Member

    Obrigadão pela dica.. Realmente faltavam-me as versões developer desses dois packages..

    Este script está muito bom 0.96 + AA.. :007:
     
    Última edição: 29 de Novembro de 2006
  14. hellaxe

    hellaxe Power Member

    É so' erros hoje:
    No Edgy:

    Código:
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Writing extended state information... Done
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Could not open file /var/lib/apt/lists/darkstar.ist.utl.pt_ubuntu_archive_dists_edgy_main_source_Sources - open (2 No such file or directory)
    
    Deve ser pq o darkstar está offline, digo eu.
     
  15. hellaxe

    hellaxe Power Member

    Desculpem o desenterranço mas há nos repositórios uma actualização para o aMSN 0.97 do svn e como eu instalei através daquele script que está no inicio da thread para ficar com as fontes lindinhas será que vou estragar a instalação que tenho, e ficar com as fontes ranhosas outra vez?
    Já agora o que trás esta 0.97 de novidade?

    Obrigado
     
  16. viskonde

    viskonde I quit My Job for Folding

    tentei fazer isto e deu me isto..

    tentei ainda instalar estes pacotes pelo gestor de pacotes synaptic, e da um erro igual..
    sabem como resolver?
     

Partilhar esta Página