1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

ASP em XP - Debugging - problema

Discussão em 'Programação' iniciada por Torgut, 2 de Maio de 2005. (Respostas: 1; Visualizações: 534)

  1. Torgut

    Torgut Power Member

    Olá!

    Sempre tive um problema, cuja resolução me intriga. Ao trabalhar com ASP, e indo testar qualquer coisa a correr, por exemplo, no IE, caso suceda um problema, só depois de um restart é que consigo saber se o que entretanto fiz para corrigir deu certo.

    Isto hoje foi de mais! O IIS tava-me a dar um erro. Cada vez que precisava de testar a sua correcção, tinha que fazer um restart. Vamos supôr que me dava um erro na linha 5 de um file chamado entrada.asp

    Tentei:

    * Ctrl + F5 (evidente)
    * Apaguei todo o conteúdo do entrada.asp e gravei. Continuava a dar erro numa linha 5 que já nem existia.
    * Apaguei todo o off-line contents e cache e tudo o mais do IE.
    * Apaguei o file - deu erro 404 - pelo menos esta foi normal
    * Fiz restart do IIS - com ele em Stop, erro normal de server - com ele depois do restart, o mesmo erro de ASP que já tinha sido corrigido.

    Esta cena dá comigo em maluco, alguém já experimentou este problema?
     
  2. "Tested and working solution"

    Boas, é um problema frequente que vem desde o IIS 5

    é bastante simples, basta apenas introduzir no topo da pagina o seguinte código VBscript:

    Response.Expires = -1
    Response.AddHeader "Pragma","No-Cache"

    Aqui aconcelho o uso de um include pois facilita.

    Já agora um pequeno pormenor, quando tive a investigar esse problema sempre achei mais fiavel o "Crl + R", mas pode ser apenas mania minha.
     

Partilhar esta Página