1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

ATI + ubuntu

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por freestyler, 6 de Maio de 2008. (Respostas: 14; Visualizações: 1511)

  1. Boas,

    Hoje tive a ideia de instalar o ubuntu no meu pc, visto que ultimamente tenho vindo a mexer no ubuntu noutro computador e até acho bastante amigável.

    Estava tudo bem instalação a 100% tudo a funcionar direitinho bastante rápido e tal... até que me lembrei de tentar instalar o beryl...

    Para instalar o beryl tinha que actualizar os drivers da gráfica

    Ora comecei a ler um tutorial e fui fazendo o que lá dizia tudo direitinho não ocorreu nenhum erro maravilha...

    Até que mandou reiniciar... mandei reiniciar o pc reiniciou aparece o menu loading do ubuntu uma tretinha depois que era normal e depois o ecrã fica todo preto!

    já experimente reiniciar umas 5x e nada :-\

    Tenho uma ATI Radeon HD 2600 Pro e instalei supostamente os ultimos drivers da ATI

    Espero que alguém me consiga ajudar

    Cumprimentos
     
  2. Gunn3r

    Gunn3r Power Member

    Eu também estou assim um bocado pro n00b com ATI's visto ter comprado um portatil com uma HD2600, mas podes tentar usar um LiveCD para editares o xorg.conf da tua instalação e voltares a carregar os drivers opensource ou mesmo vesa para voltAres a ter X
     
    Última edição: 6 de Maio de 2008
  3. Tyran

    Tyran Power Member

    beryl porquê?? o ubuntu já vem com compiz fusion

    cumpzz
     
  4. rj.rodrigues

    rj.rodrigues Power Member

    Desinstala os drivers k instalas-te.

    Instala o envy:
    (caso seja ubuntu 8.04 hardy)
    Código:
    sudo apt-get install envyng-gtk
    E instalas os drivers da grafica apartir do envy
     
  5. van_Zeller

    van_Zeller Power Member

    E quanto ao beryl, já vem instalado o compiz fusion, que agora é a mesma coisa. Só tens que instalar o "painel de controlo" para ele. Escreve ccsm na consola e segue as instruções que lá aparecem (na consola).
     
  6. Paulo Truta

    Paulo Truta [email protected] Member

    Ou vais ao menu de instalação de programas, metes todos, e na procura ''Compiz''

    Agora sobre o teu problema em alguns computadores com gráficas ATI ou processadores AMD as coisas não me têm corrido mto bem com o Ubutu...

    Cumps ;)
     
  7. viseu3500

    viseu3500 Power Member

    Boas

    Mesmo com o tutorial do primeiro post desta thread não consegui por o compiz a dar. tenho acesso ao sistema de configuração mas não consigo alterar nada.
    Eu antes tinha a verrsão 7.10 e funcionava perfeitamente, agora depois da actualização para a 8.04 deixou de funcionar.
    Tenho uma ATI HD2600 e já actualizei os drivers pelo envy.

    Alguém me pode ajudar a resolver o problema?
     
    Última edição pelo moderador: 4 de Junho de 2008
  8. rj.rodrigues

    rj.rodrigues Power Member

    Fizes-te a parte:
    "Colocar o compiz a funcionar em algumas placas da ati que ficaram na blacklist"
    ?
     
  9. viseu3500

    viseu3500 Power Member


    Fiz isso tudo. tive tb de instalar o novo envy para poder actualizar a gráfica
     
  10. rj.rodrigues

    rj.rodrigues Power Member

    Tens direct Rendering?

    Para ver:
    Código:
    glxinfo | grep "direct rendering"
     
  11. viseu3500

    viseu3500 Power Member

    Sim, tenho
     
  12. rj.rodrigues

    rj.rodrigues Power Member

    O que é k ele diz ao fazeres:
    Código:
    compiz --replace
     
  13. viseu3500

    viseu3500 Power Member

    Diz o seguinte:

    Código:
    Checking for Xgl: not present.
    Detected PCI ID for VGA: 01:00.0 0300: 1002:9581 (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: not present.
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: present.
    Checking for non power of two support: present.
    Checking for Composite extension: present.
    Comparing resolution (1440x900) to maximum 3D texture size (8192): Passed.
    Checking for nVidia: not present.
    Checking for FBConfig: present.
    Checking for Xgl: not present.
    /usr/bin/compiz: 407: /usr/local/bin/compiz: not found
    
     
  14. Boas, estou a usar Ubuntu Jaunty e estou com o mesmo problema.
    Isto é o que aparece quando faço: compiz --replace

    Código:
    Checking for Xgl: not present. 
    xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log 
    Detected PCI ID for VGA: 
    Checking for texture_from_pixmap: not present. 
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: present. 
    Checking for non power of two support: present. 
    Checking for Composite extension: present. 
    Checking screen 1Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
    Checking for Software Rasterizer: Not present. 
    Checking for nVidia: not present. 
    Checking for FBConfig: present. 
    running under gnome seesion, checking for gnomecompat
    Checking for Xgl: not present. 
    /usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
    É estranho porque quando faço: glxinfo | grep direct aparece:

    Código:
    direct rendering: Yes
    e quando faço: glxinfo | grep texture_from_pixmap
    Código:
        GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, 
        GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
    Alguma solução?
     
  15. Varial

    Varial Power Member

    Boas ppl

    Tenho aqui um problema similar também com uma ati 2600 pro, então a minha situação é a seguinte, instalei os drivers proprietary do site da ati + o envy e o mesa.

    e pa mas sempre que corro um jogo aparece umas listas pretas cintilantes no monitor :P e pa falta algum componente? vou mandar um print xd

    [​IMG]

    Thanks to ImageShack for Free Image Hosting
     

Partilhar esta Página