Bloqueio de ecrã passado 2mins- Windows 10- Resolvido

Genjuro

Power Member
Como não sei o que já tentaste, e o "já tentei tudo" pode ser muita coisa :D.

Nunca pesquisa rápida encontrei isto:

"Finally found the solution,just in time too because I swear I was about to go insane.

Right click on desktop > Power and sleep > Additional power settings > Choose when to turn off the display > Change advanced power settings > Restore plan defaults

I don't know why but this completely got rid of the issue and I was then able to make the settings whatever I wanted.

Hope this helps!"


https://www.tenforums.com/performan...10-sleeps-after-3-minutes-no-matter-what.html

Que depois remeteu também para isto:

"Here is the solution that worked out for me:

1. Click on the windows icon
2. Type regedit
3. Right-click on regedit icon, click Run as administrator
4. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0
5. Double click on Attributes
6. Enter number 2.
7. Go to Advanced power settings (click on Windows button, write power options, click on Power Options, in the selected plan click on the Change plan settings, click on the Change advanced power settings).
8. Click on the Change settings that are currently unavailable
9. Click Sleep, then System unattended sleep timeout, then change these settings from 2 Minutes to 20 for example.
That's it!"

https://www.tenforums.com/performan...-after-2-minutes-inactivity-3.html#post441903
 

xzk

Power Member
Como não sei o que já tentaste, e o "já tentei tudo" pode ser muita coisa :D.

Nunca pesquisa rápida encontrei isto:

"Finally found the solution,just in time too because I swear I was about to go insane.

Right click on desktop > Power and sleep > Additional power settings > Choose when to turn off the display > Change advanced power settings > Restore plan defaults

I don't know why but this completely got rid of the issue and I was then able to make the settings whatever I wanted.

Hope this helps!"


https://www.tenforums.com/performan...10-sleeps-after-3-minutes-no-matter-what.html

Que depois remeteu também para isto:

"Here is the solution that worked out for me:

1. Click on the windows icon
2. Type regedit
3. Right-click on regedit icon, click Run as administrator
4. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0
5. Double click on Attributes
6. Enter number 2.
7. Go to Advanced power settings (click on Windows button, write power options, click on Power Options, in the selected plan click on the Change plan settings, click on the Change advanced power settings).
8. Click on the Change settings that are currently unavailable
9. Click Sleep, then System unattended sleep timeout, then change these settings from 2 Minutes to 20 for example.
That's it!"

https://www.tenforums.com/performan...-after-2-minutes-inactivity-3.html#post441903
Também já tinha feito isso.


Fiz o reset dos power settings do 1º passo, fui ao regedit, pus esses Attributes com o número "2".
Apareceu essa nova opção do System unattended sleep timeout( por default estava a 2 mins) e mudei para os 120min que estão na imagem acima.



Continuo na mesma :(
 

xzk

Power Member
Um testezinho rápido, se iniciares em modo de segurança também acontece?
Testei agora em modo de segurança umas quantas vezes: o ecrã bloqueia mas de 5 em 5 minutos, de acordo com o meu cronómetro.


Que eu me lembre, o PC nem sempre fez isto. Agora que estou em teletrabalho e tanto estou no portátil da empresa como estou neste PC pessoal noto que tenho de estar constantemente de 1 em 1 minuto a mexer o rato para o ecrã não bloquear. É de uma pessoa ter um aneurisma.

O PC é Desktop.
 

Genjuro

Power Member
Mais umas sugestões:

Já desabilitaste na BIOS todas as opções de poupança de energia?
A tua BIOS está atualizada?
Os drivers também estão todos atualizados? (há um SW que verifica isso e que já usei "Iobit Driver Booster", mas há outros do genero)
 

xzk

Power Member
Mais umas sugestões:

Já desabilitaste na BIOS todas as opções de poupança de energia?
A tua BIOS está atualizada?
Os drivers também estão todos atualizados? (há um SW que verifica isso e que já usei "Iobit Driver Booster", mas há outros do genero)
Depois do teu post:

-Atualizei a BIOS,
-Atualizei os drivers todos( com o programa que referiste)
-Verifiquei as opções de poupança de energia e está tudo normal.
-Depois dei reset ás opções de energia no pc, e voltei a colocar tudo de novo.

Continuo com o problema :(



Cronometrei o tempo que demora a bloquear a tela e deu me 5minutos.

:(
 

Genjuro

Power Member
Sinceramente, já não tenho mais ideias a não ser o "golpe final" de reinstalares/repores o SO...

PS: Um workarround que me lembro é criares uma "Sheduled Task" que corra um script de X em X minutos que simule um click no ecrã, já usei isso em tempos numa VM que trancava a sessão por política após X minutos...
 

MOUSETM

Colaborador
Staff
Genjuro xzk

dado ao que já foi feito, acho que o problema é mais profundo, e só lá vai mesmo com a reinstalação do sistema operativo, recorrer a alternativa como workarrond como foi sugerido é apenas adiar o problema.
 

xzk

Power Member
Sinceramente, já não tenho mais ideias a não ser o "golpe final" de reinstalares/repores o SO...

PS: Um workarround que me lembro é criares uma "Sheduled Task" que corra um script de X em X minutos que simule um click no ecrã, já usei isso em tempos numa VM que trancava a sessão por política após X minutos...

Por acaso fui pesquisar agora:
"automated click so the screen doesnt go off( reddit)"
Na terceira opção aparece o tópico:
https://www.reddit.com/r/Windows10/comments/beun6k
fiz o que diz no tópico: Contas->Opções de início de sessão:

"Necessário início de sessão" ->"Quando o PC for reativado da suspensão"

Mas dizia em letras vermelhas" Não é possível alterar isto por motivos de segurança"

Pesquisei no reddit mais um pouco sobre este problema.
Cheguei ao tópico:
https://www.reddit.com/r/sysadmin/comments/enxc97 "
Settings > Accounts > Sign-in options > Require sign-in
It's greyed out on "When PC wakes up from sleep" and I have not been able to find a way around it. There is a red message saying "Authentication is required when this PC wakes from sleep. Security policies on this PC are preventing you from changing this setting".

o 1º comentário desse link tinha a solução:
"You probably have a security policy set on your computer from adding your work account
Make sure your work account is not added to Settings > Accounts > Access work or school
If you can't remove it then backup your stuff manually and reinstall"

"Aceder a profiss./escolar" -> Removi as contas de universidades que estavam linkadas, e voilá.

Tive a testar e já não tenho o ecrã a suspender.



Desculpem o post grande, fica aqui a solução caso alguém precise.
Aparentemente se tiveres contas de trabalho/escola adicionadas o ecrã bloqueia independentemente dos settings de energia que tenhamos, de forma a proteger os dados penso eu.

Problema resolvido.
 
Última edição:
Topo