1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Code -> dúvidas

Discussão em 'Web Development' iniciada por Anthology, 21 de Junho de 2008. (Respostas: 28; Visualizações: 7592)

Estado do Tópico:
Fechado a novas mensagens.
  1. Anthology

    Anthology Power Member

    Boas,

    Bem eu queria por um video num site, como não sabia o código tive a pesquisar e encontrei.
    Inseri o código e agora sempre que vou ver aparece um quadrado com as dimensões do video todo branco e daí não sai :wow:

    Se alguem souber o código correcto por favor diga.

    Cumpz
     
  2. MPalhas

    MPalhas Power Member

    podes-te ter enganado ao indicar nesse código o caminho para o ficheiro de vídeo.

    ajudava se pusesses aqui o código em questão
     
  3. Anthology

    Anthology Power Member

    Eu estou a ir buscar o video ao youtube.
    Já tive a ver o código

    Código:
    <embed style="width:400px; height:326px;" id="VideoPlayback" 
    align="middle" type="application/x-shockwave-flash" 
    src="[B][U][URL]http://video.google.com/googleplayer.swf?videoUrl[/URL][/U][/B]=http%3A%
    2F%2Fvp.video.google.com%2Fvideodownload%3Fversion%3D0%26
    secureurl%3DvgAAAG7ggqAHSiJjpW0D3w4aYTUFW9M-NghJgbJjy8mhm
    cEoPD-qcpQj2i1OD9xJ6RseUKhCxEKqxhx0jnEJlzf04o-E7gUJc5z_Ur
    OEGJAZeqGJwm5u3VIm_6cNAj34Tj_GwI13lu4V8_s49xIsqh8GGFa2yKI
    pP3DN-u3fZclxMdm3EKZKMqwjROPGPOcl1AMH17kgA5XA503H4WS0Gefm
    G5TKWrRHsY2d3pOatXR_2IxBzGEIq5p-9ybrmmn_o0zj6g%26sigh%3DP
    dJGakwLdDs6uXBefAsAxQMQDls%26begin%3D0%26len%3D3569%26doc
    id%3D8734085858581743191&thumbnailUrl=http%3A%2F%2Fvi
    deo.google.com%2FThumbnailServer%3Fapp%3Dvss%26contentid%
    3Dbc66969d46ff8d61%26second%3D0%26itag%3Dw320%26urlcreate
    d%3D1147452288%26sigh%3DhQlKmBGLA2yrYhrTGpU029bCEHA&p
    layerId=8734085858581743191" allowScriptAccess="sameDomain" 
    quality="best" bgcolor="#ffffff" scale="noScale" 
    wmode="window" salign="TL" FlashVars="playerMode=embedded">
    </embed>
    O código era este, eu apenas mudei a hyperlink
     
    Última edição pelo moderador: 24 de Junho de 2008
  4. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    O player do Google Video apareceu, mas o vídeo não. Não ficou apenas branco, como descreveste ;)
    Podes colocar o vídeo em questão, mesmo?
     
  5. Anthology

    Anthology Power Member

    Eu até posso por.
    Mas o que queria mesmo era o código certo.

    http://youtube.com/watch?v=yZIummTz9mM

    Este é o video que quero por (estou a fazer um site/fan aos linkin park) Talvez até tenha posto o url no sitio errado.
     
  6. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    Código:
    <object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/yZIummTz9mM&hl=en"></param><embed src="http://www.youtube.com/v/yZIummTz9mM&hl=en" type="application/x-shockwave-flash" width="425" height="344"></embed></object>
    Está ali ao lado, em Embed.
     
  7. Anthology

    Anthology Power Member

    Já agora como ponho em auto-play?

    cumpz
     
  8. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    Código:
     
     <object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/yZIummTz9mM&hl=en"></param><embed src="http://www.youtube.com/v/yZIummTz9mM&hl=en&autoplay=1" type="application/x-shockwave-flash" width="425" height="344"></embed></object>
    
    Um conselho: não o faças a menos que seja mesmo preciso. Não há nada pior do que entrar numa página e ter logo música/vídeo a correr ;)
     
  9. Anthology

    Anthology Power Member

    Obrigado, por acaso concordo, odeio principalmente aqueles com músicas irritantes.

    Ultima coisa, gostava de por uma imagem, o código é:

    background {url: ;}

    certo?

    cumpz
     
  10. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    Não necessariamente. Se só queres pôr uma imagem, acho que o ideal é <img src="link" alt="texto alternativo"> :)
     
  11. Anthology

    Anthology Power Member

    Se tiver numa pasta, como faço, "folder"?
     
  12. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    Como assim?
    Se tiveres a imagem numa pasta, ficas com o link como "pasta/imagem.extensão", como por exemplo
    <img src="/images/logo.png" alt="Logotipo">
     
  13. Anthology

    Anthology Power Member

    Desculpas, mas gosto de perceber os códigos que introduzo.
    O que significa esse logotipo?
     
  14. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    Foi só um exemplo de imagem :P a menos que eu tenha percebido mal o que querias.
    a tag é <img src="caminho completo para a imagem" alt="um texto qualquer para a descrever">. Escolhi "logotipo" como podia ter escolhido qualquer outra coisa ;)
     
  15. Anthology

    Anthology Power Member

    já tinha desconfiado...

    Então vai ficar:

    <img src"/Documents and Settings/m1gu3l/Os meus documentos/As minhas imagens/linkin.jpg" alt="BANDA">

    Mas não dá :(
     
  16. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    Não dá porque tens de fazer upload da imagem para o servidor. Se a imagem ficar na mesma pasta que o ficheiro HTML que a chama, então pões só <img src="linkin.jpg" alt="Banda">. Cuidado com o src=, que te está a faltar aí ;)
     
  17. Anthology

    Anthology Power Member

    ah, ok. Obrigadão! :009:

    cumpz
     
  18. Anthology

    Anthology Power Member

    Bem, tenho que voltar a pedir ajuda porque acontece uma coisa totalmente não engracada.
    Este é o código que me foi dado:

    Código:
    <object width="250" height="250"><param name="movie" value="[URL]http://youtube.com/watch?v=hhop9vDL4Cw=en"></param><embed[/URL] src="[URL]http://youtube.com/watch?v=hhop9vDL4Cw=en&autoplay=1[/URL]" type="application/x-shockwave-flash" width="250" height="240"></embed></object>
    e agora queria mudar de video. O normal era apenas mudar o link e substituir pelo o outro.

    <object width="250" height="250"><param name="movie" value="http://youtube.com/watch?v=hhop9vDL4Cw=en"></param><embed src="http://youtube.com/watch?v=hhop9vDL4Cw=en&autoplay=1" type="application/x-shockwave-flash" width="250" height="240"></embed></object>

    Mas assim que mudo o link o "quadrado" onde está o video fica em branco 8|
    Que faço?

    Cumpz
     
  19. Kayvlim

    Kayvlim Undefined Moderator
    Staff Member

    Código:
     
    [noparse]<object width="250" height="250">
    <param name="movie" value="http://youtube.com/watch?v=hhop9vDL4Cw=en"></param>
    <embed src="http://youtube.com/watch?v=hhop9vDL4Cw=en&autoplay=1" type="application/x-shockwave-flash" width="250" height="240"></embed>
    </object>[/noparse]
    
    Isso não está certo.

    Não colocas o link completo como /watch?v=xxx, mas sim /v/xxx! Isto é, quando meteres aí o link, não ponhas youtube.com/watch?v=hhop9vDL4Cw; coloca youtube.com/v/hhop9vDL4Cw.
     
  20. metRo_

    metRo_ Power Member

    Visto já teres os teus problemas resolvidos, só vou postar para dar os parabens ao Kayvlim pela ajuda que te deu... Eu no teu caso tambem queria assim alguem :)
     
Estado do Tópico:
Fechado a novas mensagens.

Partilhar esta Página