1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Colocar o PHP com MySQL no IIS

Discussão em 'Web Development' iniciada por khaluh, 27 de Fevereiro de 2008. (Respostas: 3; Visualizações: 1148)

  1. khaluh

    khaluh Power Member

    Boas

    EStou com problema com a utilização do PHP e do MySQL no IIS.

    Estou a seguir o http://www.ryanwalsh.ca/blog/?p=4#comment-5 e aparece-me a informação da phpinfo(); mas quando faço o ficheiro de teste "mysqltest.php", devolve-me a seguinte mensagem:

    You are not authorized to view this page

    The URL you attempted to reach has an ISAPI or CGI application installed that verifies user credentials before proceeding. This application cannot verify your credentials.
    Please try the following:
    • Contact the Web site administrator if you believe you should be able to view this directory or page.
    • Click the Refresh button to try again with different credentials.
    HTTP Error 401.5 - Unauthorized: Authorization failed by an ISAPI/CGI application.
    Internet Information Services (IIS)

    Technical Information (for support personnel)
    • Go to Microsoft Product Support Services and perform a title search for the words HTTP and 401.
    • Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Configuring ISAPI Extensions, and About Custom Error Messages.
    • In the IIS Software Development Kit (SDK) or at the MSDN Online Library, search for topics titled Developing ISAPI Extensions, ISAPI and CGI, and Debugging ISAPI Extensions and Filters.
    Qual poderá ser o problema?
     
  2. p3dro

    p3dro Power Member

    Tenta verificar se tens o "Anonymous Access" activo.
    Para veres esta opção vais às propriedades do teu "Default Web Site", depois na tab "Directory Security" tens o botão "Edit" ao lado do texto "Enable anonymous access and edit the authentication ...."; de seguida activa a checkbox "Anonymous Access", no username adiciona a conta "IUSR_...." (geralmente é o nome da máquina) e coloca a respectiva password. Activa também a opção "Allow IIS to control password".
     
  3. khaluh

    khaluh Power Member

    Bom dia

    Obrigado pela resposta, a unica parte que não tinha feito era o activar o "Allow IIS..." mas não consigo essa opção...
     
    Última edição: 5 de Março de 2008
  4. khaluh

    khaluh Power Member

    Bom dia

    Após realizar umas pesquisas, verifiquei que o IIS 6.0 tal não é possivel (Allow IIS to control password) http://support.microsoft.com/kb/332167

    Mesmo após seguir o que eles aí dizem e reiniciar o IIS, continuo com o mesmo problema.

    Como poderei corrigir esta situação?
     

Partilhar esta Página