1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Como desactivo o OpenGL?

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por sideshow, 8 de Outubro de 2006. (Respostas: 13; Visualizações: 883)

  1. sideshow

    sideshow Power Member

    Olá ppl!

    A pergunta é mesmo essa: Como desactivo o OpenGL da minha gráfica?

    OS: Ubuntu 6.06
    Gráfica: ATI Radeon 9600 Pro


    Obrigado!!!
     
  2. CR_

    CR_ Power Member

    Só por curiosidade: para quê que queres o OpenGL desactivado? Depois muito programas não dão...
     
  3. sideshow

    sideshow Power Member

    Porque no meu ecran aparecem riscos quando está activado, nem consigo ver videos, metade do video tá com riscos, é um problema k tenho na minha garfica.
    Por ex. no jogo SuperTux nas Options tem lá uma opção para desactivar ou activar o OpenGL. Quando activo aparecem as riscas (vermelhas) por todo o ecran, quando desactivo desaparecem.


    Quais?


    Mas sabes como faço isso?
     
  4. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    Bem, aqui está 1 pedido não muito usual, lol. Muitos querem opengl e veem-se nas horas.
    Talvez a maneira mais rápida seja desactivar a aceleração em si, omitindo a secçao DRI 0666 no /etc/xorg.conf.

    E agora pergunto, como activast a aceleração dessa ati? talvez o problema esteja mesmo aí.
     
  5. sideshow

    sideshow Power Member

    E como se faz isso? Dentro da /etc não tenho nenhum xorg.conf


    Não faço a mínima ideia do que estás a falar. Eu nunca fiz nada... Isto aconteceu depois de um dia ter batito sem querer na placa quando estava a tirar um disco da caixa!

    Obg pela ajuda...
     
  6. CR_

    CR_ Power Member

    Quando tinha a lib do OpenGL quebrada não conseguia abrir, por exemplo, o Open Office.

    O meu conselho é instalares os drivers da ati como deve ser...


    EDI: É /etc/X11/xorg.conf
     
  7. iStarTAC

    iStarTAC Power Member

    Não será melhor instalar uma drivers que suportem OpenGL como deve ser na tua gráfica ?
     
  8. sideshow

    sideshow Power Member

    Acho que não tem a ver com isso, pois também tenho windows e tenho instalado os drivers mais actuais do site e continua a mesma cena, acho que é mesmo do hardware.


    Vou experimentar omitir o DRI 0666
     
  9. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    Se calhar mais vale mandar isso pra RMA (se der) :D

    So 1 pergunta, instalaste os drivers da ati?
    (de facto é /etc/X11/xorg.conf )
     
  10. sideshow

    sideshow Power Member

    Não não dá! Já comprei a placa há uns 5anos e comprei na ***** (na altura ainda não tinha cerebro) lol!!

    Não, mas já tive sem os drivers da ATI e funcionou bem!


    Sim fiz akilo do omitir o DRI e não arrancou o sistema, tive de voltar a por como estava.


    Outra informação que poderá ser importante, os riscos e cenas estranhas que aparecem no ecran também aparecem no Boot do PC, por ex. quando está a ler a memoria a detectar os discos, etc.
     
  11. Sahaqiel

    Sahaqiel Power Member

    o que eu te vou propor agora apenas pode aliviar o problema dos riscos, ou talvez não, assumindo que são artefactos.

    vê esta thread aqui no ubuntu forums.

    Basicamente instala o rovclock conforme o guia ou o readme, e em vez de fazeres overclock faz underclock. Também tive uma 9800 pro que dava problemas ( apesar de não dar na bios, ou na parte de detectar memória e discos ) e o rovclock safou-me até ela "morrer" mesmo.

    Espero que ajude. No mínimo ficas a saber mais sobre o problema da gráfica.
     
    Última edição: 9 de Outubro de 2006
  12. Cooling

    Cooling 1st Folding then Sex

    pera ai que isso de dar riscos e cenas maradas também no Boot...já não tem nada a ver com software...
    isso é a placa nas ultimas.
     
  13. sideshow

    sideshow Power Member

    Nas últimas que já duram uns meses... :p

    Vou tentar aquilo do rovclock..
     
  14. LinuxWarrior

    LinuxWarrior Power Member

    podes sempre tirar os drivers da ati,
    e em vez de fglrx na secção dos drivers (no ficheiro /etc/X11/xorg.conf) usa radeon.
    depois procura a linha em que diz:

    Código:
    load "GLX"
    e comenta-a adicionando um # no inicio.
     

Partilhar esta Página