1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

comportamento estranho de turbo memory

Discussão em 'Windows Desktop e Surface' iniciada por muddymind, 26 de Fevereiro de 2008. (Respostas: 9; Visualizações: 1105)

  1. muddymind

    muddymind 1st Folding then Sex

    Boas!

    Eu ontem adquiri um modulo de memória robson e parecia que aos poucos ia tendo melhorias de desempenho mas agora aconteceu algo estranho...

    Deixei o tatil ligado a noite toda a sacar torrents e agora quando chego ao pé dele deparo-me com o disco a ser usado de forma absurda, a ram a saltitar entre 25% e 100% (quando deveria estar estável à volta de 50% de uso) e a o windows a arrastar-se completamente...

    Depois de abrir o gestor de tarefas e o monitor de recursos deparei-me com isto:

    [​IMG]

    Alguém me sabe dizer porque raios isto tá a acontecer?!?!?

    []
     
  2. Romani48

    Romani48 Power Member

    os dados saltaram todos para o ficheiro de paginação..

    a turbo memory não tem aqui nenhum papel..

    anyway um cold boot fazia lhe bem
     
  3. muddymind

    muddymind 1st Folding then Sex

    Vamos por partes:

    A utilização do portátil foi a mesma que tantas outras vezes e foi a primeira vez que aconteceu... qual é a única diferença entre o agora e o antes? turbo memory...

    Agora tu dizes que saltou tudo para o ficheiro de paginação pois bem... somando todos os conjuntos de memória de todos os processos nem 1,5GB dava por isso como raios é que tnh reportado quase 3GB de memória virtual utilizados? Por isso tem de ter a haver com caches e afins - turbo memory.
    Já para não falar que se fosse isso este estado de lentidão deveria permanecer apenas alguns minutos e não 1h (que foi quando decidi fazer reboot).
    Já agora... reparast bem qual era o processo que estava a utilizar mais o disco? :o

    Após o reboot ele voltou ao mesmo logo no início durante uns 10m e depois passou-lhe.

    Neste momento a utilização da RAM anda sempre pelos 35% enquanto antes andava pelos 50% e sempre que vou fazer alguma coisa ou abrir alguma coisa tenho um delay superior e uma grande utilização do disco rígido...
     
  4. Romani48

    Romani48 Power Member

    a memoria virtual não é igual á memoria fisica.. se tiveres 2Gb de RAM podes ter até 32Gb (acho que é o limite maximo de um sistema Home Premium 32bits) de ficheiro da paginação

    O processo que estava a ser mais usado no disco? era o Utorrent.. a turbo memory não está no disco..

    eu queria dizer é que não acho que seja da turbo memory em cima mas de como ficou configurado pelo sistema o ficheiro no dispositivo..

    faz uma coisa, volta a reconfigurar o ready boost da turbo memory..
     
  5. muddymind

    muddymind 1st Folding then Sex

    Eu falo de uma coisa e tu respondes outra :P Eu sei perfeitamente o que é memória virtual ou não tivesse feito no semestre passado a cadeira de sistemas operativos e anteriormente arquitectura avançada de computadores... seja memória física ou memória virtual, esta tem de ser alocada por algum processo e somando a memória virtual de todos os processos a correr na altura de forma alguma se aproximava dos 3GB que eram reportados. Isto é prática comum quando se usam caches e também acontece no linux mas sinceramente... 1,5GB de cache?!?!? raios isso é muito.... :eek: por exemplo agora está a 1,5GB de mem virtual ocupada quando o total dos processos ocupa 800MB o que já são valores normais...

    Bolas... olha novamente para lá... o processo com mais escritas/leituras é o System... e a mexer onde? no ficheiro de readyboost na unidade do turbo memory... porra pá... isso tá no SS :P

    Reconfigurar pela consola da intel? no way... a própria intel diz para não se configurar nada aí pois aquilo pode levar a comportamento estranhos e o comando para activar/desactivar as cenas não funciona correctamente... acho que foi no anandtech que mostraram como aquilo era uma valente m*rd*...

    Não há outra forma de controlar isso?
     
    Última edição: 26 de Fevereiro de 2008
  6. Romani48

    Romani48 Power Member

    não é muito não... eu normalmente tenho 1.3Gb de Cache.. está normal e tu na SS tinhas mais 100 threads e 10 processos que eu neste momento.. não te esqueças que o Vista tem o Superfetch sempre a trabalhar na cache... quem sabe se o Superfetch se está a ajustar á turbo memory.. isto é normal por exemplo quando metes mais memoria no teu pc.. mas como a memoria RAM é mais rápida que a Turbo memory, não notas esta "lentidão" que te referes.. que se calhar no teu caso até pode ser a mais..


    eu sei.. mas isso estava a acontecer porque tinhas a memoria a 100% utilizada.. isso é porque tiveste um leak de memoria.. algum programa está te a fazer isso... e o Vista usa assim

    RAM do sistema
    Sistema REadyboost (Turbo memory neste caso)
    Ficheiro de paginação

    Como a ram estava instável (devido ao leak, pelo menos parece me ser o problema), o sistema estava a saltar para o Readyboost (estava a escrever na TM), e a preencher te o ficheiro de paginação..

    pois.. mas julgo ser o melhor..

    porém acho que a culpa não foi disso..

    como disse o utorrent está lá também, também claro, estavas a fazer Downloads.. porém eu vi me forçado noutro dia a largar o utorrent porque este me estava a fazer constantes leaks quer de memoria quer do CPU..

    punha me o CPU a 100%, gastava me RAM a mais, e bloqueava.. fechando no gestor de tarefas punha o a 0s.. mas não o fechava... não antes de uma espera de uma media de 3/4 minutos..


    parece me, mais uma vez ser o caso..



    porém, e não obstante disto, fazeres uma limpeza á TM seria o 1º passo a tomar

    cumps :)

    PS: da proxima abre também o "separador" da RAM e vê o que está a consumir tanta RAM..
     
  7. muddymind

    muddymind 1st Folding then Sex

    Bem... agora finalmente está tudo OK... infelizmente fiz uma série de coisas ao mesmo tempo que não me permite saber exactamente o que é que solucionou o problema....

    Tirei o módulo de memória robson;
    Revi as zona indexadas (passei de 85K objectos indexados para 10K);
    Desfragmentei todas as unidades;
    voltei a colocar o módulo de memória robson;

    Agora o disco mal é utilizado :D

    Mesmo com o utorrent a sacar a todo o vapor o sistema mantém-se rápido e sem grande actividade do disco (aumentei o timing do utorrent para escrever no disco) :P
     
  8. Romani48

    Romani48 Power Member

    pah para mim foi o facto de tirares e voltares a por a memoria robson.. por acaso nem perguntei se isso era fácil de remover no pc que estás a ver isso.. porque o facto de removeres e voltares a ligar poe isso tudo "a 0s"

    já agora.. o meu task manager +/- em idle
    [​IMG]
    vez os 1,3Gb em cache.. 1,5 não é preocupante :D
     
  9. muddymind

    muddymind 1st Folding then Sex

    Bem... tirar o módulo fácil não é mas smp é mais garantido que a console da intel.

    O que me tava a chatear não era o tamanho da cache mas sim a performance degradada, utilização MUITO intensa do disco rígido e utilização do cpu muito elevada em idle... Isto em modo bateria era uma lentidão enorme e autonomia mt degradada...

    enfim... agora já tá tudo de volta ao normal e já voltei a ver as melhorias da memória robson...

    []
     
  10. Romani48

    Romani48 Power Member

    eu sei que não era o tamanho da cache que te estava a incomodar ;)

    porém foi o "reset" da memoria ao tira la do portátil que, penso,te resolveu o problema :)
     

Partilhar esta Página