1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Condição Se(...) no excel duvida no teste logico

Discussão em 'Windows 7 e anteriores' iniciada por Andre1979, 16 de Maio de 2009. (Respostas: 9; Visualizações: 21485)

  1. Andre1979

    Andre1979 Power Member

    no excel a função Se(teste_logico;valor_se_verdadeiro;valor_se_falso)

    a minha duvida é que eu queria era fazer um teste logico do genero..

    se A e b < 0,2 então x senão y

    o problema é que só consigo fazer a primeira comparação e preciso de fazer a segunda.
     
  2. f19

    f19 Power Member

    Boas,

    Dentro da primeira fórmula podes colocar outra fórmula, só sei inglês:

    IF ( And(A<0,2;B<0,2);"Verdadeiro";"Falso")

    Presumo que o And seja E.


    Cumps
     
  3. MikeFR

    MikeFR Power Member


    =SE(E(A1>0,2;A2>0,2);"true";"false")

    Fiz em português. :P

    Está correcto assim.
     
  4. Andre1979

    Andre1979 Power Member

    obrigado já testei a coisa.. muito obriigado
     
  5. If Excel

    Boas

    No excel tenho uma formula com o Proc que me devolve um valor (=PROC(C7;A$7:A$2000;B$7:B$2000)

    Quando esta formula nao devolve um valor escreve o seguinte: #N/D

    O que eu queria é que ele nao mostra-se isto, ou seja, já experimentei com o IF, mas não dá:

    =SE(C7>0;"=PROC(C7;A$7:A$2000;B$7:B$2000";" ")

    se for maior que zero escreve o valor, senão fica em branco.

    Sim, nas configurações do excel eu posso nao mostrar estas informações, mas não é isso que pretendo..

    alguma ideia?
     
  6. pena99

    pena99 I fold therefore I AM

    A fórmula que colocas-te apresenta erros, tenta a seguinte:

    =SE(C7>0;PROC(C7;A$7:A$2000;B$7:B$2000);" ")
     
  7. Sim, tem razão relativamente à formula. mas o meu problema continua, mas agora é com o proc. o pretendo é que em função do que eu escrever em c7 ele preencha outra celula com um texto, resultado do proc. O problema, é que o proc, quando não enconta o valor, coloca o resultado abaixo mais próximo. O que quero é que caso o valor procurado nao exista, nao escreva nada.
     
  8. pena99

    pena99 I fold therefore I AM

    Exemplo
    ......A B C
    1- 1 a
    2- 2 b
    3- 3 c
    4- 4
    5- 5 d
    6- 6 g
    7- 7 Aparece o resultado (c7)
    8- 8 k
    9- l

    =PROCV(c7;A1:B9;2;Verdadeiro)

    Resultados:
    c7=1 -> a
    c7=2 -> b
    c7=4 -> 0
    c7=5 -> d
    c7=9 -> 0

    Para o sesultado não aparecer zero coloca a seguinte fórmula: (utilizei os teus valores)
    =SE(PROCV(C7;A$7:B$2000;2;VERDADEIRO)=0;" ";PROCV(C7;A$7:B$2000;2;VERDADEIRO))

    Espero ter ajudado
     
    Última edição: 6 de Janeiro de 2010
  9. Antes de mais obrigado pelo tempo disponibilizado.

    No entanto já consegui o que pretendia.

    A minha fórmula final é esta:

    =SE.ERRO(SE(C7>0;PROCV(C7;'Atribuição de Obras BT'!A$7:B$2000;2;FALSO);" ");"Esta obra não está na Folha de Atribuição de Obras BT")

    o proc deixou de funcionar quando precisava de dados de uma folha para outra.

    Então começei a usar o procv mas depois o meu erro era em vez de usar uma matriz com pelo menos duas colunas, estava a usar só uma coluna e depois ia chamar um vector na coluna dois, quando esta não existia.

    Depois quis ir mais longe, e quando introduzia uma obra que nao existia na listagem, em vez de me aparecer um erro, me aparecesse uma mensagem - conseguido com o if.erro.

    E finalmente está a funcionar bem.

    Mas já que falamos de Excel, há alguma forma de eu partilhar um ficheiro destes com dois utilizadores em rede, em simultâneo?
     
  10. pena99

    pena99 I fold therefore I AM

    Ainda bem que conseguiste chegar a fórmula pertendida.

    Em relação à última questão, sei que é possível, pois utilizo no trabalho, mas não sei fazer.

    Só uma ideia, no Browser Opera dá para transformar os nossos pc em servidores, utilizando o Unite - depois dentro do unite tens uma pasta a onde podes partilhar os ficheiros, se escolheres a opção com password, só quem tiver a password e o link do ficheiro é que tem acesso aos documentos a partilhar.
    Mas julgo que haverá algo muito mais simples para partilhar os ficheiros em rede.

    Um abraço.
     

Partilhar esta Página