1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Dúvidas Configurar asterisk voip + telefones IP

Discussão em 'Dúvidas e Suporte—Internet, Redes, Segurança' iniciada por pepeferrone, 26 de Março de 2009. (Respostas: 11; Visualizações: 1707)

  1. pepeferrone

    pepeferrone Power Member

    Bom dia,

    Eu quero fazer chamadas voip gratis, usando o servidor Trixbox ( Asterisk ) que instalei na empresa onde estou a estagiar e o telefone IP ( k espero receber em breve ) e um outro que provavelmente vai para Inglaterra .Sei que tenho de ter as portas 5060 UDP abertas e tambem da 10000 a 20000 redireccionadas para o servidor do asterisk. O meu problema agora e arranjar as configuracoes ou um manual que me ajude a configurar ( trunks, inbound routes e outbound routes ).

    Agradeco toda e qualquer ajuda :001:
     
    Última edição pelo moderador: 30 de Março de 2009
  2. v0rlon

    v0rlon Power Member

    Prepara-te para algumas dorzinhas de cabeça com o NAT eheheh.

    Tens ip estatico? Se tivesses 1 estático disponível tira o server da NAT e mete publico com uma boa firewall, vai-te poupar algumas chatisses!

    Se so tiveres um estático partilhado em NAT ha algumas configurações importantes. Não me recordo no trixbox mas sei como configurar a pata, por isso se precisares de ajuda diz.

    Vais fazer cahamdas para a PSTN ou é mesmo só voip entre softphones externos e internos?
     
  3. pepeferrone

    pepeferrone Power Member

    Ya tenho ip estatico. Dentro da empresa e para as filiais fala-se gratis, mas nao por voip. Eu vou receber um telefone IP e o outro vai prai para inglaterra, ( mesmo k seja em PT mas fora da rede da empresa vai dar ao memso penso ) depois ligo os 2 ao servidor trixbox para falar entre eles. Por enqt so tenho 1 softphone instalado num pc com o vista.

    Tou com dificuldades em encontrar um manual de configuracao so encontro para ligar as operadoras.

    Obrigado.
     
  4. ticoo-pt

    ticoo-pt Power Member

    Grandes dores de cabeça, mesmo... Estou a tentar configurar o Asterisk+FreePBX aqui em casa, numa ligação MEO Fibra com o Thomson TG784n (10.2.1.L). Dentro da rede consigo ligar para as extensões, mas de fora da rede aleatoriamente não tenho som na chamada, ou então a chamada cai ao fim de um segundo com a indicação de "481 call leg/transaction does not exist" no cSipSimple para Android.

    Já vi instruções para desactivar o SIP ALG no router, coisa que não consegui fazer (e nem sei se isso não teria implicações no serviço de telefone fixo do router), já abri os portos do RTP, mas isto continua a não funcionar.

    Sugestões do que poderei estar a fazer mal? :)
     
    Última edição: 23 de Agosto de 2015
  5. topoman

    topoman Power Member

    Problemas com NAT? Configurar isso é muito simples... Mais do que NAT eu preocupava-me em ter um serviço SIP aberto!
    O mais certo é daqui a uns tempos serem atacados!

    De qualquer forma reditect da porta UDP SIP para registo, aconselho a que mudem no Asterisk para outra que nao a 5060...redirect das portas UDP 10000 a 20000 (eu reduziria este número).
    Extensões de fora activar nat=yes e se necessário no próprio asterisk definir que esta em NAT e qual o IP exterior (que pode ser um nome - dynamic)...
     
  6. ticoo-pt

    ticoo-pt Power Member

    O serviço não vai ficar aberto. Tenho um cliente OpenVPN no smartphone e vou usá-lo para aceder ao SIP.
    Mas chateia-me não conseguir meter isto a funcionar.

    Eu alterei logo os portos, tanto o 5060 como o 10000-20000. De resto está tudo feito como dizes, e continua a não dar.
     
  7. topoman

    topoman Power Member

    Ahh tens OpenVPN... Então é seguro! Porreiro!
     
  8. topoman

    topoman Power Member

    Como tens o OpenVPN? Está em modo Bridge com a rede do asterisk ou estás a fazer NAT?
     
  9. ticoo-pt

    ticoo-pt Power Member

    NAT. Mas com o OpenVPN consigo estabelecer a chamada entre extensões.
     
  10. topoman

    topoman Power Member

    Hummm... Eu utilizo OpenVPN em NAT, e ligo-me a um Asterisk e não tenho problemas...
    Se tens no peer nat=yes muda para nat=no...
    Se não tens o asterisk público nao deves ter nat=yes nas confs gerais do Asterisk nem externalIP configurado...
     
  11. ticoo-pt

    ticoo-pt Power Member

    (Editei a mensagem imediatamente acima porque se calhar não se percebia que me referia ao Asterisk)

    Sim, é como eu, com o OpenVPN funciona bem. Tendo o servidor público é que não. Mas de qualquer forma isto não vai ficar público, mas não queria desistir de perceber porque é que não consigo configurar isto estando o servidor público. :(

    Porquê?
     
  12. topoman

    topoman Power Member

    Eu já utilizei um Asterisk público por trás de um router e sempre funcionou correctamente, atraves do NAT nas confs gerais do asterisk + externalip...
     

Partilhar esta Página