1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. COVID-19 Mantenham-se seguros: Pratiquem distanciamento físico de 2 metros. Lavem as mãos. Usem máscara.
    Informação sobre COVID-19. Ajuda a combater o COVID-19 com o [email protected] e com o [email protected].
    Remover anúncio
  3. Discute connosco a apresentação da AMD com novidades sobre gráficas RDNA 2, em direto a partir das 16:00 (Lisboa)!
    Remover anúncio

Construção de um NAS num HP ProLiant microserver gen8 G1610T

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por luckypt, 23 de Fevereiro de 2017. (Respostas: 753; Visualizações: 50361)

?

Para animar a coisa... Que SO usam no vosso server? :)

  1. CentOS

    4 vote(s)
    8,0%
  2. Debian

    5 vote(s)
    10,0%
  3. FreeNAS

    14 vote(s)
    28,0%
  4. XPEnology

    6 vote(s)
    12,0%
  5. OMV

    1 vote(s)
    2,0%
  6. Windows / Windows Server

    9 vote(s)
    18,0%
  7. Ubuntu Server

    6 vote(s)
    12,0%
  8. Outro

    5 vote(s)
    10,0%
  1. vgoncalves

    vgoncalves Power Member

    tens IP fixo? por acaso não mudou o IP?
     
  2. Não.

    Fiz porcaria ainda maior. Com o problema no boot, tanto mexi que agora deixei de ter as pools :(

    Os discos não me aparecem. Tenho acesso ao freenas, mas não tenhamos discos :(

    Achas que é possível recuperar ?
     
  3. vgoncalves

    vgoncalves Power Member

    em relação ao freenas não te consigo ajudar, eu uso xpenology...

    pode ser que algum membro tenha algumas dicas...
     
  4. At Work

    At Work Power Member

    Exportaste a configuração do FreeNAS?
    Monta imagem que criaste e exporta o ficheiro de configuração.

    Cumps
     
  5. Tenho vários ficheiros exportados da configuração do freenas. Já repus e não consigo ver os discos.

    “Monta a imagem que criaste e exporta...”

    Exporta ou importa?
     
  6. At Work

    At Work Power Member

    Se não queres ter o trabalho de configurar o FreeNAS de raiz, é montares a imagem que fizeste numa VM e depois exportares a configuração e importar para o FreeNAS.

    Há uns anos tive um problema semelhante e como não tinha o FreeNAS a correr em duas pens USB tive que instalar de raiz numa pen e depois importei as pools existentes.
    Do que me recordo a coisa foi simples, perdi algumas horas a googlar e ler documentação, mas não perdi dados.

    Basicamente só tens de adicionar a pool existente.

    https://www.google.pt/search?sxsrf=...MuMC4xLjKYAQCgAQGqAQdnd3Mtd2l6&sclient=psy-ab

    Cumps
     
  7. Mas como consigo fazer isso se deixei de ver os discos no nas?

    O único disco que vejo é a pen do boot :s

    Eu nem me importava de montar o freenas de raiz, o que eu não quero é perder os dados que tenho nos discos!
    Já estive a ver no nas, e não consigo criar pools nem importar, porque não tenho os discos :(

    Há alguma forma de recuperar os dados , para voltar a montar o nas?
     
  8. Gandalf

    Gandalf I fold therefore I AM

    No Freenas tenhas zfs pool? Se sim qual?
    E os discos são reconhecidos na bios/controladora?
     
  9. Em storage, não vejo os discos em lado nenhum!

    Na bios, se for aqui (ver imagem), também não aparecem [​IMG]

    Eu sei que andei na bios a mexer, por causa do boot não estar correto, e talvez tenha feito bosta aí :(

    É possível recuperar a informação do disco de outra forma? Para reconstruir o nas de raiz?
     
  10. Gandalf

    Gandalf I fold therefore I AM

    Enquanto nao aparecerem na bios/controladora nada feito.
    Tenta repor os default settings na bios a ver se aparecem.
     
  11. Mas aqui devia aparecer o disco do boot e também não aparece!
    Será que é aqui que os discos têm de aparecer?

    Mais logo já tiro a pilha para fazer reset.

    Existe alguma forma de recuperar os dados do disco no Windows?
     
  12. dblaster7

    dblaster7 Power Member

    Certamente deve ter alterado de uefi para legacy de alguma forma ou vice versa e deu problema mas um reset á BIOS deve resolver sim.
     
  13. skandal

    skandal Power Member

    Que confusão que para aqui vai.... :P

    Não te preocupes com essa tab de storage, isso só aparece quando tens o HPE AMS instalado no sistema operativo (que não tens no FreeNAS, porque o AMS não tem versão para FreeBSD)

    Deves conseguir importar a pool desde que não tenhas escrito nada nos discos, pelo método que o @At Work mencionou.

    O Gen8 só tem modo BIOS, não tem UEFI.

    O que aconteceu com quase 100% de certeza é que deves ter mudado o controlador interno do Gen8 de modo AHCI para modo RAID. Isto deve ter acontecido quando fizeste reset à BIOS.
    No inicio deste video consegues ver como mudar de RAID mode para AHCI.

    Also, actualiza a BIOS e o iLO para a ultima versão :P
     
    Última edição: 31 de Agosto de 2020
  14. Podes crer, confusão e stress na minha cabeça :(
    Escrever nos discos não o fiz quase decerteza, porque fiz sempre praticamente tudo com eles desligados (la houve uma coisa ou outra que não), mas tentei ter esse cuidado.

    Eu penso que deixei de ter acesso a eles, quando alterei algo relacionado com o arranque no boot, e sei que recebi uma mensagem de alerta (que estupido ignorei), e depois disso quando consegui entrar no freenas já não tinha os discos.

    Tentei repor as configurações mas não resolvi nada. Não retirei a pilha para ele perder as configurações!
    A ver se logo já vejo o vídeo para ver se faço alguma coisa!

    Estou mesmo com medo de não voltar a ter acesso
     
  15. At Work

    At Work Power Member

    Faz o que te indicaram.

    Em casos em que a pool está cifrada, também essa é possível de recuperar. Por isso, mantém a calma e faz as coisas com calma e atenção. Mais vale "perderes" um fim de semana de volta disso e fazeres as coisas com pés e cabeça do que fazeres asneira de forma irreversível ;)

    Cumps
     
  16. Sim, vou fazer o que já me indicaram aqui.
    Assim que fizer dou feedback

    Desde já obrigado pela ajuda
     
  17. Obrigado por tudo!

    Com o vídeo consegui meter tudo on-line

    Mas agora tenho um HDD com erro. Qual a melhor forma de refazer?

    No mirror penso que deveria estar ada1p2 e não /dev/ada1p2


    [​IMG]
     
  18. Ou será mais fácil retirar, formatar e colocar como novo?
     
  19. skandal

    skandal Power Member

    Ou deves ter escrito nesse disco ou o disco está a falhar. Se escreveste no disco sem querer, podes fazer detach, formatar e voltar a fazer attach. Se o disco está a falhar, convém colocar um novo.
     
  20. Escrevi no disco, com o problema que tive com o boot! É isso que me está a parecer.

    Então neste primeiro passo faço detach? É necessário desligar o outro ou posso fazer com tudo ligado?