1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Corrigir config do SuSe9.3 - como ?

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por madafakapc, 20 de Novembro de 2005. (Respostas: 12; Visualizações: 773)

  1. madafakapc

    madafakapc Power Member

    COmo posso corrigir uma config errada penso eu do meu monitor ou placa grafica no SuSe 9.3 visto que quando este vai arrancar começa a piscar o botao de ligado do monitor o qual fica todo preto!

    Julgo ser monitor ou grafica!
     
  2. PrOdG

    PrOdG Power Member

    Acontece-te isso quando tentas entrar no X (modo gráfico), ou ainda antes da inicialização do SO (a parte em que aparecem as linhas "Starting <serviço>... [ok]") ?

    No primeiro caso, provavelmente é um problema da configuração do X, só tens de entrar com um live CD, montar a partição onde tens o SUSE e alterar por aí o ficheiro /etc/X11/xorg.conf convenientemente (ou XF86Config, não sei que ambiente gráfico usa o SUSE).

    No segundo, provavelmente é um problema do framebuffer, tens também de entrar com um live CD, montar a partição e recompilar o kernel alterando o que for necessário (desactiva-o em primeiro lugar para poderes loggar-te sem o live CD, e depois pesquisas o que alterar).
     
  3. diablos

    diablos Power Member

    Provavelmente deve ser quando entras no X, por isso faz assim, quando te aparece o ecrã do grub onde podes escolher o suse metes como parametro adicional "init 3", ele vai carregar o SO sem X fazes login e corres o SaX2, vai te aparecer uma treta gráfica onde configuras sem prob a resolução.
     
  4. madafakapc

    madafakapc Power Member

    ja fiz um boot atraves do suse safemode que me vai para uma linha de comando do linux, faço login em prompt mas depois como devo bootar o SO??qual é o procedimento para arrancar o SO a partir da linha de comando???
     
  5. PrOdG

    PrOdG Power Member

    A linha de comandos É o SO. O que tu queres dizer é arrancar o ambiente gráfico, o X.

    Se não alterares nada nos ficheiros de configuração, não vale a pena tentares entrar no X, porque arrancar por aí ou depois do boot é exactamente a mesma coisa. Quando tiveres alterado alguma coisa, basta escrever 'startx' para começares o ambiente gráfico.
     
  6. madafakapc

    madafakapc Power Member

    e como posso entao corrigir o problema da placa ou monitor? atraves do grub ou linha de commandos?
     
  7. hellaxe

    hellaxe Power Member

    No menu inicial apresentado pelo Grub aparece uma opção de boot de segurança se não estou em erro.
    Escolhe essa opção e depois vais ao /etc/X11/xorg.conf e tens de editar isso para as definições do teu monitor.

    Código:
    #cd /etc/X11/xorg.conf 
    #vi xorg.conf (pode ser outro editor de texto, por exemplo o nano)
              - Verificar o que diz a parte que tem o monitor e a placa grafica
    Outra forma é fazer correr em linha de comandos o
    Código:
    #xorgconfig ou # xorgcfg
    não me recordo agora depois é seguir o que pergunta o configurador.

    Antes de alterares o xorg.conf faz um backup
    Código:
    #mv xorg.conf xorg.conf.bak
    Espero que ajude
     
  8. tkm_[pt]

    tkm_[pt] Power Member

    Podes sempre tentar correr o sax2, como root, nessa mesma linha de comandos. Mas se o problema continuar vais ter que editar o ficheiro à pata para corrigir o problema.
     
  9. madafakapc

    madafakapc Power Member

    temo que o problema que tenho se deve a ter uma placa ati radeon 9200 que pelo que ja li na net da problems no linux! E ja instalei varias versoes de linux e nenhuma corre!
     
  10. PrOdG

    PrOdG Power Member

    Algumas correções menores ao post do hellaxe, no caso de não estares a conseguir:

     
  11. madafakapc

    madafakapc Power Member

    Isso vai-me resolver a questao dos drivers ou la que seja da ATI?
     
  12. hellaxe

    hellaxe Power Member

    PrOdG Tens razão estava a dormir quando fiz aquilo , de certezao. O mv só renomeia o ficheiro.
    Só uma dica: quando fizeres uma correcção creio que é preferivel fazeres um quote do que foi escrito e depois colocas por baixo a tua correcção. Creio que fica mais perceptivel:x2:
     
  13. PrOdG

    PrOdG Power Member

    Eu pus a bold o que corrigi, mas é capaz de se ver melhor as diferenças dessa maneira :)

    Em relação ao tópico, não desistas porque é um "problema de incompatibilidade". Já verificaste tudo? Tens a gráfica suportada no kernel? X bem configurado? Drivers instalados?
     

Partilhar esta Página