1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Deixei de ter acesso à Net

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por Lagaffe, 26 de Março de 2007. (Respostas: 5; Visualizações: 781)

  1. Lagaffe

    Lagaffe Power Member

    Viva.
    Tenho o Ubuntu 6.06 na mesma máquina com Windows XP (dual boot). Até ontem estava tudo a funcionar estável. Uso modem ADSL + router.
    Como de vez em quando tenho necessidade de enviar um fax e não tinha nenhum intalado no meu PC, instalei ontem uma placa fax/modem interno de 56K. Funcionava tudo bem no Windows, mas no Linux deixei de ter acesso à Net através de ADSL. Como não tinha conhecimentos nem tempo para tentar resolver o problema, voltei a tirar a placa de Fax/Modem e quando liguei novamente o PC já tinha acesso à Net (em Windows e em Linux). Estive aliás várias horas a trabalhar em Linux com acesso à Net.
    Hoje liguei o PC e já não tenho novamente acesso à net em linux (mas continuo a ter em windows).
    Uma vez que retirei a placa que me deu problemas e estive tudo bem depois disso, não encontro explicação, nem sei por onde começar a investigar o que estará mal.
    Se alguém me puder dar umas luzes ...
     
  2. LnxSlck

    LnxSlck Power Member

    Deverias por mais informação específica sobre o porquê de não teres net, mas podes começar por aqui o resultado do ipconfig para ver que interfaces de net tens por ai..
     
  3. Lagaffe

    Lagaffe Power Member

    O porquê queria eu saber...:D

    Quando tento fazer ping ao rooter ou ao outro pc da rede local, tenho a mensagen

    connect: Network is unreachable
     
  4. Mektub

    Mektub Power Member

    O teu eth0 não tem um endereço IP4 mas sim um endereço IPv6 que não vai funcionar.

    O aspecto correcto devia ser:

    eth0 Link encap:Ethernet HWaddr 00:10:BC:B6:EB:5A
    inet addr:192.168.1.111 Bcast:192.168.1.255 Mask:255.255.255.0

    Por qualquer razão o teu DHCP não está a obter o endereço IP4.

    Como estás a usar um router tens provavelmente endereços privados tipo 192.168.1.X (Verificar !). Uma solução rápida é dares ao PC com Ubuntu um enderçeo fixo livre com um IP dentro da mesma gama.

    Mektub
     
  5. luxitan

    luxitan Power Member

    experimenta correr o comando dhclient (como root)
     
  6. Lagaffe

    Lagaffe Power Member

    Coloquei IP fixo e já está a funcionar.
    Obrigado :)

    Só gostava de saber porque é que o DHCP deixou de obter o endereço IP4...
     

Partilhar esta Página