1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Dois discos SATA, sem raid.

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por luminoso, 12 de Novembro de 2005. (Respostas: 1; Visualizações: 629)

  1. luminoso

    luminoso To fold or to FOLD?

    Viva.
    Sou iniciado em linux e pela primeira vez estou a usar ubuntu 5.10.
    Instalei inicialmente em um dos meus discos SATA, ligando depois o outro, onde tenciono ter uma partiçao ext3(dizem que é a melhor, sem fragmentaçao) e uns 20Gigas no final da unidade caso precise de windows.

    O que se passa é que nao consigo nem formatar nem atribuir uma partiçao ao meu segundo disco.
    Ligo-o, é detectado e a ferramenta "Sistema->Administração->Discos" nem formata nem consegue montar o disco na pasta /home/disco2 previamente criada por mim, em root.

    Entao instalei a aplicação Gparted. Consigo apagar as partiçoes todas, criar uma partiçao Ext3 como quero mas nao sou capaz de a formatar(mas fica definida), dando o erro:

    Código:
    Unable detect filesystem! Possible reasons are:
    -The file system is damaged,
    -The file system is unknow to libparted,
    -There is no filesystem avaiable (unformated)
    
    Entao tentei usar a consola:
    Código:
    [email protected]:~$ sudo fdisk -l
    Password:
    
    Disk /dev/sda: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cilindros of 16065 * 512 = 8225280 bytes
    
    Dispositivo Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1       14405   115708131   83  Linux
    /dev/sda2           14406       14593     1510110    5  Estendida
    /dev/sda5           14406       14593     1510078+  82  Linux swap / Solaris
    
    Disk /dev/sdb: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cilindros of 16065 * 512 = 8225280 bytes
    
    Dispositivo Boot      Start         End      Blocks   Id  System
    /dev/sdb1             136       14593   116133885   83  Linux
    [email protected]:~$
    
    apaguei e refiz a partiçao com "fdisk /dev/sdb", mas depois...

    Código:
    [email protected]:~$ sudo mkfs.ext3 /dev/sdb1
    mke2fs 1.38 (30-Jun-2005)
    Could not stat /dev/sdb1 --- Arquivo ou diretório não encontrado
    
    The device apparently does not exist; did you specify it correctly?
    [email protected]:~$
    
    Alguem sabe como poderei ultrupassar este problema?
    Obrigado por tudo,

    Luminoso


    [EDIT]
    Eu tinha gentoo antigamente neste disco2, e já quando assim era ubuntu nao lia as partiçoes de gentoo..
     
  2. luminoso

    luminoso To fold or to FOLD?

    Solved, bastou reiniciar... :confused:
     

Partilhar esta Página