1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Drivers de som 5.1

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por kingdom, 1 de Setembro de 2005. (Respostas: 7; Visualizações: 3065)

  1. kingdom

    kingdom 1st Folding then Sex

    Boas pessoal,

    Estou em Ubuntu Linux e não estou a conseguir por a minha Creative SoundBlaster Live! 5.1 a dar som com as 4/5 colunas, mas apenas com duas.

    Isto porque não estou a conseguir instalar os drivers da placa de som aqui no Ubuntu. Fiz download dos drivers 1.0.9b da ALSA para esta placa de som mas não estou a conseguir instalá-los.

    Tentei da forma convencional (para instalar tar.gz):

    cd /directory/directory/...

    /.configure

    make

    make install

    Quando faço configure aparece-me isto:

    Ok, aqui percebo que tenho de fazer qualquer coisa no kernel. Mas exactamente o que?

    Pessoal que já instalou drivers de som em Ubuntu que fale por favor...

    Abraço
     
  2. TuxBoss

    TuxBoss Power Member

    Se instalaste o binário do kernel não tens a source.
    Código:
    apt-get install kernel-source-2.6.xx (sendo xx a versão q quiseres) 
    
    podes fazer "apt-cache search kernel-source" para veres quais as versões disponiveis.
     
  3. kingdom

    kingdom 1st Folding then Sex

    Sim e depois de fazer isso? Já agora qual a versão do kernel que recomendam instalar actualmente?

    Tipo quero ter aqui os passos todos a seguir para não me perder mesmo....
     
  4. kingdom

    kingdom 1st Folding then Sex

    Ok, problema resolvido....afinla não era nada de mais...nem sequer era necessário instalar os drivers da ALSA nem nada que se pareça. Era só mesmo mexer no Surround Mixer...

    Bem pessoal obrigado na mesma...

    Cumps
     
  5. ordisi

    ordisi Banido

    Eu sei que foi um desenterranço e peras mas não preciso abrir um topico novo. Reutiliza-se este.
    A minha duvida é a seguinte, instalei (outra vez) o UBUNTU 7.10 e ele reconheceu automaticamente a minha Sounblaster 24 bit 5.1 externa por usb. Dá som quando ponho a tocar, mas só dá em duas colunas, as duas frontais. Nem a central, nem as traseiras nem o subwoofer tocam. (mais ou menos o mesmo problema).
    Mas... no alsamixer só tenho 2 barras de Volume: PCM e PCM Capt.
    Não há (acho que devia) barras para cada canal de som.
    Alguem me podes ajudar por favor?

    Desde já obrigado.
     
  6. petersaints

    petersaints Power Member

    Dá para adicionar mais controlos ao ALSA Mixer mas agora explicar como sem estar mesmo a fazê-lo ...
     
  7. firedrops

    firedrops Power Member

    carrega no icon com o altifalante para acederes as configurações do mixer. vai nao sei bem aonde para poderes por uma carrada de ticks em diferentes "outputs" (nao sei outro nome para lhe dar). testa activar o wave center, surround, etc, etc, etc......ligas uma carrada deles e vais desligando uns ate teres o que precisas para ter som nas colunas todas. eu normalmente adiciono o wave center, wave surround e mais outro cujo nome nao me ocorre.
     
  8. ordisi

    ordisi Banido

    O problema é fazer aparecer mais barras onde alterar o volume dos canais...
    É que só me aparece mesmo o tal PCM e mais nada.
     

Partilhar esta Página