1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Dual-boot com 2 Discos, ambos com XP (RESOLVIDO)

Discussão em 'Dúvidas e Suporte Técnico PC' iniciada por Techdoctor, 7 de Agosto de 2006. (Respostas: 7; Visualizações: 1355)

  1. Techdoctor

    Techdoctor Power Member

    Já fiz algumas configurações de dual-boot mas nenhuma como esta:

    Tenho 2 Discos com o XP instalado, os quais uso em alternância no mesmo PC
    (um tem net configurada e o outro n, pois é só para trabalho, principalmente edição de vídeo - é para estar mais imune a "viroses"...).

    Como já me começo a fartar do "liga/desliga" e qq dia os cabos de bus vão ficar-me nas mãos, queria ter um menú de arranque para escolher o Disco q pretendo.

    Eu sei q dá para fazer com boot managers mas penso q bastará acrescentar uma linha ao "Boot.ini", o q será muito + simples.
    Só q n estou a conseguir. Alguém sabe dizer-me como se faz?

    São 2 Discos, cada 1 com 4 partições, sendo a 1ª de cada 1 a de arranque e eles estão ambos ligados na Controladora IDE1 (1 como master e outro como slave, obviamente).
    Em cada Disco foi instalado o XP isoladamente (apenas com esse Disco no PC).
    Pretendia, portanto, juntar os 2 e ter opção de boot apenas editando o ficheiro "boot.ini".

    O meu "boot.ini" tem a seguinte configuração:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn


    Nota: já experimentei acrescentar no fim uma linha do tipo
    multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Disco de Edicao de Video" /fastdetect
    mas n resultou...

    Qd me preparo para escolher a 2ª opção no menu de arranque (carrego na seta para baixo) o PC bloqueia imediatamente
    (se escolher a 1ª opção arranca normalmente).

    [​IMG]
     
    Última edição: 8 de Agosto de 2006
  2. Techdoctor

    Techdoctor Power Member

    Será q nunca ninguém experimentou fazer o mesmo?!...

    Já pesquisei na net mas apenas me aparece o q eu já sei:
    - 1 Disco com 2 partições para Windows 98 e XP
    - 1 Disco com 2 partições para 2 Windows XP

    N me aparece nada com 2 Discos!

    Se alguém souber como é para 2 Discos, 1 com 98 (ou outro S.O. qq) e outro com XP q "poste" aqui, pois por analogia deverá dar para chegar lá.

    Obrigado.
     
  3. ec99031

    ec99031 Power Member

    Vai experimentando numeros nos diferentes parenteses... :)

    Desculpa lá mas eu n sei mesmo...
     
  4. Techdoctor

    Techdoctor Power Member

    Já experimentei com:

    multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Disco de Edicao de Video" /fastdetect
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Disco de Edicao de Video" /fastdetect
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Disco de Edicao de Video" /fastdetect
    multi(0)disk(1)rdisk(0)partition(2)\WINDOWS="Disco de Edicao de Video" /fastdetect
    multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Disco de Edicao de Video" /fastdetect
    multi(0)disk(1)rdisk(0)partition(5)\WINDOWS="Disco de Edicao de Video" /fastdetect
    (este pq o 1º Disco tem 4 partições)

    Nenhum funcionou.
    [​IMG]
     
  5. ec99031

    ec99031 Power Member

    Vê este Site:
    http://www.windowsnetworking.com/kb...minTips/Booting/PurposeoftheBOOT.INIFile.html

    Pelo que percebi tem de ser do género:
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Disco de Edicao de Video" /fastdetect

    EDIT:
    ou então
    multi(0)disk(0)rdisk(1)partition(5)\WINDOWS="Disco de Edicao de Video" /fastdetect

    Isto considerando que o 2º disco está logo a seguir ao 1º, porque se tens uma ou mais unidades opticas pelo meio...
     
  6. Techdoctor

    Techdoctor Power Member

    Como podes ver no meu post anterior, a tua 1ª hipótese já foi testada sem sucesso. A 2ª é q n.

    Agora vou ter mesmo q sair e só à noite vou poder ver se resulta. Depois coloco aqui a resposta.

    Obrigado pela dica e pelo link.
     
  7. atlante

    atlante Power Member

    Faz um fdisk e ve qual a organizacao das particoes.

    Assim deve ser mais facil acertares, o principio é igual a 1 só disco, apenas tens que mudar para o hda1 e hda2 conforme a tua tabela de particoes.

    Cumps, abraco
     
  8. Techdoctor

    Techdoctor Power Member

    F****** !!! Resolvido !

    Há vezes q por muito q procuremos a solução para o problema onde é + lógico, só a iremos descobrir num lance de sorte ou experimentando coisas q parecem nada ter a haver.

    No meu caso foi 1 lance de sorte induzido pelo atlante... ( [​IMG] )

    Passo a explicar:

    Em virtude do link indicado pelo ec99031 (o qual muito agradeço) consegui perceber melhor como se definiam os parâmetros do "boot.ini".
    Assim sendo, percebi q:
    -
    "multi" teria q ser "0" para ambas as opções
    - "disk" teria q ser "0" para ambas as opções
    - "rdisk" teria q ser "0" para a 1ª opção e "1" para a 2ª
    - "partition" teria q ser "1" para ambas as opções (se tinha percebido direito)

    Mas isto dava-me uma linha como eu já tinha experimentado e q n havia resultado:
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Disco de Edicao de Video" /fastdetect
    (exactamente a q o ec99031 me indicou tb)

    Pensei q o problema estaria então no nº da partição.
    Havendo programas muito melhores q o "FDISK" (é antigo, é do DOS, n interpreta direito os tamanhos grandes dos Discos, ...), tal como
    o "Partition Magic 8" com o qual estou habituadíssimo a mexer em partições, achei estranho o atlante recomendar-me esse utilitário.
    Mas pq o tenho em boa conta ( [​IMG] ) - temo-nos encontrado em várias threads - resolvi experimentar (talvez desse alguma informação diferente...).

    Arranquei com uma disquete do "Windows 98" e qd tento seleccionar a 2ª opção (arranque sem suporte para CD-ROM) o sistema fica bloqueado!
    Exactamente o q me acontecia com os testes de boot. Estranho...

    Reiniciei e escolhi a 1ª opção. Demorou + 1 pouco (para carregar o suporte de CD-ROM q eu n precisava para nada) e finalmente fiquei com a linha de comandos disponível. Mas qd tento escrever "FDISK" aparece-me no ecran "^D "... ?!

    Percebi q havia problemas em "DOS" (chamemos-lhe assim) com o meu teclado USB. Pois...

    Troquei de teclado com o do outro PC (q é PS2) e... sem problemas para escolher a 2ª opção!

    Voltei a experimentar acrescentar ao "boot.ini" a linha q tinha + lógica
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Disco de Edicao de Video" /fastdetect
    e... BINGO!

    Case closed!


    Um muito obrigado aos 2 q me tentaram ajudar: ec99031 e atlante.
     
    Última edição: 8 de Agosto de 2006

Partilhar esta Página