1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Dúvida excel

Discussão em 'Programação' iniciada por sparxxx1987, 29 de Junho de 2012. (Respostas: 6; Visualizações: 988)

  1. sparxxx1987

    sparxxx1987 Power Member

    Boa noite, Desculpem a dúvida, talvez seja algo ridicula mas nao estou a ver como se faz.

    Tenho duas colunas com cerca de 1000 valores ( B e D), e o meu objectivo é escrever numa outra coluna (os valores de B) apenas se os valores na coluna D estiverem entre 0 e 50 .

    =SE((D3<=50)*E(D3>=0);B3;-1)

    esta era a funçao que estava a pensar usar, mas apresenta o problema de escrever -1 nos valores maiores que 50. O que faz ficar na mesma com 1000 linhas (só quero escrever os menores que 50!
    Eu estava a tentar acrescenta a essa funçao algo de se a anterior for =-1 entao volta para a linha anterior.. Já estou farto de tentar so' que nao sei como se faz.

    Obrigado desde já.
    Cumprimentos
     
    Última edição: 1 de Julho de 2012
  2. nfk

    nfk Power Member

    Talvez haja uma maneira melhor, mas podes fazer um sort nessa coluna e ficas com os -1 todos juntos. Se a ordem for importante, antes do sort acrescenta uma coluna E com os números de 1 a 1000. Depois do sort eliminas os -1 e fazes sort pela coluna E.
     
  3. sparxxx1987

    sparxxx1987 Power Member

    Obrigado, mas será que nao existe nenhuma maneira melhor de resolver isto? Assim fica pouco apresentavel e confuso..
    Fico à espera de respostas,
    muito obrigado
     
  4. Não percebi muito bem o que pretendes. Quando a coluna D for >50, não queres que escreva nada? Se sim, a solução é =SE((D3<=50)*E(D3>=0);B3;""), mas estou com a sensação que não é bem isso que queres.
     
  5. sparxxx1987

    sparxxx1987 Power Member

    Semelhante a isso, mas nesse caso o que acontece e' que fica a celula em branco. o que eu quero e' algo semelhante com

    10 55
    20 35
    5 63
    8 44
    70 55
    22 23

    quero:
    20
    8
    22

    ou seja.. escrever todos os valores da coluna da esquerda caso os valores da coluna da direita sejam menores que 50.

    O que aconteceu com o teu codigo foi o seguinte:

    (vazio)
    20
    (vazio)
    8
    (vazio)
    22

    Não quero essas celulas em branco.. se for possivel claro!

    Muito obrigado,
    Cumprimentos
     
  6. WDFOX

    WDFOX Moderador
    Staff Member

    Aí já terás que recorrer ao VBA. Posso tentar fazer isso, já digo qualquer coisa.

    Será que me podias enviar o ficheiro em causa? Já tenho o modulo disso feito, mas com o teu ficheiro era melhor, porque assim ficava já tudo certo e já não precisavas de fazer mais nada.
     
    Última edição: 3 de Julho de 2012
  7. Pois, ai já terá de ser VBA sim. Se o WDFox tem o módulo já desenvolvido, escuso de o desenvolver, mas vou manter-me atenta a este tópico e se precisares de mais alguma coisa diz.
     

Partilhar esta Página