1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Dúvida instalar 2o router

Discussão em 'Dúvidas e Suporte—Internet, Redes, Segurança' iniciada por gamer06, 31 de Outubro de 2018. (Respostas: 8; Visualizações: 296)

  1. gamer06

    gamer06 Power Member

    Boas,
    Tenho um router da vodafone HG8247H we funciona sem problemas. E tenho um Raspberry que o queria ligar por cabo à rede. Porém o sítio onde ele se encontra não me da jeito passar um cabo até ao router. Daí estar a pensar em colocar um TP-Link wr3420 (que está com openwrt) para fazer esse efeito. Com o openwrt permite me o router ligar por Wifi ao router da vodafone e por sua vez ligar ao raspberry por cabo.

    E preciso de ajuda dos mais entendidos para aqui:

    O router vodafone : 192.168.1.1 que começa atribuir os ip’s apartir do .64

    O openwrt:
    192.168.1.200
    Raspberry:
    192.168.1.201

    Ao fim de muito batalhar já consigo ter isto ligado e a funcionar com internet...
    Mas estando isto ligado desta maneira pelo router da vodafone só consigo ver que o openwrt está ligado e não o raspberry certo? Não há maneira de ver também o raspberry? Porque senão não tenho acesso à rede “Samba” do Rpi.
    Aqui fica o exemplo:

    https://i.gyazo.com/9880971b7fbb77927020f64aeea15727.jpg


    Espero ter me conseguido esclarecer

    Agradeço toda a ajuda
     
    Última edição: 31 de Outubro de 2018
  2. nao estou a entender a tua duvida e acho que o problema está na configuração do samba.
    Se tens o PI na tua rede, só tens de configurar em condiçoes o samba. Mete aqui o samba.conf para ver o que estás a fazer de errado.
     
  3. Slash

    Slash Power Member

    Verifica se não tens nenhuma firewall a correr no openwrt.
     
  4. gamer06

    gamer06 Power Member

    O samba funciona normalmente. Porque se eu ligar o raspberry no router 1 ( principal) tenho acesso ao samba...

    O router 2 é unicamente para o raspberry( ligado por cabo).

    O router 1 e para os outros dispositivos todos.

    A questão é que estando eu estou ligado no router principal não vejo o ip do raspberry sequer. Por tanto também não tenho acesso ao samba
     
    Última edição: 2 de Novembro de 2018
  5. Slash

    Slash Power Member

    Tens a certeza que o outro router não está como router? É que se tiver isso nunca vai funcionar. Tens que o colocar em modo Bridge.

    Não podes usar o Wi-Fi do pi e ligar directamente via Wi-Fi ao router 1?
     
  6. gamer06

    gamer06 Power Member

    Acho que está como repetidor. Porque está a receber sinal por wifi e a partilhar por lan...

    O rpi antes estava ligado por wifi ( ao router 1) só que aos fim de semana parecia que ficava com a rede muito lenta. O acesso a ele tornava se impossível mas ele continuava na rede.
    Então queria experimentar se assim fazia melhorias
     
  7. gatofedorento

    gatofedorento Power Member

    @gamer06 Acho que o tp link está em modo router por isso não permite que vejas o rpi a partir do router da vodafone.
    Porquê não usas uma power line em vez do tp link? Resolvias os teus problemas num instante.
    Cumps
     
  8. gamer06

    gamer06 Power Member

    Isso seria solução mas teria que comprar um Powerline. E se conseguisse configurar o router já não precisava de comprar
     
  9. gatofedorento

    gatofedorento Power Member

    Então tens que garantir que o tp-link está configurado em modo access point e não em modo router. Firewall no tp-link tem que estar desativada.
    Cumps
     

Partilhar esta Página