1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Problema Eclipse

Discussão em 'Windows 7 e anteriores' iniciada por joaomiguel 94, 20 de Setembro de 2012. (Respostas: 11; Visualizações: 1879)

  1. joaomiguel 94

    joaomiguel 94 Power Member

    Boas, eu estou a iniciar-me na programação e foi-me recomendado instalar o eclipse para começar a programar em Java, a questão é que quando o faço o mesmo dá-me um erro quando o inicio. O erro é o seguinte: "Failed to load the JNI shared library "C:\Users\João Miguel\Downloads\eclipse\jre\bin\client\jvm.dll". O que é que faço nessa pasta referida está o ficheiro que eles referem mas continua a dar erro... Cumprimentos
     
  2. Restaurador

    Restaurador Power Member

    Ou tens o dados em duplicado nessa pasta ou então tenta usar a ver de 64bit e não a de 32...
     
    Última edição pelo moderador: 20 de Setembro de 2012
  3. ciberg

    ciberg Moderador
    Staff Member

    Pode não ter nada a ver mas tenta instalar numa pasta que não tenha pastas pelo caminho com acentos e espaços no nome.
     
  4. joaomiguel 94

    joaomiguel 94 Power Member

    Mas é que o próprio eclipse é que me pede para por ali...
     
  5. ciberg

    ciberg Moderador
    Staff Member

    Tu pões o Eclipse onde quiseres, na instalação tens essa opção, e até tens uma versão sem installer que é só fazer unzip e correr e parece-me que é essa que tu tens.

    Até porque não faz sentido estares a correr o eclipse na pasta de downloads.

    Já agora, tu fizeste a extração ou estás a correr o eclipse de dentro do zip?
     
    Última edição: 21 de Setembro de 2012
  6. joaomiguel 94

    joaomiguel 94 Power Member

    Fiz extracção. Mas é assim, antes de haver este erro havia um outro em que ele pedia o java dentro do próprio eclipse, eu pus lá o java e agora dá o erro que referi acima, não sei que fazer...
     
  7. WDFOX

    WDFOX Moderador
    Staff Member

    Coloca a pasta do eclipse na raiz do disco e verifica se continua a dar o erro.
     
  8. ciberg

    ciberg Moderador
    Staff Member

    Seguiste as instruções? - http://wiki.eclipse.org/Eclipse/Installation

    Já agora peço desculpas, tinha a ideia que o Eclipse tinha um installer também disponível além do zip mas atualmente não tem, apesar de ter a ideia que já teve em tempos.
     
  9. joaomiguel 94

    joaomiguel 94 Power Member

    Eu pus a pasta na pasta "programas (x86)" e agora quando tento iniciar o eclipse há um novo erro: " Error:missing `client' JVM at `C:\Program Files (x86)\eclipse\jre\bin\client\jvm.dll'. Please install or use the JRE or JDK that contains these missing components."

    Edit: Ciberg, não segui as instruções mas já tinha feito o download do Java... Nem sabia que havia instruções.
     
  10. ciberg

    ciberg Moderador
    Staff Member

    Já instalaste o JAVA?
     

Partilhar esta Página