1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Dúvidas Endereço IP numa rede

Discussão em 'Dúvidas e Suporte—Internet, Redes, Segurança' iniciada por beherit, 15 de Junho de 2009. (Respostas: 15; Visualizações: 1126)

  1. Boa noite

    Ando com este problema já há um tempão e não consigo resolver... :mad: Agradeço a quem me poder ajudar. É o seguinte:

    Tenho um webserver IIS a correr no XP Pro e um servidor de bases de dados ao qual acedo através do http://localhost/... Ora o que eu queria agora era aceder à mesma através de outros PCs.
    Se o fizer através da net móvel (no PC servidor), basta colocar o ip em vez de "localhost" (no PC cliente) no endereço e tudo funciona bem. O problema é que eu queria disponibilizar o acesso quando estou ligado via wireless a uma rede doméstica da MEO (router Thomson). Nesse caso o IP é do tipo 192.168.x.xxx e quando tento aceder a partir de outro PC, dá-me erro...

    Gostaria então de saber o que preciso de fazer para resolver esta situação. :confused:

    Obrigado!
     
    Última edição: 16 de Junho de 2009
  2. kales

    kales Power Member

    Boas,
    A máquina onde corre o IIS é melhores colocares Ip fixo (IP interno). Depois no router tens de abrir a porta 80 para o Ip da máquina para que de fora possam aceder.
     
  3. Boas Kales

    Coloquei um ip fixo no pc (192.168.1.104), fiz um forward à porta 80

    [​IMG]

    e adicionei o ip 192.168.1.104 a esse forward.

    Mas mesmo assim não funciona...

    Alguma sugestão? Estarei a fazer alguma coisa errado?

    Obrigado!
     
    Última edição: 17 de Junho de 2009
  4. MrRCS

    MrRCS Power Member

    experimenta http://192.168.1.104/ no próprio pc

    isso pode estar a fazer bind só ao 127.0.0.1 (localhost)
     
  5. Boas MrRCS

    É como dizes, no próprio pc funciona!...

    O que devo fazer?

    Obrigado!
     
  6. proactiv32

    proactiv32 Power Member

    Se estás a tentar aceder a partir de outro computador dentro da tua rede, não necessitas de fazer forward de porta nenhuma. :S

    Se, efectivamente o servidor HTTP está a funcionar sem problemas (e à escuta na porta 80), deverá ser apenas necessário configurares a tua firewall para aceitar ligações a partir dessa porta.

    Já se quiseres "abrir" o servidor para alguém de fora da tua rede interna (Internet), aí é que terás de realizar o forwarding da porta para o IP do teu computador. Mas pelo que entendi, não me parece ser o caso...
     
  7. Boas proactiv32

    Na verdade eu quero abrir o servidor para acesso externo, fora da rede interna. No entanto, nem consigo aceder a partir de pc's na rede nem fora dela... simplesmente não carrega. Se abrir no próprio pc funciona correctamente... :mad:

    Imagino que o servidor esteja a funcionar correctamente, já que localmente, com localhost / 127.0.0.1 ou com o ip da máquina funciona bem...
     
    Última edição: 17 de Junho de 2009
  8. Boas

    Novos desenvolvimentos quanto a este assunto.

    Desliguei a firewall do windows no computador server e neste momento consigo aceder à aplicação a partir de outros computadores sem problemas, quando estou com a net móvel.

    Quando estou com ligado à rede e ainda com a firewall do windows desligada, consigo aceder à aplicação mas apenas dos computadores dentro da mesma rede, mas não consigo externamente...

    O que é que este comportamento vos parece? Será que é a firewall do router? Mas com o forward não devia ter ultrapassado essa questão? É que o que se passa é exactamente o mesmo que acontece quando tenho a firewall do windows ligada e com a net móvel.

    Agradeço a vossa ajuda!

    Abraço!
     
  9. nram

    nram Power Member

    "mas não consigo externamente..." ??? Externamente, é de outro PC e de outra rede?
    Se sim, depende do IP que estás a introduzir... Acho que devias trabalhar com DNS...
     
  10. MrRCS

    MrRCS Power Member

    comecemos pelo básico, a partir de outro pc, na mesma rede.

    ping 192.168.1.104
    tracert 192.168.1.104
     
  11. Quando digo "externamente" quero dizer de outro pc, fora da rede. O ip que estou a introduzir é 192.168.1.104.

    MrRCS,
    A partir de outro pc, na mesma rede, com 192.168.1.104 funciona.

    Mas se for de outro pc, fora da rede, já não dá...


    No caso de usar internet directamente a partir de um modem (neste caso um modem da Zapp), com o ip que obtenho em http://www.omeuip.com/ , tudo funciona bem, isto é, é possível aceder à aplicação a partir de outros pcs (naturalmente fica mto lenta, pq o upload do isp é lentissimo, mas funciona!).

    Agradeço a vossa paciencia! :beerchug:
     
  12. nram

    nram Power Member

    O teu erro está aqui... Lool EXTERNAMENTE, tens que introduzir o teu IP EXTERNO.... e não o interno. E pronto..
     
  13. Então coloco simplesmente o IP do router nram?
     
  14. É isso nram! Já funciona! Contudo, fica lentíssimo... Quase tão lento como com o modem da Zapp, e naquele caso é com o Meo 16Mb... Será porque o pc servidor está a aceder via wireless e ficaria mais rapido se estivesse ligado directamente pela RJ45?

    Obrigado!
     
  15. nram

    nram Power Member

    Isso já tem a ver com a ligação... o teu upload....


    Quando atrás disses-te, ip do router, eu diria NÃO, ip externo. O que o ISP te dá... normalmente 85.***.***.***
     
  16. Pois foi esse ip que usei!

    Certo! Obrigado pela ajuda!

    Abraço!
     

Partilhar esta Página