1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Erro 0xc0000142 após longas horas de repouso

Discussão em 'Windows 7 e anteriores' iniciada por Chopstick, 4 de Julho de 2008. (Respostas: 5; Visualizações: 2316)

  1. Chopstick

    Chopstick I fold therefore I AM

    Boas, quando deixo o Pc ligado uma tarde ou uma noite inteira, depois quando volto ao Pc todas as aplicações do tray estão bloqueadas, não lhes consigo aceder e quando tento ligar outra aplicação dá-me o erro: 0xc0000142 (A aplicação falhou ao inicializar-se correctamente) e não dá para executar nenhuma aplicação, o Pc nem desliga, mas o rato funciona e vejo o ambiente de trabalho. Fica como se deixásse-mos o pc ligar e depois desligásse-mos os discos rígidos e ele só conseguisse aceder á Ram.. mas ele está definido para nunca desligar os discos.

    Ajudem-me, experts.

    P.S: Não me mandem formatar pois fiz isso há menos de um mês, e a outra instalação já tinha este problema.
     
    Última edição: 4 de Julho de 2008
  2. Tenta esta workaround. Pelo que sei etm resolvido esse tipo de problemas
    Ao que parece tem a ver com o numero de processos (programas) que tens a correr.

    Deixa depois uma palavra para saber se resolveu


    Um abraço

    [email protected]


    Application failed to initialize properly (0xc0000142)


    Archived from groups: microsoft.public.win2000.general

    I found a MS Knowledge Base article that seems to be in line with this
    problem. If you seem to have a set limit on the number of applications
    that you can have running concurrently, adjust your "desktop heap"
    parameters in the registry.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session
    Manager\SubSystems

    Modify the section that says "SharedSection=x,y,z"
    X is the "system-wide" heap
    Y is the "per-session" heap
    Z is the "non-interactive" heap

    These numbers are in kb.

    When I modified mine I had to increase the Z parm, but for you I would
    imagine it would be both X and Y.

    MS says that if you increase the parms around 256 or 512 it should be
    enough to run your apps.

    I had a similar problem with one of my servers that was running a
    nightly scheduled task that would open MS access and run a macro.
    Problem was the script would never close access when it was done. I
    ended up having 34 copies of access running before my scripts stopped
    working.

    Given I really didn't HAVE to adjust the heap parameters; just closing
    the access instances would have done the trick. But it worked before I
    found out I had all those programs running.

    MS KB824422
    http://support.microsoft.com/defau [...] -us;824422

    Article references a problem with SQL server, but in reality it applies
    to any program.
     
  3. Chopstick

    Chopstick I fold therefore I AM

    chego á parte do subsystem, a partir daí não sei o que fazer, alguem pode explicar?
     
  4. Boas amigo.

    Presumo que estejas no XP, eu estou no vista pelo que as chaves no registo aqui são
    ligeiramente diferentes.


    Deverás ter agora uma chave chamada SubSystems, na janela do lado esquerdo.
    Na janela do lado direito tens uma chave chamada "WINDOWS".

    Seleciona-a com o rato e clica com o botão direito. Escolhe a opção Modify.
    Estarás a modificar o registo do windows nessa chave.

    No meio dessa lenga lenga toda aparece algures escrito
    SharedSection=1024,3072,512

    ou parecido... isto é do meu windows.

    tens de alterar os dois primeiros valores para, por exemplo o dobro.

    Se tiveres 512,512,256 poe 1024,1024,256

    Okapa?

    Um abraço

    [email protected]
     
  5. Chopstick

    Chopstick I fold therefore I AM

    opa porreiro, tá feito, pus: SharedSection=2048,6144,512

    espero que resolva, obrigado
     
  6. Chopstick

    Chopstick I fold therefore I AM

    essa modificação originou outro problema e o problema original não foi resolvido

    agora fica a ligação á net "pasmada", sem fazer nada, passado umas horas....fica o utorrent a pensar nas estrelas...

    para além de se eu o deixar ainda mais horas, fica todo o sistema como na descrição inicial...

    não me apetece nada voltar ao vista....dava ainda mais problemas que este
     

Partilhar esta Página