1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Erro a instalar ia32-libs

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por PsySc0rpi0n, 12 de Dezembro de 2012. (Respostas: 9; Visualizações: 2935)

  1. PsySc0rpi0n

    PsySc0rpi0n Power Member

    Estou com o Debian Wheezy e ao tentar instalar as ia32-libs deu-me o seguinte erro:

    Código:
    Os pacotes a seguir têm dependências não satisfeitas:
     ia32-libs : Depende: ia32-libs-i386 mas não é instalável
    E: Não foi possível corrigir problemas, você tem pacotes mantidos (hold) estragados.
    Como posso resolver isto?
     
  2. Darkangel_13

    Darkangel_13 Power Member

    tenta isto
    sudo dpkg -i *deb
     
  3. nfk

    nfk Power Member

  4. PsySc0rpi0n

    PsySc0rpi0n Power Member

    Isso instalaria todos os .deb que estivessem na directoria onde eu estivesse penso eu, não é?

    Já estive a ver o link que deixaste mas estou com receio de estar a fazer downgrade ao sistema inteiro sem necessidade...

    Da última vez que instalei o Debian no PC não tive estes problemas...

    E mesmo que quisesse fazer isso, eu não tenho o file /etc/apt/preferences para alterar...
     
    Última edição: 13 de Dezembro de 2012
  5. PsySc0rpi0n

    PsySc0rpi0n Power Member

    Ninguém me consegue mostrar mais nenhuma alternativa?
     
  6. nfk

    nfk Power Member

    Leste a informação sobre multiarch?
     
  7. carlitos

    carlitos Power Member

    Debian está a mudar para multiarch e pelo que entendi nas listas de discussão o pacote "ia32-libs" e " ia32-libs-gtk" não existirá na versão Wheezy.
    Para ter aplicações 32bit em 64bit é preciso adicionar a arquitectura i386. O processo que fiz foi:

    #dpkg --add-architecture i386
    #apt-get update
    #apt-get -u dist-upgrade

    com esta actualização desinstala as ia32-libs e instala varios pacotes libs-i386.
     
  8. PsySc0rpi0n

    PsySc0rpi0n Power Member

    Já fiz isso e o Teamviewer continua a não dar para instalar...

    Diz que o Teamviewer depende do ia32-libs e não instala...
     
  9. PsySc0rpi0n

    PsySc0rpi0n Power Member

    Não sei porque é que o outro dia tentei o apt-get install -f e não resultou e agora já resultou...

    Enfim...
     
  10. PsySc0rpi0n

    PsySc0rpi0n Power Member

    Estou a dar comigo em maluco de novo... Tive que instalar o Debian de novo e estou novamente com problemas com as ia32-libs.

    Tentei a seguinte sequência:

    Código:
    sudo dpkg --add-architecture i386
    sudo apt-get update
    sudo apt-get -f install
    
    Acabou por instalar uma carrada de pacotes i386 que eu não pedi mas as ia32-libs não instalou!

    Não sei... Nunca acerto com isto à primeira...
     

Partilhar esta Página