1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Erro Instalação

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por SOAD, 23 de Novembro de 2005. (Respostas: 6; Visualizações: 677)

  1. SOAD

    SOAD Power Member

    Boas pessoal,
    eu sou novo em linux e estou com uma problema na instalaçao de programas.
    neste momento estou a tentar instalar o compilador ghc e ocorre-me o seguinde erro durante a instalaçao.

    checking build system type... i686-pc-linux-gnulibc1
    checking host system type... i686-pc-linux-gnulibc1
    checking target system type... i686-pc-linux-gnulibc1
    Which we'll further canonicalise into: i386-unknown-linux
    checking for perl... /usr/bin/perl
    checking if your perl works in shell scripts... yes
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether ln -s works... yes
    checking for sed... /bin/sed
    checking for gcc... gcc
    checking for C compiler default output... configure: error: C compiler cannot create executables
    See `config.log' for more details.


    alguem me pode ajudar?
     
  2. HecKel

    HecKel The WORM

    sacaste mesmo o binário (ou algo que lhe valha) ou tás a tentar instalar pelo app-get? tenta pelo app-get, o app-get vai-te buscar as dependências todas, e cheira-me que isso é falta de uma dependência.

    Desculpa "ajudar" dando um caminho mais fácil do que tentar "ensinar" a resolver..., mas também não saberia fazer doutra forma :(

    abraços, HecKel
     
  3. xtr3me

    xtr3me Power Member

    é apt-get e não app-get e isso só bomba se ele tiver derivados de debian
    ;)

    Para o prob deve tar no gcc ... tenta reinstalar isso e cuidado para n instalares uma versão instável ..
     
  4. HecKel

    HecKel The WORM

  5. SOAD

    SOAD Power Member

    antes de mais muito obrigado pelas ajudas, mas so queria pedir, se poderem claro, para tentar dar uma esplicação passo a passo de como e isso do apt-get eu n faco mm ideia do que e isso, e a 1a vez que tenho linux.

    obrigado
     
  6. xtr3me

    xtr3me Power Member

    O apt-get é o gestor de pacotes do debian e distros baseadas nele (como o ubuntu).
    Para usares o apt-get tens algums comandos muito básicos:

    apt-get install <programa> - para instalar
    apt-cache search ... - para procurar nos repositórios por tudo o que contenha ...
    apt-get remove <programa>
    etc

    Recomendo-te a leres os mans das coisas. Podem dar uma grande ajuda e quase todos os comandos de linux têm man(uais).

    man <comando>

    Cumps
     
  7. SOAD

    SOAD Power Member

    ja resolvi o problema...era a falta de muitos pacotes...instalei com o sypnatic
     

Partilhar esta Página