1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

erro no apt-get (ubuntu)

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por h3NtRiX, 1 de Outubro de 2006. (Respostas: 9; Visualizações: 2220)

  1. h3NtRiX

    h3NtRiX Power Member

    boas!

    instalei recentemente o ubuntu e reparei que ao fazer apt-get install para programas conhecidos como amule ou amsn, este não os encontrava. pensei que fosse das sources, então andei para la a brincar com o ficheiro sources.list e adicionei uns quandos mirrors que encontrei na net. fui entao instalar o amule, começou a instalar e depois apareceu uma mensagem a dizer que nao podia continuar a instalaçao porque dependia de uns ficheiros quaisquer. entao saquei outra source.list, fez update bem mas ao tentar instalar o amule outra vez aparece a mesma coisa. tentei instalar o amsn e acontece o mesmo. a mensagem é a seguinte:

    [email protected]:/# apt-get install amule
    A Ler Listas de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Você deve querer executar `apt-get -f install' para corrigir isto:
    Os pacotes a seguir têm dependências não satisfeitas:
    amule: Depende: libcrypto++5.2c2a mas não vai ser instalado
    Depende: libwxgtk2.6-0 (>= 2.6.1.2ubuntu2) mas não vai ser instalado
    Depende: amule-common (= 2.1.0-1ubuntu1) mas não vai ser instalado
    libc6: Depende: tzdata mas não está instalável
    libc6-i686: Pré-Depende: libc6 (= 2.3.6-0ubuntu20) mas 2.3.6.ds1-4 está para ser instalado
    E: Dependências não satisfeitas. Tente `apt-get -f install' sem nenhum pacote (ou especifique uma solução).
    [email protected]:/# apt-get -f install
    A Ler Listas de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Corrigindo dependências... falhou.
    Os pacotes a seguir têm dependências não satisfeitas:
    libc6: Depende: tzdata mas não está instalável
    libc6-i686: Pré-Depende: libc6 (= 2.3.6-0ubuntu20) mas 2.3.6.ds1-4 está instalado
    E: Erro, pkgProblemResolver::Resolve gerou falhas, isto pode ser causado por pacotes mantidos (hold).
    E: Impossível corrigir dependências



    dava jeito uma ajudinha :)

    cumprimentos

    ps: e ao fazer apt-get remove aparece isto:

    [email protected]:/# apt-get remove amule
    A Ler Listas de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    O pacote amule não está instalado, então não será removido
    Você deve querer executar `apt-get -f install' para corrigir isto:
    Os pacotes a seguir têm dependências não satisfeitas:
    libc6: Depende: tzdata mas não está instalável
    libc6-i686: Pré-Depende: libc6 (= 2.3.6-0ubuntu20) mas 2.3.6.ds1-4 está para s er instalado
    E: Dependências não satisfeitas. Tente `apt-get -f install' sem nenhum pacote (o u especifique uma solução).
    [email protected]:/#

     
  2. alexmgarcia

    alexmgarcia Power Member

    Faz o seguinte em root:
    mv /etc/apt/sources.list /etc/apt/sources.list.bkp
    gedit /etc/sources.list

    E colas lá:
    Código:
    ## Ubuntu Mirrors by ClubeLinux.org ##
    #
    deb http://pt.archive.ubuntu.com/ubuntu/archive/ dapper main restricted universe multiverse
    deb-src http://pt.archive.ubuntu.com/ubuntu/archive/ dapper main restricted universe multiverse
    deb http://darkstar.ist.utl.pt/ubuntu/archive/ dapper main restricted universe multiverse
    deb-src http://darkstar.ist.utl.pt/ubuntu/archive/ dapper main restricted universe multiverse
    deb ftp://ftp.rnl.ist.utl.pt/ubuntu/ dapper main restricted universe multiverse
    deb-src ftp://ftp.rnl.ist.utl.pt/ubuntu/ dapper main restricted universe multiverse
    
    ## Ubuntu - Updates ##
    #
    deb http://pt.archive.ubuntu.com/ubuntu/archive/ dapper-updates main restricted universe multiverse
    deb-src http://pt.archive.ubuntu.com/ubuntu/archive/ dapper-updates main restricted universe multiverse
    deb http://darkstar.ist.utl.pt/ubuntu/archive/ dapper-updates main restricted universe multiverse
    deb-src http://darkstar.ist.utl.pt/ubuntu/archive/ dapper-updates main restricted universe multiverse
    deb ftp://ftp.rnl.ist.utl.pt/ubuntu/ dapper-updates main restricted universe multiverse
    deb-src ftp://ftp.rnl.ist.utl.pt/ubuntu/ dapper-updates main restricted universe multiverse
    
    ## Ubuntu - Security ##
    #
    deb http://pt.archive.ubuntu.com/ubuntu/archive/ dapper-security main restricted universe multiverse
    deb-src http://pt.archive.ubuntu.com/ubuntu/archive/ dapper-security main restricted universe multiverse
    deb http://darkstar.ist.utl.pt/ubuntu/archive/ dapper-security main restricted universe multiverse
    deb-src http://darkstar.ist.utl.pt/ubuntu/archive/ dapper-security main restricted universe multiverse
    deb ftp://ftp.rnl.ist.utl.pt/ubuntu/   dapper-security main restricted universe multiverse
    deb-src ftp://ftp.rnl.ist.utl.pt/ubuntu/ dapper-security main restricted universe multiverse
    #backports
    deb http://darkstar.ist.utl.pt/ubuntu/archive/ dapper-backports main restricted universe multiverse
    deb-src http://darkstar.ist.utl.pt/ubuntu/archive/ dapper-backports main restricted universe multiverse
    Salvas e fechas.

    Depois em root ainda:
    apt-get update

    E depois tenta esses installs, btw, convem às vezes fazeres um upgrade à distribuição:
    apt-get dist-upgrade

    Se tiveres alguma dúvida diz. :)

    Cumps,
     
  3. h3NtRiX

    h3NtRiX Power Member

    muito obrigado :D. vou tentar isso e depois digo se funcionou.

    mais uma vez, obrigado.
     
  4. h3NtRiX

    h3NtRiX Power Member

    o problema continua. tá aqui o que apareceu la na consola:

    [email protected]:/etc/apt# apt-get update
    Ign http://pt.archive.ubuntu.com dapper Release.gpg
    Ign http://pt.archive.ubuntu.com dapper-updates Release.gpg
    Obter:1 http://darkstar.ist.utl.pt dapper Release.gpg [189B]
    Obter:2 http://darkstar.ist.utl.pt dapper-updates Release.gpg [1 89B]
    Obter:3 http://darkstar.ist.utl.pt dapper-security Release.gpg [ 189B]
    Obter:4 http://darkstar.ist.utl.pt dapper-backports Release.gpg [189B]
    Obter:5 ftp://ftp.rnl.ist.utl.pt dapper Release.gpg [189B]
    Ign http://pt.archive.ubuntu.com dapper-security Release.gpg
    Obter:6 http://darkstar.ist.utl.pt dapper Release [34,8kB]
    Ign http://pt.archive.ubuntu.com dapper Release
    Obter:7 http://darkstar.ist.utl.pt dapper-updates Release [30,9k B]
    Ign http://pt.archive.ubuntu.com dapper-updates Release
    Obter:8 http://darkstar.ist.utl.pt dapper-security Release [30,9 kB]
    Obter:9 ftp://ftp.rnl.ist.utl.pt dapper-updates Release.gpg [189 B]
    Obter:10 http://darkstar.ist.utl.pt dapper-backports Release [23 ,3kB]
    Ign http://pt.archive.ubuntu.com dapper-security Release
    Obter:11 http://darkstar.ist.utl.pt dapper/main Packages [619kB]
    Ign http://pt.archive.ubuntu.com dapper/main Packages
    Ign http://pt.archive.ubuntu.com dapper/restricted Packages
    Obter:12 ftp://ftp.rnl.ist.utl.pt dapper-security Release.gpg [1 89B]
    Ign http://pt.archive.ubuntu.com dapper/universe Packages
    Ign http://pt.archive.ubuntu.com dapper/multiverse Packages
    Ign http://pt.archive.ubuntu.com dapper/main Sources
    Obter:13 http://darkstar.ist.utl.pt dapper/restricted Packages [ 4571B]
    Obter:14 http://darkstar.ist.utl.pt dapper/universe Packages [24 58kB]
    Ign http://pt.archive.ubuntu.com dapper/restricted Sources
    Ign http://pt.archive.ubuntu.com dapper/universe Sources
    Ign http://pt.archive.ubuntu.com dapper/multiverse Sources
    Ign http://pt.archive.ubuntu.com dapper-updates/main Packages
    Ign http://pt.archive.ubuntu.com dapper-updates/restricted Packa ges
    Ign http://pt.archive.ubuntu.com dapper-updates/universe Package s
    Obter:15 ftp://ftp.rnl.ist.utl.pt dapper Release [34,8kB]
    Ign http://pt.archive.ubuntu.com dapper-updates/multiverse Packa ges
    Ign http://pt.archive.ubuntu.com dapper-updates/main Sources
    Ign http://pt.archive.ubuntu.com dapper-updates/restricted Sourc es
    Ign http://pt.archive.ubuntu.com dapper-updates/universe Sources
    Ign http://pt.archive.ubuntu.com dapper-updates/multiverse Sourc es
    Ign http://pt.archive.ubuntu.com dapper-security/main Packages
    Ign http://pt.archive.ubuntu.com dapper-security/restricted Pack ages
    Obter:16 ftp://ftp.rnl.ist.utl.pt dapper-updates Release [30,9kB ]
    Ign http://pt.archive.ubuntu.com dapper-security/universe Packag es
    Ign http://pt.archive.ubuntu.com dapper-security/multiverse Pack ages
    Ign http://pt.archive.ubuntu.com dapper-security/main Sources
    Ign http://pt.archive.ubuntu.com dapper-security/restricted Sour ces
    Obter:17 http://darkstar.ist.utl.pt dapper/multiverse Packages [ 95,2kB]
    Ign http://pt.archive.ubuntu.com dapper-security/universe Source s
    Obter:18 http://darkstar.ist.utl.pt dapper/main Sources [255kB]
    Obter:19 ftp://ftp.rnl.ist.utl.pt dapper-security Release [30,9k B]
    Ign http://pt.archive.ubuntu.com dapper-security/multiverse Sour ces
    Obter:20 http://darkstar.ist.utl.pt dapper/restricted Sources [1 478B]
    Obter:21 http://darkstar.ist.utl.pt dapper/universe Sources [975 kB]
    Err http://pt.archive.ubuntu.com dapper/main Packages
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper/restricted Packages
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper/universe Packages
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper/multiverse Packages
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper/main Sources
    404 Not Found
    Obter:22 ftp://ftp.rnl.ist.utl.pt dapper/main Packages [619kB]
    Err http://pt.archive.ubuntu.com dapper/restricted Sources
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper/universe Sources
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper/multiverse Sources
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper-updates/main Packages
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper-updates/restricted Packa ges
    404 Not Found
    Obter:23 http://darkstar.ist.utl.pt dapper/multiverse Sources [4 6,6kB]
    Obter:24 http://darkstar.ist.utl.pt dapper-updates/main Packages [71,4kB]
    Err http://pt.archive.ubuntu.com dapper-updates/universe Package s
    404 Not Found
    Obter:25 http://darkstar.ist.utl.pt dapper-updates/restricted Pa ckages [14B]
    Obter:26 http://darkstar.ist.utl.pt dapper-updates/universe Pack ages [15,4kB]
    Obter:27 http://darkstar.ist.utl.pt dapper-updates/multiverse Pa ckages [866B]
    Obter:28 http://darkstar.ist.utl.pt dapper-updates/main Sources [46,3kB]
    Err http://pt.archive.ubuntu.com dapper-updates/multiverse Packa ges
    404 Not Found
    Obter:29 http://darkstar.ist.utl.pt dapper-updates/restricted So urces [14B]
    Obter:30 http://darkstar.ist.utl.pt dapper-updates/universe Sour ces [3129B]
    Obter:31 http://darkstar.ist.utl.pt dapper-updates/multiverse So urces [427B]
    Obter:32 http://darkstar.ist.utl.pt dapper-security/main Package s [50,5kB]
    Obter:33 http://darkstar.ist.utl.pt dapper-security/restricted P ackages [4496B]
    Err http://pt.archive.ubuntu.com dapper-updates/main Sources
    404 Not Found
    Obter:34 http://darkstar.ist.utl.pt dapper-security/universe Pac kages [20,8kB]
    Err http://pt.archive.ubuntu.com dapper-updates/restricted Sourc es
    404 Not Found
    Obter:35 http://darkstar.ist.utl.pt dapper-security/multiverse P ackages [2159B]
    Obter:36 http://darkstar.ist.utl.pt dapper-security/main Sources [12,4kB]
    Err http://pt.archive.ubuntu.com dapper-updates/universe Sources
    404 Not Found
    Obter:37 http://darkstar.ist.utl.pt dapper-security/restricted S ources [960B]
    Obter:38 http://darkstar.ist.utl.pt dapper-security/universe Sou rces [3126B]
    Obter:39 http://darkstar.ist.utl.pt dapper-security/multiverse S ources [520B]
    Obter:40 http://darkstar.ist.utl.pt dapper-backports/main Packag es [7276B]
    Obter:41 http://darkstar.ist.utl.pt dapper-backports/restricted Packages [14B]
    Obter:42 http://darkstar.ist.utl.pt dapper-backports/universe Pa ckages [13,9kB]
    Obter:43 http://darkstar.ist.utl.pt dapper-backports/multiverse Packages [1130B]
    Obter:44 http://darkstar.ist.utl.pt dapper-backports/main Source s [3510B]
    Obter:45 http://darkstar.ist.utl.pt dapper-backports/restricted Sources [14B]
    Obter:46 http://darkstar.ist.utl.pt dapper-backports/universe So urces [5750B]
    Obter:47 http://darkstar.ist.utl.pt dapper-backports/multiverse Sources [653B]
    Err http://pt.archive.ubuntu.com dapper-updates/multiverse Sourc es
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper-security/main Packages
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper-security/restricted Pack ages
    404 Not Found
    Obter:48 ftp://ftp.rnl.ist.utl.pt dapper/restricted Packages [45 71B]
    Err http://pt.archive.ubuntu.com dapper-security/universe Packag es
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper-security/multiverse Pack ages
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper-security/main Sources
    404 Not Found
    Obter:49 ftp://ftp.rnl.ist.utl.pt dapper/universe Packages [2458 kB]
    Err http://pt.archive.ubuntu.com dapper-security/restricted Sour ces
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper-security/universe Source s
    404 Not Found
    Err http://pt.archive.ubuntu.com dapper-security/multiverse Sour ces
    404 Not Found
    Obter:50 ftp://ftp.rnl.ist.utl.pt dapper/multiverse Packages [95 ,2kB]
    Obter:51 ftp://ftp.rnl.ist.utl.pt dapper/main Sources [255kB]
    Obter:52 ftp://ftp.rnl.ist.utl.pt dapper/restricted Sources [147 8B]
    Obter:53 ftp://ftp.rnl.ist.utl.pt dapper/universe Sources [975kB ]
    Obter:54 ftp://ftp.rnl.ist.utl.pt dapper/multiverse Sources [46, 6kB]
    Obter:55 ftp://ftp.rnl.ist.utl.pt dapper-updates/main Packages [ 71,4kB]
    Obter:56 ftp://ftp.rnl.ist.utl.pt dapper-updates/restricted Pack ages [14B]
    Obter:57 ftp://ftp.rnl.ist.utl.pt dapper-updates/universe Packag es [15,4kB]
    Obter:58 ftp://ftp.rnl.ist.utl.pt dapper-updates/multiverse Pack ages [866B]
    Obter:59 ftp://ftp.rnl.ist.utl.pt dapper-updates/main Sources [4 6,3kB]
    Obter:60 ftp://ftp.rnl.ist.utl.pt dapper-updates/restricted Sour ces [14B]
    Obter:61 ftp://ftp.rnl.ist.utl.pt dapper-updates/universe Source s [3129B]
    Obter:62 ftp://ftp.rnl.ist.utl.pt dapper-updates/multiverse Sour ces [427B]
    Obter:63 ftp://ftp.rnl.ist.utl.pt dapper-security/main Packages [50,5kB]
    Obter:64 ftp://ftp.rnl.ist.utl.pt dapper-security/restricted Pac kages [4496B]
    Obter:65 ftp://ftp.rnl.ist.utl.pt dapper-security/universe Packa ges [20,8kB]
    Obter:66 ftp://ftp.rnl.ist.utl.pt dapper-security/multiverse Pac kages [2159B]
    Obter:67 ftp://ftp.rnl.ist.utl.pt dapper-security/main Sources [ 12,4kB]
    Obter:68 ftp://ftp.rnl.ist.utl.pt dapper-security/restricted Sou rces [960B]
    Obter:69 ftp://ftp.rnl.ist.utl.pt dapper-security/universe Sourc es [3126B]
    Obter:70 ftp://ftp.rnl.ist.utl.pt dapper-security/multiverse Sou rces [520B]
    Obtidos 9626kB em 1m23s (115kB/s)
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper/main/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper/restricted/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper/universe/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper/multiverse/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper/main/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper/restricted/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper/universe/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper/multiverse/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-updates/main/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-updates/restricted/binary-i386/Packages.gz 404 Not Foun d
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-updates/universe/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-updates/multiverse/binary-i386/Packages.gz 404 Not Foun d
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-updates/main/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-updates/restricted/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-updates/universe/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-updates/multiverse/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-security/main/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-security/restricted/binary-i386/Packages.gz 404 Not Fou nd
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-security/universe/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-security/multiverse/binary-i386/Packages.gz 404 Not Fou nd
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-security/main/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-security/restricted/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-security/universe/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/archive/dists /dapper-security/multiverse/source/Sources.gz 404 Not Found
    A Ler Listas de Pacotes... Pronto
    E: Falhou o download de alguns ficheiros de índice, foram ignora dos ou os antigos foram usados em seu lugar.
    [email protected]:/etc/apt# apt-get install amule
    A Ler Listas de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Você deve querer executar `apt-get -f install' para corrigir ist o:
    Os pacotes a seguir têm dependências não satisfeitas:
    amule: Depende: libcrypto++5.2c2a mas não vai ser instalado
    Depende: libwxgtk2.6-0 (>= 2.6.1.2ubuntu2) mas não vai ser instalado
    Depende: amule-common (= 2.1.0-1ubuntu1) mas não vai se r instalado
    libc6: Depende: tzdata mas não está instalável
    libc6-i686: Pré-Depende: libc6 (= 2.3.6-0ubuntu20) mas 2.3.6.d s1-4 está para ser instalado
    E: Dependências não satisfeitas. Tente `apt-get -f install' sem nenhum pacote (ou especifique uma solução).
    [email protected]:/etc/apt# sudo apt-get -f install
    A Ler Listas de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Corrigindo dependências... falhou.
    Os pacotes a seguir têm dependências não satisfeitas:
    libc6: Depende: tzdata mas não está instalável
    libc6-i686: Pré-Depende: libc6 (= 2.3.6-0ubuntu20) mas 2.3.6.d s1-4 está instalado
    E: Erro, pkgProblemResolver::Resolve gerou falhas, isto pode ser causado por pacotes mantidos (hold).
    E: Impossível corrigir dependências
    [email protected]:/etc/apt#
     
  5. alexmgarcia

    alexmgarcia Power Member

    Hmm, faz assim... abre o Synaptic e procura por essas dependências e vê se tens algo a bloquear, caso tiveres, manda desbloquear e tenta novamente.

    Cumps,
     
  6. iGama

    iGama Ubuntuguide Translator

    Usa o comando:

    sudo aptitude -f install

    ou

    sudo aptitude install programa

    O aptitude resolve melhor as dependencias que o apt-get.
     
  7. TuxBoss

    TuxBoss Power Member

    Instalaste um programa qualquer que não estava nos repositories oficiais e que tem como dep uma versão mais avançada da libc do que as disponiveis nas oficiais. Agora estás a tentar instalar outra coisa oficial que tem como dep uma versão mais antiga.

    A solução é encontrares qual é o prog que tem como dep 2.3.6.d s1-4 e desinstalares.
    Depois já consegues fazer o update.
     
  8. h3NtRiX

    h3NtRiX Power Member

    tu és Deus! 1000 obrigados.

    obrigado aos outros também por tentarem ajudar :D
     
  9. alexmgarcia

    alexmgarcia Power Member

    Problem Solved então. :002:
     
  10. h3NtRiX

    h3NtRiX Power Member

    sim. podem fechar.

    muito obrigado a todos. :D
     

Partilhar esta Página