1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Error 404 - server nagios

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por jbrasil, 17 de Julho de 2007. (Respostas: 9; Visualizações: 1557)

  1. jbrasil

    jbrasil Power Member

    Amigos,
    Boa tarde !
    Instalei o nagios for server.

    [[email protected] conf]# ps -aux | grep nagios
    Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
    nagios 5744 0.0 0.1 2244 1020 ? Ss 20:00 0:01 /usr/share/nagios/bin/nagios -d /usr/share/nagios/etc/nagios.cfg
    nagios 12743 0.0 0.1 2240 1016 ? Ss 20:13 0:00 /usr/share/nagios/bin/nagios -d /usr/share/nagios/etc/nagios.cfg
    nagios 5424 0.0 0.0 2244 496 ? S 21:15 0:00 /usr/share/nagios/bin/nagios -d /usr/share/nagios/etc/nagios.cfg
    nagios 5425 0.0 0.1 2884 700 ? S 21:15 0:00 /usr/share/nagios/libexec/check_ssh -t 20 30.30.30.180
    root 5468 0.0 0.1 2928 748 pts/0 R+ 21:15 0:00 grep --color nagios

    Porém, está ocorrendo erro ao tentar abrir os link's do nagios.
    Mensagem:

    Objeto não encontrado!
    A URL requisitada não foi encontrada neste servidor. O link na página referida parece estar com algum erro ou desatualizado. Por favor informe o autor desta página sobre o erro.
    Se você acredita ter encontrado um problema no servidor, por favor entre em contato com o webmaster.
    Error 404
    10.0.0.171
    Apache/2.2.3 (Mandriva Linux/PREFORK-1mdv2007.0)

    Vcs, tem alguma dica ?
    Obrigado.
    José Roberto.
     
  2. luxitan

    luxitan Power Member

    e configuraste o apache para servir as páginas do nagios?
     
  3. jbrasil

    jbrasil Power Member

    Sim...
    Veja as configurações:

    ScriptAlias /nagios/cgi-bin/ /usr/share/nagios/sbin
    <Directory "/usr/share/nagios/sbin/">
    AllowOverride AuthConfig
    Options ExecCGI
    Order allow,deny
    Allow from all
    </Directory>


    Alias /nagios/ /usr/share/nagios/share/
    <Directory "/usr/share/nagios/share">
    Options None
    AllowOverride AuthConfig
    Order allow,deny
    Allow from all
    </Directory>

    Obrigado.
    José Roberto.
     
  4. xupetas

    xupetas Banido

    ele não está a dir a directoria correcta. o erro 404 é isso mesmo.
    procura nos logs de apache onde eh q ele está a ir a ver se da pra perceber onde te enganaste.
     
  5. jbrasil

    jbrasil Power Member

    Verifiquei o log do apache
    /var/log/httpd
    tail -f error_log

    [Wed Jul 18 19:30:10 2007] [error] [client 10.0.0.75] script not found or unable to stat: /usr/share/nagios/sbinstatus.cgi, referer: http://10.0.0.171/nagios/side.html

    Porém, ainda não consegui resolver este problema.
     
  6. Condez

    Condez [email protected] Member

    As directorias que colocaste na configuração do apache, existem?

    Faz um search ao File System e vê onde está localizado o ficheiro "sbinstatus.cgi".
     
  7. xupetas

    xupetas Banido

    ve se a directoria onde tens esse .cgi do nagios tem permissões de execução para files CGI
     
  8. jbrasil

    jbrasil Power Member

    Não existe este arquivo.
    [[email protected] /]# find / -name sbinstatus.cgi*
    Que problema estranho...
     
  9. luxitan

    luxitan Power Member

    parece que falta uma barra aqui no meio /usr/share/nagios/sbinstatus.cgi

    vê se existe um status.cgi em usr/share/nagios/sbin , se existir experimenta na configuração do apache substituir:

    ScriptAlias /nagios/cgi-bin/ /usr/share/nagios/sbin

    por:

    ScriptAlias /nagios/cgi-bin/ /usr/share/nagios/sbin/ (nota a barra no fim)
     
  10. jbrasil

    jbrasil Power Member

    Deu certo !!!
    Muito obrigado.
    Valeu.
    :-)
    []'s
    José Roberto.
     

Partilhar esta Página