1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Excel Office XP - ajuda com fórmula

Discussão em 'Windows Desktop e Surface' iniciada por P4ulo, 22 de Setembro de 2007. (Respostas: 15; Visualizações: 4934)

  1. P4ulo

    P4ulo Power Member

    Boas,
    Precisava de uma ajuda no seguinte;
    Tenho a seguinte estrutura numa tabela:
    Office XP Português
    ----A -----------------B-----------------C
    1 ZONA----------CÓDIGO OCORRÊNCIA
    2 coimbra -------------3
    3 aveiro ---------------15
    4 coimbra -------------15
    5 aveiro ----------------3
    6 coimbra -------------10
    7 aveiro ---------------15

    (usei os "-" apenas para ajustar as duas colunas A e B)

    Preciso de contar quantos códigos 15 ocorreram em coimbra por exemplo - via fórmula (uma vez que a tabela real tem mais de 4mil linhas e a ideia é não ter que usar os filtros automáticos)

    Tentei o contar.se / bdcontar / contar.val etc - conheço muito pouco acerca destas fórmulas ou das fórmulas excel em geral.

    Não encontro forma de fazer contagem de acordo com a condição: contar quantas vezes o código "15" ocorreu apenas em coimbra.

    Obg pela atenção!
    P4ulo
     
  2. jpccaldas

    jpccaldas Power Member

  3. P4ulo

    P4ulo Power Member

    Também tentei esse!

    Não digo que estas fórmulas não funcionem o problema é não ter conhecimento em profundidade para as utilizar, do pouco que conheço e tentei nenhuma faz o que pretendo!
    :<
    Obg!
    P4ulo
     
  4. TosteX

    TosteX Powre Membre

    Isso é com um Contar.Se.

    Não sei a fórmula de cor, mas o excel tem um help que ajuda.
     
  5. ec99031

    ec99031 Power Member

    Formula Contar.se.s:

    =contar.se.s(A1:A##;"coimbra";B1:B##;15)

    É esta a formula (só tens de substituir os ## pelo numero onde acaba a lista), vá lá, papinha toda feita, as pra proxima usa a ajuda que vem com o editor de fórmulas do excel... :)
     
  6. P4ulo

    P4ulo Power Member

    Antes de mais obg!
    Já percorri a ajuda do Excel sem sucesso, daí vir ao forum pedir a ajuda!
    o contar.se.s não existe como fórmula mas permite colocar uma segunda condição...

    E infelizmente não dá resultado, recebo um #NOME? como erro :<
    zona valor
    coimbra 15
    aveiro 15
    coimbra 15
    aveiro 15
    coimba 15
    coimbra 15

    =contar.se.s(A2:A7;"coimbra";B2:B7;"15") - Erro #NOME?

    Não acredito que não dê para fazer este tipo de coisa no excel :lol:

    Abraço,
    P4ulo
     
  7. ec99031

    ec99031 Power Member

    Bom, já descobri porque te dá erro... O problema é que eu experimentei isso no office 2007 e o contar.se.s() só está disponível nesta versão, nas anteriores não existe esta fórmula.
    Assim, torna-se mais dificil o teu problema, mas já tenho a solução:

    =SOMA((A2:A##=A1)*(B2:B##=B1)

    Coloquei =A1 e =B1 de modo a que sempre que queiras contar outro valor qualquer é só mudar na célula correspondente (A1, para as células A e B1 para as células B)

    O problema, é que se metes assim a fórmula no excel ela não funciona correctamente, mas isto é um truque...

    Agora o truque:
    Depois da fórmula estar toda direitinha (principalmente a referencia às células correctas), em vez de dares enter para aplicar a fórmula, fazes ctrl+shift+enter e voilá!!!

    Exlicação: na verdade esta não estás a somar os valores existentes nas células, mas sim criaste uma array que será contada (essecialmente é isso que o ctrl+shift+enter faz, em vez de um falor cria um array). Corrijam-me se estou errado, mas acho que é isso que acontesse...

    E pronto... já aprendi umas coisitas novas em excel e tu tb :)...
     
  8. P4ulo

    P4ulo Power Member

    Oias!
    O que pretendo fazer não é somar mas sim contar;
    Testei a fórmula e mesmo usando o ctrl shift enter e com a fórmula contar.se, não me dá erro mas apresenta o valor 0.

    A lógica da fórmula seria:
    contar b:b;"15" se a:a=coimbra
    Contar na coluna B quantas vezes aparece o "15" SE na coluna A corresponder a "coimbra". De forma a ignorar todos os 15 que na coluna adjacente tenha outra zona que não "coimbra"

    Coluna A Coluna B
    aveiro 15
    coimbra 15
    aveiro 15
    coimbra 15
    coimbra 15
    aveiro 15
    viseu 15
    neste exemplo o resultado deveria ser: 3 ocorrências do número 15 em coimbra.
    com a fórmula contar.se(b:b;"15") ele vai contar TODOS os 15 que encontrar (7) e eu não quero! Quero que me diga quantos 15 ocorreram em Coimbra apenas.

    Obg pela atenção!
    :004:
    P4ulo
     
  9. P4ulo

    P4ulo Power Member

    A seguinte fórmula quando em vez de números existem letras funciona...
    Na seguinte tabela:

    A B
    COIMBRA F
    AVEIRO F
    AVEIRO F
    COIMBRA F
    AVEIRO F

    =SOMA((A2:A5="COIMBRA")*(B2:B5="F")
    O resultado é 2 (era exactamente isto que eu precisava; se utilizar a fórmula CONTAR ele ignora a condição e apresenta 4)
    Quando troco LETRAS por NÚMEROS não dá!!!

    !
    Se virem alguma luz apitem p.f.

    P4ulo
     
  10. DisturbedGod

    DisturbedGod 1st Folding then Sex

    A fórmula =SOMA((A2:A5="COIMBRA")*(B2:B5="F") que deste resulta, apenas tens que fazer uma pequena mudança.

    Para funcionar tem que ficar =SOMA((A2:A5="COIMBRA")*(B2:B5=15) , apenas retiras as aspas que tens no "F". Isto porque ao pores as aspas estás a dizer ao excel que o que está dentro delas é texto e não número, fazendo com que o excel não consiga encontrar o #VALOR.
     
  11. P4ulo

    P4ulo Power Member

    Solução correcta!

    Muito obrigado DisturbedGod - era mesmo a questão da aspas!

    Abraço!
    :002:
    P4ulo
     
  12. ec99031

    ec99031 Power Member

    A formula que pus lá em cima dá... Apenas, para te tirar trabalho, e no caso de quereres contar o numero de ocorrencias de outra cidade e/ou numero, indexei os critérios ás células A1 (para a cidade) e B1 (para o numero). Uma vez que a indexação era feita a essas duas células (A1 e B1) não precisavas de aspas nem nada, porque o excel tratava-te automaticamente de definir a formatação de cada uma delas...
     
  13. Eu preciso de uma pequena ajuda...
    Preciso de uma fórmula ou forma que me faça o seguinte:
    Imaginem que tenho uma tabela com 8 colunas de dados em que na última eu tenho apenas Deferido/Indeferido/Em Análise. Eu keria uma formula que, consoante o estado do processo me pintasse toda a linha com uma determinada cor de fundo. Isto dápara fazer com a formatação condicional mas apenas para a célula onde está escrito...
     
  14. P4ulo

    P4ulo Power Member

    Tens razão, mas conforme estava a fórmula:
    =SOMA((A2:A##=A1)*(B2:B##=B1)
    eu não estava a chegar lá.
    =SOMA((A2:A7="coimbra")*(B2:B7=15)) ctrl shift enter
    assim seria mais simples =))

    Obg por tudo !

    P4ulo
     
  15. ec99031

    ec99031 Power Member

    Também dá para a linha toda... selecionas as linhas todas e na formatação condicional colocas as condições.
    Por exemplo, supondo que tens 10 linhas com dados, selecionas a primeira, metes assim:
    http://rapidshare.com/files/58150676/excel_formata__o.JPG.html

    e depois copias a formatação para as outras linhas...
     
  16. Muito Obrigado. Coisa tão simples...
     

Partilhar esta Página