1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

[Excel] Problema com fórmula Contar.Se.S

Discussão em 'Programação' iniciada por AFA23, 23 de Novembro de 2008. (Respostas: 10; Visualizações: 2505)

  1. AFA23

    AFA23 Power Member

    Boa tarde. Tenho 1 ficheiro de excel em que 2 fórmulas funcionam se forem feita com referencia directa, se for indirecta já não funciona...

    =CONTAR.SE('1'!E:E;D2)

    FUNCIONA E DEVOLVE 251



    =CONTAR.SE(DESLOCAMENTO( '1'!1:1048576;0;CORRESP($B$2;'1'!$1:$1;0... 1000000;1);1)

    FUNCIONA E DEVOLVE 242

    A junção das 2 num Contar.Se.S dá erro. A fórmula da junção das duas é esta:

    =CONTAR.SE.S(DESLOCAMENTO( '1'!1:1048576;0;CORRESP($B$2;'1'!$1:$1;0... 1000000;1);1;'1'!E:E;D2)

    Está aqui em baixo um ficheiro do excel com o exemplo prático.

    http://www.mediafire.com/download.php?5k...

    Desde já muito obrigado, estou a tentar avançar no programa mas estou parado há algum tempo a tentar resolver este problema.
     
    Última edição: 24 de Novembro de 2008
  2. Ruben_Barbosa

    Ruben_Barbosa Power Member

    =CONTAR.SE.S(DESLOCAMENTO(M!$1:$1048576;0;CORRESP( $C$2;M!$3:$3;0)+2;1000000;1);"A";M!C:C;C9)

    ve esta ultima parte no intervalo de criterios2 M!C:C;C9 nao me parece que isto teja bem ;)
     
  3. AFA23

    AFA23 Power Member

    Não está bem porquê? M!C:C é a coluna C:C da folha M! do meu ficheiro e C9 é o campo que tem o valor a verificar. O que está mal? :(
     
  4. Ruben_Barbosa

    Ruben_Barbosa Power Member

    na minha opinião tu vais buscar isso a outra sheets/ folha certo sendo assim como é que tens um tabela na folha M! com a seleção dos Campos C:C :S tens de ter no minimo qualquer coisa assim $c$2:$f$2. PK C:C não é nada digo eu.
     
  5. AFA23

    AFA23 Power Member

    Não percebi... C:C é uma referencia para toda a coluna C do C1 ao C99999999999999. Não estou a perceber onde está o erro.

    Por exemplo a fórmula =CONTAR.SE(M!C:C;C9) funciona perfeitament, qual é a diferença para o contar.se.s?

    Obrigado.
     
  6. AFA23

    AFA23 Power Member

  7. Ruben_Barbosa

    Ruben_Barbosa Power Member

    E melhor partilhares o excel digo eu assim torna-se mais facil resolver ;)

    cumps
     
  8. AFA23

    AFA23 Power Member

  9. AFA23

    AFA23 Power Member

    Ninguém teve este problema ou tem uma ideia como ajudar?
     
  10. Ruben_Barbosa

    Ruben_Barbosa Power Member

  11. AFA23

    AFA23 Power Member

Partilhar esta Página