1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Excel

Discussão em 'Windows Desktop e Surface' iniciada por lopesrb, 2 de Abril de 2007. (Respostas: 14; Visualizações: 1402)

  1. Gostava da vossa ajuda para um coisa.
    Eu tenho 2 tabelas no excel com numeros uma ao lado da outra.
    do tipo:
    A B
    1 23
    2 27
    3 54
    4 62
    5 12


    Eu queria uma função que encontrasse um numero da coluna b e devolvesse o valor da coluna A a partir de uma celula que cujo numero não é sempre o mesmo
    TIPO:

    A B C
    1 23 valor
    2 27 Função
    3 54
    4 62
    5 12
    Imaginemos que o valor é 23 eu quero uma função que procure o valor 23 na coluna b e que me de o valor ao lado ou seja 1. se o valor fosse 27 a solução da função seria 2...

    Não sei s fui mt complicado :p

    Agradeço já antecipadamente:)
     
  2. DisturbedGod

    DisturbedGod 1st Folding then Sex

    Tens uma função para isso que se chama procv ou vlookup, conforme o idioma do teu excel.

    Mas nesse caso que disseste não iria resultar. Tens que trocar as colunas.

    A coluna A tem que ficar com os valores que queres encontrar. E a coluna B terá que ficar com os valores que queres que a função te dê.

    E nesse caso a função seria algo como isto: =procv(A1;A1:A5;2;Falso) .

    Onde A1 é o valor que queres procurar na tua tabela.
    O intervalo A1:A5 é a tua tabela inteira.
    O 2 é a coluna da tabela que queres que a função te dê o valor. Se tivesses 5 colunas na tabela, e se o teu valor pretendido estivesse na quinta coluna, terias que introduzir o 5.
     
  3. não sei porque fiz tudo igual mas não dá
    s eu puser o valor de 1 em vez de 2 ele obviamente dá-me o numero que eu procuro,
    mas s eu puser o valor 2 ele dá #ref!:(:(:(:(:(:(:(:(:(
    #REF!
    #REF!
    #REF!
     
  4. DisturbedGod

    DisturbedGod 1st Folding then Sex

    O que pode ter acontecido é que ao passares a fórmula para a célula abaixo a fórmula pode ter perdido os valores de referência da coluna e da linha.

    O que tens a fazer é acrescentar um $ (que bloqueia os valores no intervalo que escolheste) antes da referência da coluna e da linha. Ficando a fórmula algo como isto: =procv(A1;$A$1:$A$5;2;Falso) .
     
  5. nem assim.
    aparece o mesmo o que eu já tentei foi o seguinte:
    =PROCV(O59;O5:O54;2;0)
    =PROCV(O59;O5:O54;2;FALSO)
    =PROCV(O59;O5:O54;2;0)
    =PROCV(O$59;O$5:O$54;2;FALSO)
    =PROCV(O59;O$5:O$54;2;0
    =PROCV(O$59;O$5:O$54;2;0)
    não faço a minima ideia porque isto acontece.
     
  6. DisturbedGod

    DisturbedGod 1st Folding then Sex

    Nesse caso só estas a utlizar uma coluna como intervalo, em vez do 2 terá que ser o 1.

    Como tens o intervalo de O5 a O54, ele só esta a ver nessa coluna o valor que introduziste e a dar o mesmo valor. Não te está a fazer a correspondência entre linhas.
     
  7. DisturbedGod

    DisturbedGod 1st Folding then Sex

    Sorry, enganei-me lá em cima no exemplo fórmula...

    =procv(A1;A1:B5;2;Falso)

    Deve ficar algo como isto... :|
     
  8. era isso agora já dá.
    só tenho mais um problema.
    se houver numeros repetidos ele só me dá o primeiro:(
     
  9. DisturbedGod

    DisturbedGod 1st Folding then Sex

    Não te consigo ajudar nesse problema.
     
  10. obrigado na mesma
     
  11. Sniper2

    Sniper2 Power Member

    boas,

    tenho uma outra maneira para a tua questão.:x2:

    Se tiveres 2 células disponíveis para a procura, podes utilizar a função CORRESP (na versão PT, não sei qual a correspondente na versão ING :rolleyes: ).

    Portanto... visto que queres inserir (para procurar) um numero na lista, e queres que te devolva o numero ao lado, fazes o seguinte:

    As 2 células vão funcionar, uma de comparação e a outra de devolução, ou seja uma vais colocar o número que procuras e a outra vai devolver "o número ao lado".:D

    Desta forma imaginemos que vais deixar que as 2 células sejam a A1 e B1,
    A1 - número a procurar / B1 - número devolvido

    B1= CORRESP(+A1;<intervalo dos números a procurar>;<intervalo dos números a devolver>):wow:

    depois é só colocar na célula A1 os valores que procuras. E voilá, já está. :009:

    Espero que não tenha sido confuso, mas se tiveres alguma dúvida :007: , estamos aqui.:004:

    Cumps
    Sniper2
     
  12. Thanks Sniper2

    foste claro como a agua e funciona ás mil maravilhas;) mx s o numero a procurar for repetido e corresponder a numeros diferentes ele dá-me sempre o primeiro:(
    Não há nenhuma formula que de para que isto não aconteça tipo alguma com SE !!!!
     
  13. Sniper2

    Sniper2 Power Member

    Estive agora a testar, e de facto fugiu-me esse pormenor.:wow:

    E descobri mais um "pormenor", se o numero não existir ela (função) atribui outros número que constam na coluna :wow: , tenho de ver isso melhor.

    Se bem que este meu "pormenor" penso que seja bastante fácil de resolver, :rolleyes: implementando umas funções SE.

    Em relação à tua chamada de atenção, não estou de momento a "ver" uma possível solução, mas tenho de analisar bem as funções existentes.:rolleyes:

    Agora de momento, não posso analisar isto, mas assim que puder, vou dizendo.

    Cumps
    Sniper2
     
  14. Na boa Sniper2. Não é nada de urgente.
     
  15. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    Usa a ajuda do excel, normalmente podes usar o wizard passo a passo.
    metes = e se reparares aparece um f(x) e 1 uma especie de varinha.
     

Partilhar esta Página