1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Excel

Discussão em 'Windows Desktop e Surface' iniciada por nasty, 23 de Dezembro de 2007. (Respostas: 3; Visualizações: 622)

  1. Ora bem, o meu pai pediu-me pra lhe fazer uma cena e eu tenho andado aqui às voltas e nao consigo resolver isto. Aliás, nem sequer sei se existe algum tipo de função q me permita fazer tal coisa. O problema é o seguinte:


    - Por ex, na coluna L (de L1 até L10) tenho os números 50 até 60, por ordem crescente. Na coluna M (M1 até M10) tenho os numeros 100 a 90, por ordem decrescente. Estas 2 colunas irão funcionar como uma 'tabela', isto é, vao conter valores tabelados. O facto de ser L e M é so 1 exemplo, podiam ser outras quaisquer;

    - A1 e B1 irá ser onde ficarão 2 numeros.

    Pretendo saber como consigo fazer pra pegar no valor que tá em A1, verificar se existe na coluna L e substitui-lo pelo valor correspondente da coluna M.
    Por ex, se o numero fosse o 52.. Ele seria encontrado em L3, e eu queria retornar o valor em M3 (98 neste caso). E fazer exactamente o mesmo para B1 (verificar s existe na coluna L e substituilo pelo valor correspondente da coluna M).

    Nao sei se me fiz entender, de qq maneira se n entenderam qq coisa apitem sff. E desde já obrigado pela ajuda. Abraco
     
  2. Insira a fórmula na célula B1
    =PROCV(A1;L1:M11;2;FALSO)


    Abs
     
  3. Joalgo

    Joalgo Power Member

    Julgo que ele não quer só procurar na célula é na coluna toda, pelo que o teu "L1" será algo tipo "$L$1$L$999" (por 999 entenda-se última linha da coluna que se pretende)

    PS: Não tenho aqui o Excel para experimentar agora.
     
  4. Joalgo

    Joalgo Power Member

    Já consegui verificar:
    =PROC(A1;L:L;M:M)
     

Partilhar esta Página