1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Falha no Update do Ubuntu

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por revolta, 2 de Janeiro de 2007. (Respostas: 4; Visualizações: 1088)

  1. revolta

    revolta Power Member

    Estava a fazer o update para o Ubunto 6.10 pelo comando:

    #sudo aptitude update && sudo aptitude upgrade
    #gksudo "update-manager -c -d "

    deparei me logo com um erro dizendo que nao encontrava a opçao " -c " , tentei o mesmo commando so com a linha "-d " e comçou a fazer os dowloads.
    quando a meio da instalaçao dos pacotes surgiu um erro e a isntalaçao parou.

    agora qundo tento "actualizar o sistema" aparece este erro:
    [​IMG]

    fui ao gestor de pacotos Synaptic tentar reeinstalar os pacotes quebrados, sao eles:
    tangerine-icon-theme
    tango-icon-theme-common
    ubuntu-desktop

    quando os tento Reinstalar aparece me o seguinte erro:
    [​IMG]


    como posso resolver isto e actualizar correctamente o Ubuntu?
     
  2. hellaxe

    hellaxe Power Member

    Quais os repositórios que estás a usar?
     
  3. revolta

    revolta Power Member

    Ubunto 5.10 (Fonte) suportado oificilamente, restricted, universe
    Ubuntu 6.06 LTS update (binario) ( Todos os componentes)
    Actuaçizaçoes do Ubuntu 5.10 (fonte) (main restricted)
    Ubuntu 6.06 LTS (binario)( Todos os componentes)
    Ubuntu 5.10 backports (bin) ( Todos os componentes)
    Ubuntu 5.10 backports (fonte) ( Todos os componentes)
    Actuaçizaçoes segurança ubuntu 5.10 (main restrict)
    ubuntu 6 .06 LTS securty updates (bin ) ( Todos os componentes)
    Actualizaçoes segurança ubuntu 5.10 (universe)

    ufff...acabou:P lolol

    sera preciso alterar todas de modo a ficarem com todos os componentes?
     
  4. hellaxe

    hellaxe Power Member

    Só precisas de ter os repositórios do Dapper - 6.06 LTS.
    Eu uso os do darkstar e e da UMinho, que creio que estão algures pelas threads do Dapper e do Edgy-6.10.

    Agora aconselho-te a fazer o seguinte: metes uma sources.list limpa, só com os repositórios do Dapper. Depois faz esse comando.

    Comigo nunca funcionou decentemente, já com pessoal daqui do fórum esteve perfeito.
    Se não funcionar e quiseres arriscar:
    Metes a sources.list só com os repos do Edgy-6.10.
    Código:
    sudo apt-get update
    sudo apt-get upgrade
    Rezar para que fique certinho:x2: .

    Se quiseres por tudo certinho é fazer uma fresh install, no caso de nenhum dos métodos acima descritos darem certo.

    Agora vou chonar. Alguém ajude o rapaz se ele estiver enrascado.
     
  5. revolta

    revolta Power Member

    jaaa rulaaa!!

    deve ter havido ***** conflito entre os repositorios, foi logo a 1º;)
    thanks Hellaxe!!

    e dorme bem! eheheh

    cumps
     

Partilhar esta Página