1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Flash - Problema com loadmovie()

Discussão em 'Web Development' iniciada por holografix, 22 de Julho de 2008. (Respostas: 1; Visualizações: 564)

  1. holografix

    holografix Power Member

    Viva

    Não conheço a fundo o funcionamento do Flash mas preciso de resolver um problema que envolve uma reorganização dos ficheiros/directorios existentes.
    Neste momento na raiz do site existe um ficheiro main.swf que carrega, através da função loadmovie()/loadmovienum(), mais 3 ficheiros swf (sub1.swf, sub2.swf, sub3.swf).
    Neste momento os ficheiros swf estão na pasta raiz junto do index.php e tudo funciona correctamente.
    Terá agora de ser criada uma pasta "flash" para onde serão movidos os ficheiros swf. No index.php a alteração foi apenas a localização do ficheiro main.swf que passou a ser http://www.exemplosite.com/flash/main.swf. O problema é que o ficheiro main.swf não carrega os restantes ficheiros. Os ficheiros foram apagados e criados de novo na nova pasta mas apenas aparece a área onde o conteúdo flash deveria ser exibido. Se os ficheiros estiverem na raiz do site não há problemas.
    Alguém poderá dar alguma dica sobre o possivel problema e solução?

    Cumprimentos
    holo
     
  2. BytesBR

    BytesBR Power Member

    Após vários tópicos com muito conteúdo achei um em que eu possa ajudar, bem...

    Flash não é bola de cristal, ele precisa ao menos que tenha o no "main.swf" o link direcionando a pasta, mas como isso eu não sei muito e nem sei se há como ter uma função que faça isso melhor pensar em deixar tudo na mesma pasta, se der use a "gambiarra" de html no flash, direcione os links em cada sessão e veja se funcionou, caso ao contrário melhor esquecer daquela pasta.
     

Partilhar esta Página