1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Formula Excel

Discussão em 'Windows Desktop e Surface' iniciada por Cavaleiro, 6 de Janeiro de 2007. (Respostas: 2; Visualizações: 685)

  1. Bom dia para todos os techzones.
    Precisava de uma ajuda para uma formula do excel é que só consigo resolver parte do problema.
    Tenho por exp uma grelha BCPontos %Nota<29,9030 a 37,9138 a 44,9245 a 49,9350 a 54,9455 a 56,9557 a59,9660 a 62,9763 a 65,9866 a 69,9970 ou >10 e pretendo que a cada nota da coluna B corresponda a nota respectiva na coluna C.
    Já tentei com a formula
    (=SE(F61>=70%;"10";SE(F61>=66%;"9";SE(F61>=63%;"8";SE(F61>=60%;"7";SE(F61>=57%;"6";SE(F61>=55%;"5";SE(F61>=50%;"4";SE(F61>=45%;"3";"2"))))))))
    mas ficam-me a faltar as notas 1 e zero. Alguem me consegue ajudar?
    O meu obrigado
     
  2. A grelha não ficou e condições vou colocar os valores sem a grelha:

    A B

    <29,9 0
    30 a 37,9 1
    38 a 44,9 2
    45 a 49,9 3
    50 a 54,9 4
    55 a 56,9 5
    57 a 59,9 6
    60 a 62,9 7
    63 a 65,9 8
    66 a 69,9 9
    70 ou > 10
     
  3. news_js

    news_js Power Member

    Completas uma tabela com 3 colunas, sendo a primeira para o limite mínimo, a segunda para o limite máximo e a terceira para a nota.

    Depois usas a fórmula de "Procura Vertical". Se a tabela estiver em A24:C28 a fórmula será deste tipo

    =PROCV(J6;$A$24:$C$28;3)

    J6, por exemplo, contem o valor que vai dar origem à nota.
    $A$24:$C$28 é a localização da tabela, é melhor ficar bloqueada ($).
    O "3" informa que a nota está na terceira coluna da tabela.
     

Partilhar esta Página