1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Fórmulas Excel p/ Determinação da Média

Discussão em 'Windows 7 e anteriores' iniciada por Syriamn, 14 de Agosto de 2008. (Respostas: 7; Visualizações: 4962)

  1. Syriamn

    Syriamn Power Member

    Boas,

    Preciso de uma ajuda e passo a explicar:

    Preciso de uma fórmula que me determine a média de acordo com as células preenchidas, por exemplo:

    De jan a dez a média é, obviamente x/12 mas eu quero que o denominador me considere só a as células preenchidas uma vez que eu só tenho dados até julho queria que o excel me determinasse automaticamente o denominador sem eu estar mês a mês estar a alterar a fórmula da média.

    Deve, com certeza, haver uma fórmula automática para isto.

    Se alguém souber e a puder compartilhar... Dava um jeito que nem imaginam.
     
  2. sportingdan

    sportingdan I'm cool cuz I Fold

    fááááácil :berlusca:

    usa a função "CONTAR.SE" no denominador ;)

    ps: não uso excel há 3 anos :x mas julgo que com esta dica, chegas lá :D
     
  3. Mavors

    Mavors Power Member

    Por defeito o Excel não contabiliza as empty cells para o AVERAGE... Pelo menos do 2003 para cima.

    Que Excel estás a usar?

    Tás a usar a formula AVERAGE ou estás a fazer =SUM(a1:a13)/12 p.ex.?
     
  4. Syriamn

    Syriamn Power Member

    Acredites ou não, não chego lá:confused:, mas não é por não te teres explicado bem, a fórmula é esta:

    =MÉDIA(A1:L1), como é que eu digo ao excel isto:

    "Só consideras como elegível p/ a média os dados introduzidos, independentemente do seu resultado."
     
    Última edição: 14 de Agosto de 2008
  5. Mavors

    Mavors Power Member

    Epah, ainda não percebi mto bem a tua duvida, mas vamos ver se nos entendemos :D

    Imagina a seguinte folha de calculo

    Código:
        A       B       C       D       E       F       G       H
    1  12      23      34               11              13     16
    
    Se eu fizer =MÉDIA(A1:H1) o resultado será 18,166 que é igual à =SOMA(A1:H1) / 6
    em que 6 são o número de valores preenchidos embora haja 8 cells.

    O que tu queres é que essa média contabilize as células vazias ou não? É que se quiseres que contabilize apenas os valores preenchidos o excel já faz isso por defeito...

    Já agora diz-me a versão de excel que usas.
     
  6. Syriamn

    Syriamn Power Member

    OK, a m/ versão é o excel 2007

    o facto é que eu tenho uma folha somente c/ dados linkada para a folha das fórmulas que é a que tenho estado a falar. Assim, tenho dados preenchidos até Julho pelo que de Julho para a frente, na folha dos dados está vazia mas quando linko para a das fórmulas atribuo-lhe o valor de 0 por causa do erro "DIV/0". Se calhar tenho de considerar no contar.se a condição ">0".
     
  7. Mavors

    Mavors Power Member

    Ah, se os dados estão preenchidos a 0 é diferente... claro que ele considera.
    Sendo assim tens que fazer assim:

    =SOMA(A1:A11)/CONTARSE(A1:A11;">0")

    e vê se funciona.

    PS. Não sei se é mesmo CONTARSE pq tenho o Excel em Ingles, mas isso é facil de confirmares.
     
  8. Syriamn

    Syriamn Power Member

    Está OK!!

    Em resposta à questão, a fórmula é CONTAR.SE

    Obrigado
     

Partilhar esta Página