1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Frontpage

Discussão em 'Web Development' iniciada por berto87, 29 de Junho de 2007. (Respostas: 3; Visualizações: 597)

  1. berto87

    berto87 Power Member

    Boas pessoal.

    Criei uma galeria de fotos no frontpage mas quando publico elas não aparecem, aparece aquele simbolo pequeno no canto superior esquerdo, alguém aqui sabe porque é que isso acontece?
    Se alguém puder ajudar...!?

    MC
    Roberto Francisco
     
  2. TosteX

    TosteX Powre Membre

    Deves estar a fazer mal o link para as fotos, provavelmente pões online com o caminho do ficheiro no disco ex: c:\foto.jpg
     
  3. berto87

    berto87 Power Member

    hum...é provável, mas como faço a alteração disso??
     
  4. shello

    shello Moderador
    Staff Member

    Deves usar ligações relativas.
    Imaginemos a estrutura de directorias
    Código:
    Galeria
      +- index.html
      +- fotos
         +- foto1.jpg
         +- foto2.jpg
         +- foto3.jpg
    
    No index.html, as tags <img> teriam de ficar
    Código:
    <img src="fotos/foto1.jpg" alt="Foto 1" />
    <img src="fotos/foto1.jpg" alt="Foto 2" />
    <img src="fotos/foto1.jpg" alt="Foto 3" />
    Isto seriam caminhos relativos, pois estão relativos à localização do ficheiro onde são chamados. Se movesses esta directoria Galeria para outro local qualquer, continuaria a funcionar, pois ele vai chamar as imagens que estão dentro da directoria fotos que está na mesma directoria que o index.html.

    este link para mais informação sobre caminhos absolutos e relativos.

    Cumprimentos.
     

Partilhar esta Página