1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

GCC-4.0 e Eclipse

Discussão em 'Programação' iniciada por ngm, 4 de Dezembro de 2006. (Respostas: 2; Visualizações: 946)

  1. ngm

    ngm Power Member

    Boas,

    Eu possuo um MacBook e necessito de trabalhar com o Eclipse em projectos C++.

    Portanto, instalei o Eclipse para Mac OS X, instalei o CDT para Mac OS X e, só no fim, instalei o GCC 4.0 para Mac OS X.

    Para verificar a correcta instalação do GCC utilizei o comando "gcc -- version" e deu erro. Entretanto utilizei o comando "gcc-4.0 --version" e correu perfeitamente bem! Ou seja, o compilador é invocado utilizando "gcc-4.0 qq_coisa" e não "gcc qq_coisa".

    O problema é que o Eclipse utiliza apenas "gcc qq_coisa" para invocar os comandos e portanto não encontra o GCC no meu sistema.

    Parece-me que para resolver o problema tenho duas alternativas: mudo a invocação de "gcc-4.0" para "gcc" ou altero todos os comandos no Eclipse (se for possível). Quer uma quer outra... não sei por onde começar.

    Alguém me pode ajudar?
     
  2. TuxBoss

    TuxBoss Power Member

    Devias de haver um alias do gcc-4.0 para gcc.
    Não havendo facilmente mudas isso. Vais a project -> Properties->Compiler(??) e mudas tudo o que tenha a ver com o gcc para gcc-4.0.
    Fácil...
     
  3. ngm

    ngm Power Member

    PROBLEMA RESOLVIDO.

    Obrigado TuxBoss...

    De facto, foi necessário um alias do gcc-4.0 para gcc. Esse alias facilmente se obtém utilizando o comando "sudo gcc_select 4.0" em que 4.0 é a versão do GCC que se pretende utilizar.

    Para mais informações: "man gcc_select".

    Para os meninos do OSX que queiram utilizar o Eclipse, não devem apenas instalar o GCC 4.0 presente nos DVDs de instalação do OSX mas também o Pack Development Tools que contém o utilitário gcc_select, bem como outros indispensáveis ao bom funcionamento do Eclipse como make, cvs,...
     

Partilhar esta Página