1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Gcc + Libc6-dev

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por huntedbyafreak, 13 de Março de 2007. (Respostas: 8; Visualizações: 1373)

  1. huntedbyafreak

    huntedbyafreak Power Member

    Ola,

    Estou a usar o Ubuntu 6.10.
    Uso o Kate para fazer código e o Gcc como compilador. Acontece que na compilação ele nao me esta a detectar as bibliotecas básicas como <stdio.h>. Aparece-me o erro "arquivo ou directório inexistente".

    Quando faço "sudo apt-get install build-essential" aparece-me um erro indicando que "lib6c-dev" nao está instalado nem vai ser instalado. Tentando "sudo apt-get install lib6c-dev" aparece-me o seguinte erro:

    Código:
    libc6-dev: Depende: libc6 (= 2.3.6-0ubuntu20.4) mas 2.4-1ubuntu está para ser instalado
    E: Pacotes estragados
    
    Precisava mesmo de por isto a compilar código... Como resolver isto do libc6?

    http://packages.debian.org/experimental/libdevel/libc6-dev

    Aqui deu-me entendender que este "package" é versao experimental pelo que podem ocorrer problemas de dependencias. A que outros packages posso recorrer de forma a por isto a funcionar?
     
  2. ruimoura

    ruimoura Power Member

    Vê se isto ajuda -

    sudo aptitude update
    sudo aptitude install build-essential

     
    Última edição: 13 de Março de 2007
  3. huntedbyafreak

    huntedbyafreak Power Member

    O libc6-dev continua a nao querer nada comigo...

    Código:
    Os seguintes pacotes estão DANIFICADOS:
      libc6-dev
    Os seguintes NOVOS pacotes serão automaticamente instalados:
      cpp-4.0 dpkg-dev g++ g++-4.0 gcc-4.0 gcc-4.0-base libmudflap0
      libmudflap0-dev libstdc++6-4.0-dev linux-kernel-headers
    Os seguintes NOVOS pacotes serão instalados:
      build-essential cpp-4.0 dpkg-dev g++ g++-4.0 gcc-4.0 gcc-4.0-base
      libmudflap0 libmudflap0-dev libstdc++6-4.0-dev linux-kernel-headers
    0 pacotes actualizados, 12 novos instalados, 0 para serem removidos e 0 não actualizados.
    É preciso obter 10,7MB de ficheiros. Depois de desempacotar serão utilizados 39,6MB.
    Os seguintes pacotes possuem dependências não satisfeitas:
      libc6-dev: Depende: libc6 (= 2.3.6-0ubuntu20.4) mas 2.4-1ubuntu12.3 está instalado.
    Resolving dependencies...
    As seguintes acções irão resolver estas dependências:
    
    Manter os seguintes pacotes na sua versão actual:
    build-essential [Não Instalado]
    g++ [Não Instalado]
    g++-4.0 [Não Instalado]
    gcc-4.0 [Não Instalado]
    libc6-dev [Não Instalado]
    libmudflap0-dev [Não Instalado]
    libstdc++6-4.0-dev [Não Instalado]
    
    A Pontuação é 53
    
    Aceitar esta solução? [Y/n/q?]

    Edit: com isto, ele continua a nao instalar nada das coisas que estao a fazer falta (libc6-dev)
     
    Última edição: 13 de Março de 2007
  4. ruimoura

    ruimoura Power Member

    Pá, já não sei ... Eu aqui no meu sistema tenho o libc6 e o libc6-dev instalados na boa ...

    O que me parece é que ele está a instalar uma versãi do libc6, e depois outr, diferente, do libc6-dev, e daí não haver compatibilidade.

    Aconselhava-te a mudares o teu sources.list para este - http://easylinux.info/wiki/Ubuntu_Edgy#How_to_add_extra_repositories

    Depois tenta desinstalar o libc6, faz update ao sistema e tenta instalar outra vez ...
     
    Última edição: 13 de Março de 2007
  5. CR_

    CR_ Power Member

  6. huntedbyafreak

    huntedbyafreak Power Member

    Ok, ja resolvi o problema. O problema estava mesmo nos repositorios que estava a utilizar. Tinha lá outros repositorios, resolvi mudar para os "default" que vinham com o ubuntu e resolvi o problema...

    Obrigadinho pela ajuda!

    Nao percebo como adiciono os repositorios que estao no site oficial do ubuntu...
    http://easylinux.info/wiki/Ubuntu_Edgy#How_to_add_extra_repositories CR_ dizes que estes nao sao seguros?!
     
  7. ruimoura

    ruimoura Power Member

    Claro que são ... São oficiais ;)
     
  8. CR_

    CR_ Power Member

    O link que tu deste:

    é do Debian (Distro diferente) e isso é que tu não deves usar, pacotes de distros diferentes principalmente em pacotes importantes como esse.

    Esses que tu apontaste no último post são como já disseram os que deves usar...
     
  9. huntedbyafreak

    huntedbyafreak Power Member

    Porreiro!

    Obrigado pelos esclarecimentos!
     

Partilhar esta Página