1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

glib

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por Miguel, 23 de Fevereiro de 2005. (Respostas: 17; Visualizações: 1585)

  1. Miguel

    Miguel Power Member

    oi ppl recentemente instalei o mandrake 10.0 no pc e para alem de muitos outros problemas não consigo instalar o glib :confused: e muitos programas para serem instalados pedem este. agradecia uma ajuda.
    obrigado
     
  2. PrOdG

    PrOdG Power Member

    Que erro te aparece ao instalar o glib ? Sem esses dados é complicado ajudar :)
     
  3. Miguel

    Miguel Power Member

    erro erro não dá mas não fica instalado lol apenas fasso ./configure neste momento ele encontra-se localizado em /opt/glib e não sei mais o que fazer não encontro em nenhum sitio nada que explique o que mais tenha que fazer :(
    ja agora li que normalmente os programas devem ser instalados em /usr/local ou /opt exist alguma diferença entre os 2?
    a mudança do win pro linux ta a ser complicada lol
    thnks
     
  4. xtr3me

    xtr3me Power Member

    A diferença é que uma das directorias está na path e a outra pode não estar, daí, pode-se estar a dar o caso de ele n saber onde está o glib, pq n o encontra, apesar de ele já estar instalado.
    Acho é estranho que a install coloque o glib na /opt e dps a pasta n esteja na path.
    Vê se o caminho está na path (echo $PATH) e se n estiver, adiciona-o (http://www.troubleshooters.com/linux/prepostpath.htm ou http://linux.about.com/od/linux101/l/blnewbie3_1_4.htm, vê o que percebes melhor ;))
     
  5. Miguel

    Miguel Power Member

    o glib ta na opt porque fui eu que coloquei lol vi no how-to do gtk que era para colocar na opt e achei q o glib tambem deveria ser
     
  6. mikan

    mikan Power Member

    Fc3

    Tenta passar para o Fedora Core 3... vais gostar e resolve muitos problemas com as deps dos pacotes.

    Mais tarde sê atrevido e experimenta Gentoo... ;)
     
  7. PrOdG

    PrOdG Power Member

    Presumo que não estejas a tentar instalar a glib apenas com ./configure ?

    O procedimento correcto e mais usual para instalar um programa em Linux é o seguinte:
    Código:
    $ ./configure
    $ make
    <fazer login como root>
    $ make install
    
    Se não for este o caso... ao menos pode ser que o post ajude alguém menos experiente! :D
     
  8. Miguel

    Miguel Power Member

    sim eu sei ja fiz isso tudo mas quando vou a instalar o gtk aparece isto:

    checking for glib-config... /usr/local/bin/glib-config
    checking for GLIB - version >= 1.2.8...
    *** 'glib-config --version' returned 1.2.9, but GLIB (1.2.10)
    *** was found! If glib-config was correct, then it is best
    *** to remove the old version of GLIB. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If glib-config was wrong, set the environment variable GLIB_CONFIG
    *** to point to the correct copy of glib-config, and remove the file config.cache
    *** before re-running configure
    no
    configure: error:
    *** GLIB 1.2.8 or better is required. The latest version of GLIB
    *** is always available from ftp://ftp.gtk.org/.

    :confused: n sei o q fazer.
     
  9. PrOdG

    PrOdG Power Member

    Penso que o problema é teres duas versões do glib instaladas (1.2.9 e 1.2.10). Experimenta correr a tool glib-config de maneira a que esta aponte para a 1.2.10 e não para a 1.2.9 :)
     
  10. Miguel

    Miguel Power Member

    isso é o que me parece também mas não encontro nada :confused: ja procurei no disco todo lol
     
  11. Miguel

    Miguel Power Member

    isto do glib ta complicado :004: lol formatei o disco e voltei a tentar instalar o glib-2.6.2 e o gtk2.6.2 em relação ao glib executei os seguintes comandos:
    ./configure --prefix=/usr/local/glib
    make
    make install

    depois fui a pasta do gtk e fiz:
    ./configure --prefix=/usr/local/gtk

    e apareceu o seguinte erro:

    checking for pkg-config... /usr/bin/pkg-config
    checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0... Requested 'glib-2.0 >= 2.6.0' but version of GLib is 2.2.3

    configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

    pelo que me apercebo ele não detecta a 2.6.2 que instalei o que posso fazer?
     
  12. PrOdG

    PrOdG Power Member

    O problema é que tu estás a instalar as libraries para uma directoria diferente da default e, como te aparece na mensagem de erro, tens de ajustar o PKG_CONFIG_PATH para a directoria que escolheste. Ou então instalas a glib para a directoria default.
     
  13. Miguel

    Miguel Power Member

    hmm e podesme dizer qual é a default? é que eu não sei encontrei o glib-2.0 instalado em /usr/local/include tentei instalar pra aí e deu o mesmo erro ou devo instalar para a pasta glib-2.0?
    em relação ao ajustar o PKG_CONFIG_PATH eu não sei onde o encontro já o procurei por todo o lado e nada :| e quando tento usar o find este craxa.
     
  14. PrOdG

    PrOdG Power Member

    PKG_CONFIG_PATH é uma variável de ambiente, e não um ficheiro que possas procurar. O que te aconselho é tentares instalar tanto o glib como o glib2 (são pacotes diferentes) para as directorias default (que, sinceramente, não sei quais são), usando para isso só ./configure , e ver se fica tudo a funcionar como deve ser :)

    PS: não uses find, faz locate xxxx que é mais simples. Lembra-te é de ir fazendo updatedb como root de vez em quando ;)
     
  15. gnu

    gnu Power Member

    mandrake ... RPM
    ñ há 1 rpm para instalar a glib ?!
     
  16. Miguel

    Miguel Power Member

    thnks plas dicas vou ver o q cnsg fazer so uma coisa updatedb pra que serve? lol
     
  17. Miguel

    Miguel Power Member

    so pra informar quem andar com o mesmo problema que deve-se instalar para /usr e fica tudo bom :)
     
  18. gnu

    gnu Power Member

    updatedb serve para actualizar a base de dados utilizada pelo slocate para procurar ficheiros no disco
     

Partilhar esta Página