GlobalConnectPack c/Ubiquiti IP Alias, PublicIP

Boa noite,

tenho um serviço GlobalConnectPack e, neste momento tenho um router com OpenWRT que está a fazer a parte de receber o IP Publico e o IP Alias, mas eu gostaria de substituir esse router por um router da ubiquiti. Alguém tem a noção +- de como isso se faz ?

Configs OpenWRT:
firewall:

config nat
option name 'MEO SNAT'
option device 'eth0.20'
option src_dip '#IP_Publico'
option src 'wan'
option target 'SNAT'
option snat_ip '#IP_Publico'

network:

config interface 'wan'
option ifname 'eth0.20'
option proto 'static'
option gateway 'IP_Privado'
list dns '1.1.1.1'
list ipaddr '#IP_Publico/32'
list ipaddr 'IP_RouterPrivado/30'

Agradeço qualquer ajuda,
Obrigado
 

At Work

Power Member
Qual é o router que tens da Ubiquiti? Existem duas gamas, UniFi e EdgeRouter.

Terás que criar uma subinterface na interface que liga ao ONT com a respetiva VLAN.

Cumps
 
É um EdgeRouter 12P.

Arranjei solução. Deixo aqui como o consegui.

O problema estava na VLAN, pois o router da Operadora está em bridge, e ele já faz TAG na VLAN20. Sendo assim, tive de configurar o meu na VLAN Default (1) e adicionar os IPs estáticos fornecidos por eles, bem como adicionar ao NAT o Source NAT com o IP Publico fornecido.

hekZaiI.png

lMpjOXx.png
 
Qual é o router que tens da Ubiquiti? Existem duas gamas, UniFi e EdgeRouter.

Terás que criar uma subinterface na interface que liga ao ONT com a respetiva VLAN.

Cumps
Boa tarde,

Estou com o mesmo problema que o @Luis_Filipe6 mas o meu é da linha Unifi. Não consigo configurar o USG com os dados que a Altice me deu para a internet.
Alguém me conseguirá ajudar?
Obrigado desde já
 
GlobalConnect Pack?
Sim,
tenho o ip_internet/32
O WAN Local e o
WAN remoto
mas não estou a conseguir configurar no USG.

Na anterior solução (uma internet normal) tinha o USG em DHCP e o Thompson da MEO em bridge e funcionava lindamente...

Infelizmente não sou propriamente muito entendido em redes, pelo que qualquer ajuda é bem vinda.
Obrigado desde já
 

At Work

Power Member
Sim,
tenho o ip_internet/32
O WAN Local e o
WAN remoto
mas não estou a conseguir configurar no USG.

Na anterior solução (uma internet normal) tinha o USG em DHCP e o Thompson da MEO em bridge e funcionava lindamente...

Infelizmente não sou propriamente muito entendido em redes, pelo que qualquer ajuda é bem vinda.
Obrigado desde já

Não terás um /32 fornecido pelo ISP mas sim, um /30. Um endereço IP será a gateway do router e o outro endereço o IP da interface WAN do teu router.

No teu caso, terás que configurar as VLANs na interface WAN.

Verifica se ajuda:
https://community.ui.com/questions/...-USG-PRO/c77fa909-52a9-42ad-bdee-1fdfa065df0e
https://community.ui.com/questions/USG-WAN-VLAN-setup/72713080-d92a-45b3-9865-e0f9c852a985

Cumps
 
boa tarde, conseguiu resolver o problema? tenho o mesmo problema mas com usg-pro dream machine a linha técnica onde o comprei ninguem sabe como resolver , mas pelos vistos existem mais casos...
 

marco75

Power Member
boa tarde, conseguiu resolver o problema? tenho o mesmo problema mas com usg-pro dream machine a linha técnica onde o comprei ninguem sabe como resolver , mas pelos vistos existem mais casos...
Boas @gaitone , @Luis_Filipe6 , @seassa não sei se vai ajudar... a config abaixo é para fazer o pretendido mas num ERX, o USG e derivados são equipamentos sdn mas se conseguires adaptar ao usg/udm... se calhar editando/criando o ficheiro config.gateway.json com as alteraçoes/personalizações...
https://help.ui.com/hc/en-us/articl...anced-Configuration-Using-config-gateway-json
https://help.ui.com/hc/en-us/articles/115004872967
https://hackviking.com/2020/03/17/unifi-security-gateway-json-config/
https://kx.cloudingenium.com/ubiquiti/unifi/unifi-customize-usg-configuration-config-gateway-json/
Penso que fazendo o que os links acima dizem e com os commandos abaixo é capaz de funcionar. não tenho uma usg para testar, apenas um erx. podes experimentar e verificar se funciona?
NR: é importante ler com atenção a documentação dos links acima para que tudo funcione.

configure
set interfaces ethernet eth0 vif 20 address 100.64.X.Y/30
set interfaces loopback alias address 62.28.X.Y/32

set protocols static route 0.0.0.0/0 next-hop 100.64.X.Y

set service nat rule 5001 description RulePolicyCGNAT
set service nat rule 5001 outbound-interface eth0.20
set service nat rule 5001 outside-address 62.28.X.Y
set service nat rule 5001 protocol all
set service nat rule 5001 type source
commit;save;exit


N.R.: se o router do operador for um technicolor/thompson esquecer:
set interfaces ethernet eth0 vif 20 address 100.64.X.Y/30
set service nat rule 5001 outbound-interface eth0.20

e fazer:
set interfaces ethernet eth0 address 100.64.X.Y/30
set service nat rule 5001 outbound-interface eth0

,
pk como o @Luis_Filipe6 já tinha referido o technicolor/thompson não faz forward da tag correspondente à vlan de dados quando colocado em bridge.
 
Última edição:
Topo