1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Gnome & CentOS

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por asc123, 10 de Julho de 2007. (Respostas: 2; Visualizações: 1861)

  1. asc123

    asc123 Power Member

    Olá a todos, antes de mais parabéns por esta enorme comunidade.:)

    É o seguinte, quero instalar o Gnome como ambiente gráfico num CentOS, quando passo a instalar através do yum o que acontece é o seguinte:

    Error: Missing Dependency: perl-libxml-enno >= 1.02 is needed by package foomatic
    Error: Missing Dependency: perl-libxml-perl >= 0.07 is needed by package foomatic

    Pois bem, eu faço download de ambos e quando tento instalar:

    [[email protected] stuff]# rpm -i perl-libxml-enno-1.02-29.src.rpm
    warning: perl-libxml-enno-1.02-29.src.rpm: V3 DSA signature: NOKEY, key ID db42a60e

    Alguém sabe o que possa ser?

    Abraço
     
  2. xupetas

    xupetas Banido

    faz rpmbuild --rebuild perl-libxml-enno-1.02-29.src.rpm

    e dpx ve ao fim do log onde ele te coloca os RPM's recompilados.
     
  3. asc123

    asc123 Power Member

    rpmbuild --rebuild perl-libxml-enno-1.02-29.src.rpm Installing perl-libxml-enno-1.02-29.src.rpm
    error: Failed build dependencies:
    perl-DateManip is needed by perl-libxml-enno-1.02-29.noarch

    -------------------------------------------------------------------------------------

    rpm -i perl-DateManip-5.44-3.fc7.noarch.rpm warning: perl-DateManip-5.44-3.fc7.noarch.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
    error: Failed dependencies:
    perl(:MODULE_COMPAT_5.8.8) is needed by perl-DateManip-5.44-3.fc7.noarch

    -------------------------------------------------------------------------------------

    rpm -i perl-5.8.8-10.i386.rpm
    warning: perl-5.8.8-10.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
    error: Failed dependencies:
    libc.so.6(GLIBC_2.4) is needed by perl-5.8.8-10.i386
    libdb-4.3.so is needed by perl-5.8.8-10.i386
    rtld(GNU_HASH) is needed by perl-5.8.8-10.i386

    -------------------------------------------------------------------------------------

    já me estou a passar, cada ficheiro diz que precisa de outro
     

Partilhar esta Página