1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Grande problema - Ubuntu não arranca - problema com swap

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por The Dealer, 23 de Março de 2009. (Respostas: 5; Visualizações: 785)

  1. The Dealer

    The Dealer Power Member

    Ora bem, o que eu fiz foi o seguinte:

    Tenho o XP no C, e Ubuntu em ext3 e swap. Fiz um redimensionamento de partição (no windows com o paragon), da ext3, para lhe tirar 1gb para juntar ao swap. Como não consegui fazer Merge, fiz um delete ao swap e voltei a criar. Conclusão. Agora o Ubuntu não arranca :( Em recovery mode, dá-me uma série de erros no arranque algo como "sda3 bad entry e não sei quê"... sda3 acho que é onde está o ubuntu...

    Alguma ideia?
     
  2. The Dealer

    The Dealer Power Member

    Como tinha no fstab o swap montado com o UUID, ele deve ter mudado e é por isso q n dá :(

    arranquei com live cd do ubuntu, mas o blkid não devolve nada... (para ver o UUID actual)

    Quando tento iniciar dá-me sempre erro ext3-fs error. Poderiam-me ajudar por favor?
     
    Última edição: 23 de Março de 2009
  3. Underground909

    Underground909 Power Member

    Arranca com o live cd e faz um fsck -f /dev/sda3 (se for essa a partição que está a dar problemas)
     
  4. The Dealer

    The Dealer Power Member

    Foi de facto isso que eu fiz mas estava demasiado problemático. Preferi perder o amor a duas horas e meia e a um trabalhito ou outro.
     
  5. Underground909

    Underground909 Power Member

    Da próxima experimenta usar o gparted, é de confiança para mexer em partições.

    Já agora o problema não era do swap, mas da partição / que deve ter ficado com erros por alguma razão.
     
  6. The Dealer

    The Dealer Power Member

    Sim, entretanto nas minhas pesquisas tambem tinha descoberto. E sim igualmente em relaçao ao facto da partiçao / que ficou com erros. Não percebo é porque.
     

Partilhar esta Página